CFD Online Discussion Forums

CFD Online Discussion Forums (https://www.cfd-online.com/Forums/)
-   ParaView (https://www.cfd-online.com/Forums/paraview/)
-   -   [OpenFOAM] paraFoam error message on interPhaseChangeDyFoam propeller tutrial (https://www.cfd-online.com/Forums/paraview/211934-parafoam-error-message-interphasechangedyfoam-propeller-tutrial.html)

jcw November 22, 2018 04:53

paraFoam error message on interPhaseChangeDyFoam propeller tutrial
 
Hello!


I am working with the following tutorial:
OpenFOAM-4.1/tutorials/multiphase/interPhaseChangeDyMFoam/propeller


The case runs with 'Allrun', but I face a problem showing the results in paraFoam. When clicking the button 'Apply' in paraFoam, I receive the following error message:


Quote:

ERROR: In /xxx/xxx/OpenFOAM/v410/OpenFOAM/ThirdParty-4.1/ParaView-5.0.1/VTK/IO/Geometry/vtkOpenFOAMReader.cxx, line 4674
vtkOpenFOAMReaderPrivate (0x2fffca0): Error reading line 149 of /xxx/xxx/OpenFOAM/yyyy-2.0.x/run/OF41/propeller/constant/polyMesh/faces: Expected punctuation token ')', found




ERROR: In /xxx/xxx/OpenFOAM/v410/OpenFOAM/ThirdParty-4.1/ParaView-5.0.1/VTK/Common/ExecutionModel/vtkExecutive.cxx, line 784
vtkPVCompositeDataPipeline (0x2fda300): Algorithm vtkPOpenFOAMReader(0x2ffe3a0) returned failure for request: vtkInformation (0x10a1f50)
Debug: Off
Modified Time: 196057
Reference Count: 1
Registered Events: (none)
Request: REQUEST_DATA
ALGORITHM_AFTER_FORWARD: 1
FORWARD_DIRECTION: 0
FROM_OUTPUT_PORT: 0
It also fails when loading a different time step.

The mentioned file ./constant/polyMesh/faces looks like binary code:
Quote:

/*--------------------------------*- C++ -*----------------------------------*\
| ========= | |
| \\ / F ield | OpenFOAM: The Open Source CFD Toolbox |
| \\ / O peration | Version: 4.1 |
| \\ / A nd | Web: www.OpenFOAM.org |
| \\/ M anipulation | |
\*---------------------------------------------------------------------------*/
FoamFile
{
version 2.0;
format binary;
class faceCompactList;
location "constant/polyMesh";
object faces;
}
// * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * //


1639612
(^@^@^@^@^@^@^@^@^D^@^@^@^@^@^@^@^G^@^@^@^@^@^@^@^ K^@^@^@^@^@^@^@^O^@^@^@^@^@^@^@^S^@^@^@^@^@^@^@^W^ @^@^@^@^@^@^@^[^@^@^@^@^@^@^@^^^@^@^@^@^@^@^@"^@^@^@^@^@^@^@&^@^@ ^@^@^@^@^@*^@^@^@^@^@^@^@.^@^@^@^@^@^@^@2^@^@^@^@^ @^@^@6^@^@^@^@^@^@^@:$
^C^@^@^@^@^@^@^N^C^@^@^@^@^@^@^R^C^@^@^@^@^@^@^V^C ^@^@^@^@^@^@^Z^C^@^@^@^@^@^@^^^C^@^@^@^@^@^@"^C^@^ @^@^@^@^@&^C^@^@^@^@^@^@*^C^@^@^@^@^@^@.^C^@^@^@^@ ^@^@2^C^@^@^@^@^@^@6^C^@^@^@^@^@^@:^C^@^@^@^@^@^@> ^C^@^@^@^@^@^@C^C^@^@^@^@^@^@H^C^@^@$
^@^@^@^@^@^@^D
^@^@^@^@^@^@^H
^@^@^@^@^@^@
^@^@^@^@^@^@^Q
^@^@^@^@^@^@^U
^@^@^@^@^@^@^Y
^@^@^@^@^@^@^]
.
.
.

What is going wrong?

jcw December 13, 2018 08:57

Really no idea?

wyldckat December 22, 2018 10:53

Quick answers:
  1. The thread was originally on the main ParaView forum and since is a question regarding paraFoam, there are fewer people there who could try and answer to this issue. And around this time of the year, those who have more knowledge, also have more responsibilities and are fighting to get things done before the holidays and the end of the year. Therefore you were challenging the odds of getting an answer ;)
  2. ParaView 5.0.1 is being used with its internal reader, which was unable to open the case, likely due to a compatibility problem.
  3. My suspicion is that the OpenFOAM 4.1 version you are using is built with 64-bit labels (integers), instead of the more common 32-bit labels (integers). Therefore, the only workaround is to export the case data to VTK format with the utility foamToVTK, or download and install a more recent ParaView version that has a more recent internal reader.

MaySea July 17, 2019 11:39

motorBike tutorial not working
 
Hello everyone,
I am new to OpenFOAM and CFD in general. I have watched and read multiple tutorials though, searched for a solution to the question below for many hours and could not find it.

I'm trying to run the motorBike tutorial in OpenFOAM 6. Firstly, I did it with Allrun, then tried "manually" doing each step. Both attempts ended up in this error, when trying to visualise the project in ParaView:

Code:


In C:\bbd\ecd3383f\build\superbuild\paraview\src\VTK\IO\Geometry\vtkOpenFOAMReader.cxx, line 5463
vtkOpenFOAMReaderPrivate (000002A31F00F6A0): Error reading line 24971 of D:\....\motorBike\constant/polyMesh/faces: Expected punctuation token ')', found

ERROR: In C:\bbd\ecd3383f\build\superbuild\paraview\src\VTK\Common\ExecutionModel\vtkExecutive.cxx, line 782
vtkPVCompositeDataPipeline (000002A32F010C20): Algorithm vtkPOpenFOAMReader(000002A32F3B07C0) returned failure for request: vtkInformation (000002A330273980)
  Debug: Off
  Modified Time: 318329
  Reference Count: 1
  Registered Events: (none)
  Request: REQUEST_DATA
  FORWARD_DIRECTION: 0  ALGORITHM_AFTER_FORWARD: 1
  FROM_OUTPUT_PORT: 0

I checked polyMesh/faces file and it does not look healthy:

Code:

/*--------------------------------*- C++ -*----------------------------------*\
  =========                |
  \\      /  F ield        | OpenFOAM: The Open Source CFD Toolbox
  \\    /  O peration    | Website:  https://openfoam.org
    \\  /    A nd          | Version:  6
    \\/    M anipulation  |
\*---------------------------------------------------------------------------*/
FoamFile
{
    version    2.0;
    format      binary;
    class      faceCompactList;
    location    "constant/polyMesh";
    object      faces;
}
// * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * //


1103393
(                        "  '  +  0  4  8  <  A  F  J  O  S  W  [  `  d  i  m  q  u  z    ƒ  ‡  ‹    “  ˜                                                                  !  %  )  .  3  8  <  @  D  H  L  Q  W  \  a  e  i  m  q  u  y  }    ‡  ‹    “  —  ›  Ÿ                                                            !  &  +  /  3  7  ;  @  D  H  L  P  T  X  \  `  d  h  l  p  t  x  |    †  Š    “  ˜  œ  *      *                                           
            "  &  +  0  4  9  >  B  F  J  N  R  V  Z  _  d  h  l  p  t  x  |  €  „  ‰  Ž  “  —  œ  *                                                 
            "  '  +  /  3  8  <  @  D  H  L  P  U 

[...]

motorBike.emesh file looks similarly. I also wasn't able to visualise mesh after applying blockMesh and snappyHexMesh.

This is the the sequence of commands I'm using, when performing everything manually:

Meshing:

Rename 0 folder 0.org
blockMesh
surfaceFeatures
decomposePar
mpirun -np (number of cores) snappyHexMesh -overwrite -parallel
reconstructParMesh -constant
delete all processor folders
delete folder 0
rename folder 0.org to 0

Simulation:

decomposePar
mpirun -n (number of cores) renumberMesh -overwrite -parallel
mpirun -np (number of cores) simpleFoam -parallel
reconstructPar -latestTime

I copied the motorbike.obj from the geometry resources in FOAM_TUTORIALS. Paraview does not have any issues with the visualization of the object and the file looks OK with all the regions defined inside.

Thank you for any help. Hope I targeted the forum properly.

MaySea July 18, 2019 09:39

Anybody? I feel like I'm missing something easy here.

----

@jcw did the answer provided by @wyldckat work for you?

I'm facing very similar issues, with the most recent version of ParaView and OpenFOAM 6 when executing Allrun for a motorBike tutorial. Did you find the solution?

Cheers.

wyldckat July 18, 2019 19:39

1 Attachment(s)
Quick questions @MaySea:
  1. Which installation instructions did you follow?
  2. In which operating(s) system(s) are you running OpenFOAM and ParaView?
Because from what I can deduce:
  1. Perhaps you built a version with 64-bit labels?
    • You can confirm which label (integer) type you are using with OpenFOAM by running this command:
      Code:

      echo $WM_LABEL_OPTION
  2. It looks like you might be running ParaView on Windows?
    • If you are, then you are likely using the file extension ".foam", then depending on the version of ParaView that you are using, there should be an option for using 64-bit labels, if you have that build of OpenFOAM. For example, see the attached image.

MaySea July 19, 2019 06:59

Hi @wyldckat

1. OpenFOAM was installed by an HPCC admin in my institution.
2. I am running OpenFOAM via HPC cluster with linux installed. The OpenFOAM is using 32-bit labels, as concluded by echoing like you suggested. I'm copying the cases from HPCC Linux to visualize them on a PC Windows, as ParaView can't be installed on HPCC. The ParaView is x64 bit. I am indeed creating the .foam file to visualize them.


I guess that if its the matter of labels like you suggest, the next step will be to consult the problem with the admin. Prob they had these issues before.

What's weird is that I performed other, basic simulations using simpleFoam on the same setup and they worked well. The only difference is that I used some downloaded .stl geometry, not .obj copied from the tutorials.

Thanks for the engagement.

wyldckat July 19, 2019 08:21

Quick answer: Oh, then this might be a problem with the Endianess... what I mean is that the HPC system you are using, might be ordering the values in one way, but on the workstation is uses the other order.


There is an old thread on this topic: https://www.cfd-online.com/Forums/pa...-openfoam.html


You can check the type of Endianess the HPC system is using if you run:
Code:

uname -a
which will tell you the architecture and from there it's possible to look for what type of Endianess is uses.

jcw July 22, 2019 04:50

Quote:

Originally Posted by MaySea (Post 739314)
Anybody? I feel like I'm missing something easy here.

----

@jcw did the answer provided by @wyldckat work for you?

I'm facing very similar issues, with the most recent version of ParaView and OpenFOAM 6 when executing Allrun for a motorBike tutorial. Did you find the solution?

Cheers.


Sorry. I have not been sucessful. It is still not working.

MaySea July 24, 2019 11:41

I checked the endianess. Assuming by default that Windows runs on little endian bytes, there should not be any conflict, as the HPCC linux is little endian too:
Code:

[...] $ lscpu | grep "Byte Order"
Byte Order:            Little Endian

Looking for some other solutions. Will update in case of success...

wyldckat July 25, 2019 19:42

Quick answer @MaySea: Please try running OpenFOAM's tutorial case "incompressible/icoFoam/cavity/cavity" on the HPC system. You only need 1 core, but make sure you launch it in a job and not on the login node. I say this because the login node might be Little Endian, but the HPC nodes might be Big Endian...

But before running the case, check if the file "system/controlDict" has the "writeFormat" line set to "binary" and not "ascii".

You can run the case with this command:
Code:

foamRunTutorials
or with these two:
Code:

blockMesh
icoFoam

Then package the resulting case folder in a ZIP or tar.gz file and attach it to your next post. That way I can inspect the case and confirm what kind of binary data format it's being used.

MaySea July 29, 2019 10:26

@Wyldckat, so...

I just changed the writeFormat in controlDict to ascii from binary and it obviously worked well. When its set to binary its probably the endianess problem, as indeed its the login node which I checked to be little endian, not the batch job nodes.

I don't need a binary format, so changing to ascii solves the problem for me.

Thank you.


All times are GMT -4. The time now is 16:36.