CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Visualization & Post-Processing Software > ParaView

[OpenFOAM] Pls Help- macOS: Could not load Qt platform plugin "xcb"

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   March 5, 2022, 19:44
Default Pls Help- macOS: Could not load Qt platform plugin "xcb"
  #1
New Member
 
Mary
Join Date: Mar 2022
Posts: 1
Rep Power: 0
Marylizzle is on a distinguished road
Hello,

I'm trying to download open foam following the instructions on https://openfoam.org/download/8-macos/

1. Downloaded Docker [successful]
2. Downloaded XQuartz (XQuartz-2.8.1) [successful]
3. Created an openfoam directory to later store pitzDaily [successful]
4. Installed openfoam-8macos (using commands in step 3 on openfoam.org) [successful]
5. Downloaded ParaView-5.9.1-MPI-OSX10.13-Python3.8-64bit.pkg [successful]
6. Launched open foam with ParaView (using commands in step 6 on open foam.org) [successful]
7. Testing openfoam8-macos (using commands in step 7 on open foam.org) [--ERROR--]

Error Faced: When executing the final command paraFoam the following error pops up-

"qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, xcb."

How can I resolve this issue? Any help is appreciated

When I open ParaView from applications it opens but I can't access my openfoam file

About this Mac:
MacBook Air (Retina, 13-inch, 2019)
Processor 1.6 GHz Dual-Core Intel Core i5
Memory 8 GB 2133 MHz LPDDR3
Startup Disk Macintosh HD
Graphics Intel UHD Graphics 617 1536 MB
Marylizzle is offline   Reply With Quote

Reply

Tags
cfd, docker, openfoam, paraview, xquartz

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[OpenFOAM.org] could not load the qt platform plugin "xcb" in "" even though it was found supaol OpenFOAM Installation 11 February 25, 2022 18:37
UDF library trying to load is not compiled for parallel use on the current platform Arjunsajith Fluent UDF and Scheme Programming 10 December 9, 2021 06:47
[General] Building Paraview 4.1.0 with MPI and Python support reynoldsStress ParaView 10 July 27, 2017 08:38
critical error during installation of openfoam Fabio88 OpenFOAM Installation 21 June 2, 2010 03:01
Problems in compiling paraview in Suse 10.3 platform chiven OpenFOAM Installation 3 December 1, 2009 07:21


All times are GMT -4. The time now is 06:12.