CFD Online Discussion Forums

CFD Online Discussion Forums (https://www.cfd-online.com/Forums/)
-   ParaView (https://www.cfd-online.com/Forums/paraview/)
-   -   [OpenFOAM] ParaView command not found (https://www.cfd-online.com/Forums/paraview/61246-paraview-command-not-found.html)

joey September 13, 2006 23:14

ParaView command not found
 
Hi, everyone
I am newbie here, and I just have installed OpenFOAM on my computer.
when I run the cavity tutorial:
paraFoam $FOAM_RUN/tutorials/icoFoam cavity

I got the error message as below:
/usr/local/lib.../bin/paraFoam line 57: praview: command not found

Can anyone help me ?
Thanks a lot!
Joey

mattijs September 14, 2006 05:07

You need to install the paravi
 
You need to install the paraview pack (downloadable from OpenFOAM as well). See the installation instructions.

(I hope that command not found was 'paraview' and not 'praview')

joey September 15, 2006 01:04

I think the "command not found
 
I think the "command not found" comes from the shell and I add a line to $HOME/OpenFOAM/OpenFOAM-1.3/.OpenFOAM-1.3/apps/paraview/bashrc as below:
export PATH=$HOME/OpenFOAM/linux/paraview-2.4.3/lib/paraview-2.4/bin:$PATH.
The problem solved. Thanks a lot.

tunkers August 28, 2010 22:37

I also had the same problem with openfoam 1.7 when installing on Debian Lenny

paraview would run fine when launched manually, but not from paraFoam.
created temporary 'cavity.OpenFOAM'
/home/cfduser/OpenFOAM/OpenFOAM-1.7/bin/paraFoam: 132: paraview: not found

to fix this, edit the following file

/home/cfduser/OpenFOAM/OpenFOAM-1.7.0/etc/bashrc

add this line near somewhere near the top

export PATH=$PATH:/home/cfduser/OpenFOAM/ParaView-3.8.0-Linux-i686/bin

then

$cd
$. .bashrc

Now you will be able to type paraview from anywhere and it will run. Also paraFoam will also be able to launch paraview.

chandra shekhar pant November 6, 2020 10:39

I am not sure, if the following lines are the same or not, but this worked for me:
Code:

export PATH=$HOME/OpenFOAM/xyz-v1906/run/ParaView-5.8.0-MPI-Linux-Python2.7-64bit/bin:$PATH
as been mentioned above these lines should be added in the bashrc and after adding these lines just sourced it using
Code:

source ~/.bashrc


All times are GMT -4. The time now is 15:47.