CFD Online Discussion Forums

CFD Online Discussion Forums (
-   Phoenics (
-   -   Parallel Solver (

Ismael October 9, 2012 15:58

Parallel Solver

I would like to know, how can I run the Phoenics with all core in the same processor?

Any advice would be greatly appreciated.


tommychiu October 9, 2012 22:17

It denpends on your license type. You can contact your vendor.

algin October 10, 2012 14:05

You need to be sure that you have parallel licence. If you can run parallel PHOENICS then you should install MPICH2 and use following line, for example for 2 processes:

%MPICH2%\bin\mpiexec.exe -np 2 -localroot -channel auto %phoenics%\d_earth\d_windf\earexe.exe -par

%MPICH2% and %phoenics% should be correct paths to MPICH2 and PHOENICS on your PC.

Wikie November 26, 2012 12:02


I tried to start phoenics in parallel using a batch file. I want to use 4 processors but I'm alway getting an error telling me:
'c:\program' is not recognized as an internal or external command

this is how my batch file looks like:

cd c:\project\case1
C:\Program Files\MPICH2\bin\mpiexec.exe -np 4 -localroot -channel auto
C:\phoenics\D_SATELL\d_windf\satexe.exe f
C:\phoenics\D_EARTH\d_windf\earexe.exe -par

Does anybody knows how to fix this problem?
MPICH2 is installed proper and my license file is for 4 processors.


Rami November 27, 2012 03:24

Hi Wikie,

It could be due to the blank in C:\Program Files. Try using quotation marks:
"C:\Program Files\MPICH2\bin\mpiexec.exe -np 4 -localroot -channel auto"


algin November 28, 2012 14:36

Hi Wikie,

Change your batch file as
cd c:\project\case1
C:\phoenics\D_SATELL\d_windf\satexe.exe f
"C:\Program Files\MPICH2\bin\mpiexec.exe" -np 4 -localroot -channel auto C:\phoenics\D_EARTH\d_windf\earexe.exe -par

Wikie November 29, 2012 03:12

Hi Algin,

thanks, you solved my problem. Now it's running perfect :)


All times are GMT -4. The time now is 15:39.