CFD Online Discussion Forums

CFD Online Discussion Forums (https://www.cfd-online.com/Forums/)
-   Phoenics (https://www.cfd-online.com/Forums/phoenics/)
-   -   RUN EAREXE IN VR (https://www.cfd-online.com/Forums/phoenics/51735-run-earexe-vr.html)

STK February 17, 2004 17:31

RUN EAREXE IN VR
 
I COMPILED MY CODE IN GROUND AND KNOW I HAVE TO RUN EAREXE BECAUSE RUNEAR READS DEFAULT GROUND. HOW I CAN DO THIS?

THANKS IN ADVANCE

XZ February 18, 2004 09:36

Re: RUN EAREXE IN VR
 
You can do it in VR-Editor as follows:

1) Compile/Ground

2) Build/Earth

3) Options/Run Version/Earth/Private

4) Run /(Solver)Earth

Or from 2), double click the earexe.exe in your working directory after you have saved your file.

By the way ,I must correct your another mistake in your previous question. ...... CALL FN2(RETS,P1,0.0,1.0) should be: CALL FN2(LBNAME('RETS'),P1,0.0,1.0)

the user-defined variable RETS can not be identified directly by EARTH like P1,U1,...


STK February 18, 2004 14:10

Re: RUN EAREXE IN VR
 
THANK YOU

I HAVE TESTED BOTH OF YOUR SUGGESTIONS BUT I ALWAYS RECEIVE AN ERROR OF WINDOWS: VERY LOW VIRTUAL MEMORY. AND NEVER RUNS THE EAREXE.EXE. DO YOU KNOW A WAY OF RUNNING PUBLIC VERSION AND THE AFFECTS OF GROUND TAKE PLACE?? I WOULD BE VERY GRATEFUL TO TELL ME A WAY DIFFICULT OR NOT.

BEST REGARDS

Rami February 19, 2004 03:26

Re: RUN EAREXE IN VR
 
The easiest way to run your private earth would be from the command line rather than the VR. It will probably overcome the problem you experience. You'll find the details how this is done in CHAM's documention. If you already created your earexe, you'll simply need to run it from your working directory (where your q1, eardat etc. reside) by typing

earexe

I hope this helps, Rami

STK February 19, 2004 06:00

Re: RUN EAREXE IN VR
 
thanks i searched and founding nothing in this stupid site cham.co.uk.can you give me the link to see details about running private earth?

best regards

Rami February 19, 2004 06:48

Re: RUN EAREXE IN VR
 
o compile your ground and possibly your main using the supplied script (C:\phoenics\D_EARTH\d_windf\CMPEAR.BAT if you use windows and visual fortran) for compilation or simply using your compiler with appropriate options to compile but not link (df /compile_only /assume:byterecl /debug:none /optimize:3 *.f in my case). this will create ground.obj (and main.obj if needed). NOTE that if you use Visual Fortran in Windows, there are some initialization needed.

o link with the required objects and libraries with the supplied script (in my case it is C:\phoenics\D_EARTH\d_windf\BLDEAR.BAT), resulting in the earexe executable.

I assume the above steps are unnecessary in your case if you have already created your private earth within VR.

o open a command line window.

o change to your work directory where your q1 resides.

o if eardat have not yet been created, run satellite from a command line (runsat).

o run your private earexe from a command line. if it is in a different path, use a relative or full path followed by earexe (e.g., ..\earexe if you use Windows, and earexe is in the parent directory of you working directory).

All the above may be found in TR110 - Loading of PHOENICS Version 3.x Pentium/PC 486/UNIX, either in your local instalation ( C:\phoenics\D_POLIS\D_DOCS\TR110PC.HTM ) or online ( http://www.cham.co.uk/phoenics/d_pol...cs/tr110pc.htm ).


stk February 22, 2004 06:33

Re: RUN EAREXE IN VR
 
THANKS BUT THE PROBLEM INSISTS. DO YOU KNOW IF I CAN INSTEAD OF EAREXE TO USE RUNEAR AND THE AFFECTS OF GROUND TAKE PLACE?


All times are GMT -4. The time now is 02:36.