CFD Online Discussion Forums

CFD Online Discussion Forums (
-   Phoenics (
-   -   Why do the Plant library cases don't work? (

Alumna March 31, 2004 10:29

Why do the Plant library cases don't work?
I work at a project quite complex, and the PIL won't do the work, so I need to use Plant. I tried to open some library cases of this sort [Z136, Z135, Z140, Z122, Z112, Z131 - I guess all the rest have the same problem] but the solver won't start. The message I get in the "Result" file is: "Ground from G13S1&grex3 but no setting made. Please check".

Bearing in mind that library cases are supposed to work without any other setting made by the user, I wonder what is the problem here.

Can you help me, please?

CHAM Technical Support April 15, 2004 09:49

Re: Why do the Plant library cases don't work?
The error message you are reporting will arise if you are using the default earexe.exe (public) rather than the newly-created local earexe.exe (private). If using the VR Environment, this means that you need to click 'options'>'run version'>'earth'>'private', so that the VR Environment will run the private earexe.exe rather than the public earexe.

Alumna June 9, 2004 11:54

Re: Why Plant library cases don't work?
Thank you for your reply, but I tried to run the private version of the Earth, and after I was asked if I want the file "ground" to be build, I got the messaege that it's impossible - it ran out of virtual memory or something. In the mean time I tried to approach my problem by solving it directly into ground, whithout the aid of Plant. After a while [recently] i realized that it's impossible to do it [I seriously lack Fortran programming skills and anyway, Ground can't be compiled after all!].

I humbly ask for your cooperation - what's to do?

Rami June 10, 2004 02:30

Re: Why Plant library cases don't work?
Would you please describe the problem and the needed extra coding? I'll then try to see if I can help. I never used PLANT or the VR, but did a lot of GROUND coding.

Alumna June 10, 2004 11:00

Re: Why Plant library cases don't work?
Thank you very much for your offer, but the Ground coding is useless, since I don't have a recompilable version of the program, isn't it?

This is the problem that I am experiencing in the first place: if Ground is "newer" than Earth, I get the message that I should build it. But when I try to do this, I get the message that it's impossible. All this happens when I run the Private version of earexe, as i was told here. If I use the Public version, the simulation won't go on, due to an "error", and the message in Result is that there's no seeting made in Grex file, though I used Plant to implement the sinks and properties I need.

I get the feeling that my problem has no solution. I tried everything I could, but it's useless. At least I learned so much about Phoenics, I could write my own Lecture about it...

Rami June 12, 2004 04:37

Re: Why Plant library cases don't work?
"... since I don't have a recompilable version of the program ..."

It seems this is the cause: if you cannot compile and build the program with your own coding - created by PLANT or manually coding GROUND - then the private earexe either does not include your addition or is not created altogether. You should have a recompilable version if you wish to add your own modifications.

CHAM Technical Support June 22, 2004 12:08

Re: Why Plant library cases don't work?
PHOENICS V3.5 users with non-recompilable versions can use the new INFORM facility to introduce non-standard sources, properties, boundary conditions, output, etc.

The facility is described here:

Basically, one uses a command language in the Q1 input file to define the required modelling expressions, and these commands are interpreted and used by the PHOENICS Earth CFD solver. Therefore, no FORTRAN compiler is required.

INFORM is an alternative to PLANT and GROUND, and it is very powerful, but the command syntax can become quite challenging for complex modelling requirements.

All times are GMT -4. The time now is 12:41.