CFD Online Discussion Forums

CFD Online Discussion Forums (https://www.cfd-online.com/Forums/)
-   Siemens (https://www.cfd-online.com/Forums/siemens/)
-   -   fortran runtime error while calculating (https://www.cfd-online.com/Forums/siemens/54226-fortran-runtime-error-while-calculating.html)

Anna (aka new-user) December 2, 2004 12:10

fortran runtime error while calculating
 
Hi,

Once upon a time.... one guy was running a calculation and after, say 30 timesteps he got this message:

---- ----------------------------------------------------- TIME STEP NO 34 -----------------------------------------------------

1 1.71E-03 4.34E-03 5.89E-03-7.61E-09-1.95E-01-1.07E-01 8.71E+02 -5.86E-05-1.74E-06 5.36E-05 1.22E+00 9.03E-04 2.60E-04 1.80E+01

2 2.08E+02 1.80E+01

3 4.91E+03 1.80E+01 ? FORTRAN Runtime Error: ? Attempt to read past end of file ? READ(UNIT=20,... ? FORTRAN Runtime Error: ? Attempt to read past end of file ? READ(UNIT=20,... PNP: Saving STAR merged output file "1-12.run". PNP: Saving STAR merged output file "1-12.info". PNP: Saving STAR merged output file "1-12.pstt". PNP: Saving STAR merged output file "1-12.rpo". PNP: Saving STAR master output file "1-12.rsi". PNP: Shutdown [2004-12-02-15:54:44] Execution aborted by request (SIGABRT) after 8476 seconds (TOTAL ELAPSED TIME). 5276.350u 29.310s 2:21:21.35 62.5% 0+0k 0+0io 72140pf+0w

---------------------- so it was run in transient on 2 processors. The calculation crushed, the files were NOT merged and we do not know where is the problem... there was enough disc space, and I cannot think of any other reason.

HELP!

Thanks

a.

Richard December 2, 2004 12:18

Re: fortran runtime error while calculating
 
The unit numbers are given in appendix C of the user guide. It seems unit 20 is the vfs file, the view factors. Did you change the settings somehow and then re-start the analysis without recalculating the view factors? Maybe it's a bug.

Anna (aka new-user) December 2, 2004 12:35

Re: fortran runtime error while calculating
 
Thanks Richard,

hmmm, something has happened. the vfs file disappeared during restart! I will investigate that.

but anyway: how is that possible AFTER some iterations?? shouldn't it report the error immediately after restart?

cheers

a.


All times are GMT -4. The time now is 14:54.