CFD Online Discussion Forums

CFD Online Discussion Forums (
-   Siemens (
-   -   Running HPC (

Shazlan April 8, 2005 05:25

Running HPC

I'm using StarCD v3.22 and Windows XP. I have two question regarding running star parallelly.

1. I'm trying to run my analysis on a single computer with two processors. The .geom and .prob have been written correctly - If I run star sequentially, I face no problem. However, only one processor is utilized if I run star this way. But, when I choose the 'Parallel (Single Host)' option, I received error message as below:

d:\Shazlan\Toilet\2nd Try\toinew_0001>set CDLMD_LICENSE_FILE= d:\Shazlan\Toilet\2nd Try\toinew_0001>REM set STAR="/C/CDadapco/STAR-CD/STAR/3.22.000/windows-x86-absoft_8.2a-dso" root process failed to write port to file FAIL - process exited with code 0

I shut down my anitvirus and Windows XP SP2 firewall and yet, the problem still exist. What should I do next?

2. This time, I want to run star on two computers, which are networked together with 1 processor each computer. I chose the 'Parallel (Multiple Host)' option. However, there's an error saying:

pushd \\acer3\pnp_dir_2005-04-07_16-50-26 Z:\> "\\acer3\star322\lib\loader\star.exe"

Z:\> popd process 2 on Vtc-tr-004 exited without calling MPIFinalize Sending kill commands to launched processes process 0 on Acer3 exited without calling MPIFinalize process 1 on Vtc-tr-002 exited without calling MPIFinalize

What may the problem be?

Helps are highly appreciated! Thanks.

try April 8, 2005 13:34

Re: Running HPC
try to open a STAR-Shell from the starlauncher's help. Launch your parallel job from there according to user-guide chapter 2:

star -dp -mpi-mpich node1,1 node2,2

tip: on windows try to use star shell as much as possible when problems

ps: avoid using spaces in the file names...

All times are GMT -4. The time now is 03:06.