CFD Online Discussion Forums

CFD Online Discussion Forums (
-   STAR-CCM+ (
-   -   Reversed Flow error message when iterating (

bean February 14, 2013 06:57

Reversed Flow error message when iterating
1 Attachment(s)

I am running a fairly simple domain (see pictures), and the mesh has about 1.24m cells.

I have the inlet as a velocity inlet, and all (bar one) wall as a pressure outlet. The end of the pipe is set as a velocity inlet, but currently set to zero.

When it is iterating, it says "reversed flow on xxx walls", particuarly for the top wall and the far wall.

This error is obvious in the residuals plot. I was wondering if anyone knew the cause? Or if it is something I can ignore?!

Thanks for your help

siara817 February 14, 2013 07:17

Do you have this message, after your solution converged?

bean February 14, 2013 07:23

Yes, it starts on the very first iteration and carrys on for the entire solution. It converges but the message is still there.

siara817 February 14, 2013 09:11

I think it is good to try to extrude the outlet, it may solve the problem.
Wait until you get converged and see if you have still some reversed flow.

bean February 14, 2013 14:01

1 Attachment(s)

Thanks for your suggestion. I elongated the outlet (please see picture attached), but I was still getting the same error messages. Do i need to elongate it further?

Are there any other solutions to this that you know of?

Thanks again

siara817 February 15, 2013 08:23

When the solver solves the domian, the pressure should become zero at outlet.
In case that the flow is so low, then it is really hard to avoid reversed flow.
In order to know if the reversed flow has impact on your solution, it is good to check as follow:
After the solution converged, stop the solver, see the value of a property for example temperature in an arbitrary location. Then let the solver to iterate just once. Then check the value of that property at the same location.
If the change is huge then you need to solve the problem of reversed flow and it may be because of your mesh quality.
by the way can you see how is your mesh quality?

bean February 19, 2013 15:22


Thanks for your suggestions. I tried that and I also hadn't specified an inlet boundary layer profile. Once I did that and changed a couple of the regions to be symmetry etc it seemed to work!


All times are GMT -4. The time now is 03:03.