CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > STAR-CCM+

Floating Point Error Segregated flow solver

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree2Likes
  • 2 Post By marmot

Reply
 
LinkBack Thread Tools Display Modes
Old   May 13, 2016, 04:34
Default Floating Point Error Segregated flow solver
  #1
New Member
 
William Fulwood
Join Date: Feb 2016
Posts: 4
Rep Power: 3
willful is on a distinguished road
Sponsored Links
Hi,

I'm trying to model flow from an air vent onto a body and have run into an error when running the solution:

Error: AMG solver diverged.

Error: AMG solver diverged.
A floating point exception has occurred: floating point exception [Invalid operation]. The specific cause cannot be identified. Please refer to the troubleshooting section of the User's Guide.
Context: star.segregatedflow.SegregatedFlowSolver
Command: RunSimulation
error: Server Error

I have tried increasing time step and decreasing the under-relaxation factor for the segregated solver with no luck. This is for a project I must write up soon so any help would much appreciated
willful is offline   Reply With Quote
Sponsored Links

Old   May 13, 2016, 08:57
Default
  #2
Senior Member
 
kevin alun
Join Date: Sep 2011
Location: Germany
Posts: 106
Rep Power: 7
marmot is on a distinguished road
Check your mesh quality,
Make sure cell quality remediation is on your physical models
Check for non-continuous cell groups

Does it happen after the 1st iteration or very soon, than look at initial conditions

if it is happening later, try to monitor things like max velocity or turbulence values and stop the run, create a threshold and examine the mesh in those area,

not so good but you can try, 1st order,

have fun,
Eike and Sandy7 like this.
marmot is offline   Reply With Quote

Old   May 13, 2016, 14:36
Default
  #3
New Member
 
William Fulwood
Join Date: Feb 2016
Posts: 4
Rep Power: 3
willful is on a distinguished road
It was happening after the first iteration however i have reimported the surface mesh and run through the whole process a bit "cleaner" and i seem to have it working now

Thanks for your help though
willful is offline   Reply With Quote

Reply

Tags
floating point segregated

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[ANSYS Meshing] Help with element size sandri_92 ANSYS Meshing & Geometry 13 May 26, 2014 09:05
3d vof Smaras FLUENT 2 February 19, 2013 07:58
mass flow in is not equal to mass flow out saii CFX 2 September 18, 2009 08:07
Gmsh and samplesurface touf Open Source Meshers: Gmsh, Netgen, CGNS, ... 2 December 10, 2007 03:27
Inviscid Drag at subsonic, subcritical Mach # Axel Rohde Main CFD Forum 1 November 19, 2001 13:19

Sponsored Links


All times are GMT -4. The time now is 18:41.