CFD Online Discussion Forums

CFD Online Discussion Forums (
-   STAR-CCM+ (
-   -   zero-area faces, urgent! (

radiatn June 7, 2009 05:07

zero-area faces, urgent!
what to do if we see this message:

Updating interface In-place 2 between Region 1:HX rad core and Region 5 Rad intface:rad core tolerance 0.02
Created 115262 intersection faces (100% of master area, 99% of slave area)
Info: mesh in Physics 1 fluid contains 32 zero-area faces.
Calculating grid flux in region Volume Mesh:Region 4 Cond intface

Shortly after, my run will stop, without passing a single iteration. :mad: It could be due to this zero-area faces but i dont know how to get rid of it. Any help would be appreciated!:cool:

kyle June 7, 2009 10:28

It is unlikely that the zero area faces are causing divergence. You have something else going on.

You can try doing remove invaldid cells with some agressive settings. Do it AFTER you initialize the solution.

radiatn June 7, 2009 20:09

Hi Kyle,

Thanks, I've done that with 10 different settings but still getting divergence error. In the manual it says no problem if single precision but i dont know if by default ccm is set using single or double precision? Do you know how to change to single precision in ccm? (can't find it in the manual).

the error says (wish i could attach picture in this website):

server error: a floating point exception has occurred: floating point exception [divide by zero]. the specific cause cannot be identified. potential cause may include: (a) solution divergence due to poor mesh quality, crude initialization, etc., or (b) errors in user-define code or field functions.

Above is copied verbatim. I dont use user-coding and the mesh is trimmed cells (tried with slow, medium and fast growth rate) with porous and rotating regions. I've tried deleting those porous and rotating regions altogether but same error appeared. Changed the physics to very basic until it makes no physical sense (inviscid and laminar) and still getting same error. Frozen all solvers except segregated flow and that could run it to 1 iteration but at 2 iteration got same eror. Yesterday, i auto-repair the remeshed surface and i got zero errors after auto-repair. The tech support also could not help me much so if anyone has encountered the same problem, please point me to right direction. Been working 4 weekdays and all weekend on this. It's due today.

SKK June 8, 2009 04:24

I have had similar problems a few times. In most of these cases, the only way was to recreate the mesh!!! This was because nothing I did got rid of this error. As a result I got into the habit of saving different stages of the meshing process, so i can always go back to the previous stage if that happens and not have to generate the mesh from the very start. But in some cases I think it is definitely due to bad qulaity cells. I assume you have interfaces. How are you getting rid of the bad cells?

The method I use is to use split by function to remove negative volume cells. After this initiate the solutions. You should get the same error message at this stage. Now you can either delete the solution and decrease the interface tolerance before reinitiatiing or, if the number of bad cells are not many then simply remove these by right clicking on the regions and selecting 'remove invalid cells' WITHOUT removing the solution. The reinitiate the solution. If even after this you get the same error, than unfortunately there is nothing much you can do. But do get in touch with support guyes.

All times are GMT -4. The time now is 14:22.