CFD Online Discussion Forums

CFD Online Discussion Forums (
-   STAR-CCM+ (
-   -   Linux Server + Windows Client = No Connection (

Tu4r3g21 June 25, 2010 02:20

Linux Server + Windows Client = No Connection
Hello everyone,

I'm trying to connect a Client of StarCCM+ 4.04, based on a Windows 7 Pro x64 machine, to a Linux x86_64 Server (same version) without any success. I've already tried it with and without firewalls on both sides, antivirus switched off etc... doesn't work (ping works from both sides).

Can someone tell me please what the trick might be or even that it's just not possible so that i can stop trying to fix it?

Thanks a lot,


olauer June 25, 2010 08:11

Did you tick the Collaboration box or started the server with -collab?

How do you try to connect? With hostname and port number?

Here it works.

Good luck


By the way: you know that it is already 5.02 available and 5.04 in short future?

Tu4r3g21 June 25, 2010 10:12

I've already tried the -collab function without success.
Usually i'm starting the server by command line using a vnc-session with all necessary parameters. On the same machine it is not a big deal to connect a client-session to this server (either by 'connect to server' (using name or ip, i don't even need to set the right port), or just by double clicking on the server that's showing up in the server-window of StarCCM+) but from a different machine there is nothing. Neither a server is showing up automatically, nor any chance to find one by searching with the 'connect to server' function.
i haven't tried it with another windows version nor with another linux. Using two windows machines it is child's play to get it done.

my feeling is, that due to the fact that windows 7 pro doesn't provide the subsystem for unix-based applications as the enterprise or ultimate edition does, it might be impossible to get a connection to a linux-based server.

Oliver, can you tell me about your environment? What Windows-Version which Linux-Distri?

olauer June 25, 2010 10:29

It is very similar here. We have SuSE Linux Enterprise Desktop 10 and Windows XP64. I also cannot see a running process on the server and searching also fails.
But when I connect to the machine and specify the port (by the way, you can specify the port on the server with -port) you get a connection (at least here). And collab must be set, as you usually do not have the same users on Windows and Linux.

Good luck.


Tu4r3g21 June 25, 2010 11:19

Problem solved!! Thank you Oliver! The only thing I did was to click on search, because usually when I accidentally clicked connect, I've received an error message. Trying on purpose to connect to a server that doesn't show up after the search process was something, I haven't dared to due to common sense... 'One cannot connect to something that cannot be found'... not this time :-)
Thanks a lot Oliver! You just made my day! It works like a charm now.

Best regards,


All times are GMT -4. The time now is 19:17.