CFD Online Discussion Forums

CFD Online Discussion Forums (
-   STAR-CCM+ (
-   -   ChoosePixelFormat Failed (

nickninevah April 1, 2011 18:55

ChoosePixelFormat Failed
Hi All

This error started for me right after I upgraded to Star CMM+ 6.02. It happens whenever I have a scene that tries to save to a file. I have three scenes, set to write a picture at every timestep.

A the end of the time step, I received the error message "ChoosePixelFormat failed." Once I clicked OK, the client instance of Star CCM+ immediately shutdown with no other messages or warning. The server process was still running. I had to kill the server process, lose all my work, and start over again.

This has happened every single time that I try to save the scene file. If I turn off the file saving, everything works fine. I've talked to support about it, and they think it is a problem with my video card rendering. Has anyone else had this problem? Anyone know a solution?

System Specs
OS: Windows XP 64 bit Pro
Java: Version 1.6
Star CCM+: Version 6.02
Video Card: nVidia Quadro FX 1700
Card Driver:
CPU: 2 Dual Core Intels

abdul099 April 2, 2011 13:25

Can't you just reconnect to the still running server?

Anyway, you might try to run the simulation in batch mode without a connected client. Does the error still occur?

nickninevah April 4, 2011 18:16

That's the weird part. I can't reconnect to the server. When I open a new client, the server doesn't show.

Good idea about the batch mode. I will give that a try.

nomad April 5, 2011 14:36

This was an issue in 4.06 and they knew about it. I was hoping they had fixed it in later versions.

nickninevah April 5, 2011 21:09


That sucks. Any ideas for a work around. I tried running in batch mode; no luck.

Next I was going to try running with the switch
in the command line. I'm hoping that will help things.

sail April 6, 2011 02:07

try shutting off the hardware acceleration. if this doesn't work try setting up the software to save just one picture per timestep (silly, i know, but i've had problems and that trick sometimes works...)

edit: to turn off the hw acceleration, right click on the desktop, proprieties, advanced, should be somewhere in there...

Eike November 15, 2013 01:31

nickninevah, did that work for you?

I have the same problem with 8.02.008 ... Windows 7, btw.

All times are GMT -4. The time now is 09:08.