CFD Online Discussion Forums

CFD Online Discussion Forums (
-   STAR-CCM+ (
-   -   Converge problem (

siara817 August 12, 2011 04:42

Converge problem
Hi All,
I want to simulate air movements in a room.
I have a converge problem. Also I got this error "BiCGStab did not converge !"
in the residual page, Tdr in k-epsilon diverge. Do you know how to solve the problem?
the surface mesh quality is higher than 0.5 and volume mesh quality is higher than 0.1.
Thanks in advance for your help:)

eRzBeNgEl August 12, 2011 04:53

1. Idea: maybe use 1st order and increase in later steps to 2nd order
2. 2. Idea. Use k-omega SST Model

siara817 August 12, 2011 06:43

Thanks for the reply
I did the ideas. But they did not change the result. I tried other turbulent models but the results were not better than the first one.
Thanks again for your reply

eRzBeNgEl August 12, 2011 07:35

I assume u r running a steady simulation......just give the implicit unsteady a try....

I know this is very general, but maybe it works....

siara817 August 19, 2011 07:16

Thanks for the reply
I tried as you said.
I changed the initial conditions and it improved the convergence, but still I can see some fluctuations after 60 iterations.
I will try to improve the quality of mesh to see if it can influence.
Best Regards

sail August 19, 2011 18:50

increasing the mesh quality is generally a good idea.

you might also try to check where the simulation diverges.

also try to reduce the underrelaxation factors.

eRzBeNgEl August 29, 2011 07:17

well, at least check your geometry and your interfaces. There might be somethwing wrong.....

abdul099 September 3, 2011 07:51

High mesh quality does not mean, the mesh is good for this problem. Is it fine enough?
Is the room closed? I mean, totally enclosed by walls? Do you run compressible or incompressible?

abdul099 November 15, 2011 18:32

Maybe a little bit too late, but it might help other people with the same issue.

It seems, the message just means, the AMG solver for one equation did not reach it's convergence criteria. I would ignore the message as long as the residals don't behave weird and the result is fine.
By the way, it's not critical when a residual goes a little bit up as residuals in Star-CCM+ are normalized.

JBeilke November 15, 2011 19:45

"BiCGStab did not converge !" means, that the calculation stops. So it does not really help to ignore the message ;-)

I got this error when I tried to run an airbag gasgenerator simulation with realgas and a mixture of different species. The only way to overcome the problem was using the coupled solver.

abdul099 November 16, 2011 18:34

It does not mean, the calculation stops. It means only the AMG solver could not reach the convergence criteria within the defined number of steps and the residuals didn't go down anymore. But you don't know anything about the difference. For example, the convergence criteria for the AMG solver is 0.1 (which is the default setting), but it reaches only 0.10000001 within the (default) 30 steps - you will get the "BICGStab did not converge" message, although there's nearly no difference in the solution.

JBeilke November 16, 2011 19:05

At least my testcase stops when I get this error:

"BiCGStab did not converge !
A floating point exception has occurred: floating point exception [Invalid operation]. The specific cause cannot be identified. Please refer to the troubleshooting section of the User's Guide."

abdul099 November 16, 2011 19:57

Yeah, but the reason why it stopped was the floating point exception. That's somehting completely different. A floating point exception always means the simulation stops, and it can also occur without ever using BICGStab.
Also you can get a non-converged BICGStab without getting a floating point exception, that just depends on your physics.

And it doesn't harm to read more carefully. I've written "I would ignore the message as long as the residals don't behave weird and the result is fine."

Paulh November 17, 2011 14:47

Bi Conjugate Gradient Stabilized not converging
The online documentation indicates that BiCon is a solution acceleration method for the AMG solver. Turn it off.

This message started to appear in some of my cases in v6.04 - I haven't made the switch to v6.06 yet. Siara817, what version of the code are you using?

All times are GMT -4. The time now is 23:06.