CFD Online Discussion Forums

CFD Online Discussion Forums (
-   STAR-CCM+ (
-   -   Simulation doesnt start iterating (

saisrikar August 12, 2011 13:41

Simulation doesnt start iterating
Hello there ,

I am running an LES flow simulation around a cylindrical tank. While setting up the turbulence , I choose Reynolds stress + Length scale as a turbulence specification. Where , both are coded as respective field functions. However , If I specify the length scale to be taken from the field function , the solution does not start iterating at all. The length scale has been obtained from a previous simulation where the tank height and domain dimensions were very similar to the current simulation , so instinctively it should work.
If I specify a constant length scale , the simulation starts iterating and solves without a problem.

Just to check , I ran the simulation with SA model by using same length scale field function and it works fine.

Any help on why this is happening and how to fix it would be appreciated.


ping August 14, 2011 22:37

have you plotted the field functions you are using in a scene to ensure they have valid values EVERYWHERE?
have you editing the field functions to be a simple constant and tried this?
might need to add some conditions to the field functions to eliminate invalid values.

saisrikar August 14, 2011 22:39

Well I have checked the field functions by plotting it at the inlet. Everything seems to be all right. What I fail to understand is that it works fine if I solve using SA model , but doesn't start if I use LES

ping August 15, 2011 00:14

I would be quite disappointed if I did not see major differences in both solution stability and results when using SA - a simplistic 1 equation model compared to LES.
If your field function is producing acceptable values, then you either need to start the solution with constant values then change to the f.function after a few or many timesteps, or failing that try ramping in the f.function values - ie the f.function setting might be too sudden for the less stable LES method.

All times are GMT -4. The time now is 23:36.