CFD Online Discussion Forums

CFD Online Discussion Forums (
-   STAR-CCM+ (
-   -   STAR-CCM+ import and export not working (

rks171 December 29, 2011 15:01

STAR-CCM+ import and export not working
I'm using STAR-CCM+ using the server/client architecture with the server being on a cluster and the client being my local machine. I'm having trouble importing and exporting things. For example, when I try to export table data to a .csv file, I get the error:


Error Could not open Table export file /home/blah/...
When I try to export one of my derived parts to a .stl or .vtk file, I get the message:


Exported "line probe" to file /home/blah/blah.vtk
However, when I look in the director for the file, nothing is there. Makes no difference whether I export as .stl or .vtk.

When I try to import a .stl or .vtk file to define an arbitrary probe, the import process seems to go well, but then the arbitrary probe never shows up in the flow region and no data is available when I use the probe to extract raw data from the mesh.

Does this have something to do with the fact that the server is running on a cluster and I'm working on my local machine?

rks171 December 29, 2011 15:20

I went ahead and tried opening starccm+ directly from the cluster so that both client and server are running on the cluster. I opened it through an x window. All import/export functionality worked fine, so it is related to running my client on a local machine that affected the export/import capabilities. As a note, I connected my client to the running server instance of starccm+ by command line:


starccm+ -host localhost:port#
as opposed to starting the starccm+ GUI first and then doing a connection. I couldn't get it to find the host using the GUI method. I think it has something to do with the cluster firewall.

All times are GMT -4. The time now is 19:21.