CFD Online Discussion Forums

CFD Online Discussion Forums (
-   STAR-CD (
-   -   the combustion model problem (

hanshandiaoke November 25, 2011 21:35

the combustion model problem
I want to simulate a diesel sector with the EBU-LATCT+Shell Ignition model. Then I get the sector in prostar from es-ice and change the combustion model. But when I compute the simulation, the combustion model is still the CFM model which is the default choice in es-ice. I think the 'save_ice_after_map' file may contain the CFM information.
So how can I replace CFM model with the EBU-LATCT+Shell Ignition model successfully?
Thank you.

skylent November 26, 2011 01:40

Maybe you can give up to using the starcontrols after starsetup.

hanshandiaoke November 26, 2011 03:43

Hi skylent
I have got your opinion. But the file 'save_ice_after_map' is needed to perform the simulation, which comes from the star controls? How do I deal with this problem?
thank you.

skylent November 26, 2011 04:52

when you operate the"star setup" process, remember to deselect the "use star controls" option, and then you can set the initial condition, boundary condition,combustion model,time step... in prostar.

I also met the same kind of problem,I select ECFM-3Z SI model in "star controls", and the fuel I selected is methane(CH4). However, in prostar, when I check the combustion model, the default fuel identifier for laminar flame speed is isooctane, and after I change it to methane and save the model, the fuel identifier become isooctane again when I reopen the model. It troubles me so much.

hanshandiaoke November 27, 2011 03:08

Hi skylent
I follow your steps, deselect the "star controls" option in the "star setup" panel. But the mistake appeears," The file "save_ice" does not contain the image of an Ice save file.//Error reading from the save file.//Failed.". I think it's about the file Ice. But after I copy this file to my dictionary, the mistake does not change. I'm very confused, expect to get your reply.
Thank you.

skylent November 29, 2011 08:01

I'm sorry for that, but when I use Map method and trim method, it didnot have these problem.

hanshandiaoke November 29, 2011 08:04

Hi skylent
Thank you all the same. I think I must get another way to solve this problem.
Best regards.

skylent December 2, 2011 04:47

Change the Extrusion ratio to -1(not extrude for boundary layer),and remake the mesh.

Because I found these sentence in es-ice userguide:"This new surface will have a one-to-one correspondence with the old boundary surface and its vertices will not be positioned at the correct location. During Star setup with the selected Use Star controls option, the extruded faces will be moved to the correct location."

All times are GMT -4. The time now is 13:39.