CFD Online Discussion Forums

CFD Online Discussion Forums (
-   SU2 Installation (
-   -   Windows 7 binaries that do not require admin priviliges (

jola January 7, 2013 05:24

Windows 7 binaries that do not require admin priviliges
I have tried SU2 on Linux RedHat. I successfully ran through the first tutorial. Looks nice.

I wanted to show a few demonstrations of SU2 to my colleagues at work. To do that it would be nice to have SU2 installed on the Windows 7 computer in the conference room. However, the download currently available for Windows 7 requires a user to have administration rights on the computer. In most larger companies normal users do not have this and we are not allowed to install programs as administrators.

It would be great if it was also possible to download the Windows 7 binaries directly in windows .zip format, so that you can install SU2 in a Windows 7 machine without having administration priviliges.

mcolonno January 8, 2013 00:46

Thanks for your interest in SU^2. The installers provided for Windows require administrator (or at least a user with sufficient privileges to write registry entries) to install since registry values need to be written / modified to allow Windows to manage the installation, allow the program to be uninstalled cleanly, etc. Using .exe files without going through the installation process usually results in the process being blocked by Windows security features (treats these as viruses), especially when trying to run in parallel. In order to change these settings you'd need administrator access anyway. I would recommend requesting temporary installation privileges or contacting an administrator to perform the installation. If this is not possible I am happy to send you a zip file of the executables and you can test your luck with Windows security.

~Mike C.

racime January 8, 2013 15:22

Having the correct rights doesn't mean the program works. None of the launch files work, most of them inform on an error in the: MPI_Op_commutative... pointing to mpich2mpi.dll (that i installed as adviced by the site).

Starting the CFD executable results in an error 0xc000007b, try to reinstall. That didn't work either. This is the second time i tried to install SU^2, also tried an earlier version of the program resulting in roughly the same problems. :mad:

Startet with OpenFoam that seems a bit more complex, but at least works.

pete January 8, 2013 15:41

I just tried to install SU2 on my home computer, which is a Windows 7 64 bit machine where I have full admin rights. I ran into the same problem as you had racime. When I start SU2_CFD.exe I get a system error that says "The program can't start because libiomp5.dll" is missing from your computer." I first had not installed mpich, but I have now also installed mpich, but that didn't help and reinstalling SU2 didn't help either.

The RedHat Linux version works great though.

mcolonno January 8, 2013 16:04

Sorry you're having trouble with SU^2 on Windows. Let's debug from the ground up. The mpich / MPI errors mean that MPICH2 for Windows is either not installed or that the you're not launching it with the executables provided by MPICH2 (mpirun.exe, etc.). To use the parallel version of SU^2 please confirm that MPICH2 1.4p1 for Windows is installed and configured properly, including setting the paths per the MPICH2 documentation. Please run the examples included with MPICH2 before trying SU^2 to confirm that MPICH2 is fully functional. You should not need to do any of this to run the serial versions. If you received MPICH2-related errors running the serial versions please let us know.
The other dll mentioned above (libiomp5.dll) seems to be related to the Intel tools. Please confirm that the Intel libraries (included in the install file) have been installed per the SU^2 installation instructions.
In both cases, please indicate the platform and Windows version you are trying to run.


pete January 8, 2013 16:29

Thanks Michael, now it works. This was just an ignorant user mistake. I should learn to RTFM before posting here. All I had to do was to run "w_ccompxe_redist_intel64_2013.1.119.msi" in the C:\Program Files (x86)\Stanford ADL\SU^2 folder to install the correct Intel redistributables and then the serial version worked perfectly. Perhaps a good idea to let the installer package do this automatically?

racime January 8, 2013 16:38

Well that seemed to work :).

Thank you for the prompt reply.

jola January 8, 2013 16:44

I can use the RedHat Linux version to test SU2 for now. In the world of corporate IT policies it is not that easy to install new programs in the Windows environment. The program needs to be run on a test computer for a period to check that there are no conflicts with other programs. You also need to show a clear need for the code that you want installed for the IT department to even touch it.

A nice example of a code that can be installed as a normal user is Paraview. We ran Paraview for a long time without anyone in the IT dept. knowing about it. Paraview got integrated closely with our own design tools. Now we have got Paraview approved by our IT policy and included as a selectable package to install on all Windows machines. Without the possibility to do some skunk-works and first test Paraview as a normal user this would have been difficult... This is one of the many reasons why we run most of our CFD on Linux, where corporate IT policy is not as strict.

mcolonno January 8, 2013 17:05

Very glad to hear it's working for you. With respect to the Intel redistributable libraries we completely agree and would very much like to simply have the installer do this automatically. However that package is owned & distributed (for free) by Intel and, given that SU^2 is open source, it was not clear if the fine print in the various licenses would allow us to do that. It's 100% OK for any and user to download and install this package themselves but we could not get a clean answer in time as to whether or not it was OK for our installer to do this automatically. I know this sounds silly but we need to follow the rules as well. Hopefully future releases will be able to install this automatically.

~Mike C.

e3lb89cz January 9, 2013 03:50

I think the SU2 Windows binary is compiled by Intel C++ compiler, so some Intel runtime libraries is required. If the Windows binary can be compiled by MS VC++, it may run without any other library.

mcolonno January 10, 2013 18:19

Building with MS VC++ is certainly a possibility. The Intel compiler produces considerably faster executables so we went with the better performance. I believe we will be able to have the Intel redistributable libraries automatically installed in the future so hopefully everything will be insulated from users in the future and only one install will be necessary.

All times are GMT -4. The time now is 07:28.