CFD Online Discussion Forums

CFD Online Discussion Forums (
-   SU2 Installation (
-   -   SU2 running (

ellipsis February 4, 2013 00:30

SU2 running
When I run SU2_CFD.exe, it is not opening and the message says "There is configuration file!""Press any key to exit" I could not find anything in .cfg format in the installation directory. I have downloaded the windows 32 bit version and installed it along with the intel exe installation. But still this error comes. Please help me solve this problem. Is there any place where can i download configuration file??? I could not find it on google.

shirazbj February 4, 2013 00:37

you have to download the testcase and run the program inside a case folder where a cfg file is stored.

ellipsis February 4, 2013 04:46

SU2 running
Thank You very much for your reply! I downloaded test case as u said and tried to open the case inside it but still it is saying no configuration file! do i have to paste the downloaded test case in the home directory??? what is the program to read those cfg files?? It says unsupported format. Please help!

shirazbj February 4, 2013 06:24

cfdivan February 5, 2013 18:16

Did you run it locally? I think that you need to run it in the folder where u have all the files: mesh, setup and .exe.


ellipsis February 6, 2013 00:32


Thank you so much for the tip. But I ran it locally by clicking on the .exe file in the Stanford ADL directory, which also contains my mesh files, test cases ,etc. But still it is showing the same error. Did u get any configuration file while downloading?? should i need to install any other s/w to get it running on my windows?? or shall i try binary version?? Please reply!

shirazbj February 6, 2013 00:52

1 Attachment(s)
You need to read the manual more.

Run in a DOS terminal and speify the cfg file in your command line.

cfdivan February 6, 2013 06:20

Hi ellipsis,

Try in your prompt:
C:\Program Files (x86)\Stanford ADL\SU2\bin>SU2_CFD.exe inv_channel.cfg
Should work.

Just let me know.


zuhier February 25, 2013 03:38

Hi. I'm also a beginner. I managed to run the quick start tutorial but I did'nt get any results!

zuhier February 25, 2013 10:02


I managed to relsove this by my self! The "bin" directory where I run SU2_CFD.exe was in "program files" folder, which is sort of "write protected". Every thing gone well when I copied "bin" to "Documents" and ran the exe from there.

I hope this might help someone.

Thanks all.

malik March 13, 2013 16:29

Hi everyone,

I am using SU2 code for the first time. I want to run it on windows 7 or linux whichever is easy. I have downloaded the test cases, source code that contains trunk folder as well and binary file needed for windows (i am running on 32 bit macihne).

I want to run the ONERA M6 wing and i have also transferred the mesh files and two other from test caes/euler/onera m6 to serial folder in source code but the code is not working, it says that there is a configuration file , press any key to exit. i have also tried to run it on linux (for that i downloaded binary for linux) but there is a permission denied error and tried it with chmod 777 but then again its not working.

Any help will be greatly appreciated
Thanks in advance

All times are GMT -4. The time now is 02:33.