CFD Online Discussion Forums

CFD Online Discussion Forums (
-   SU2 Installation (
-   -   No *.plt or *.vtk output files produced (

Vartan February 20, 2014 13:45

No *.plt or *.vtk output files produced

I have downloaded and installed SU2 3.0, 64 bit binary for Windows 7 (serial version). Initially SU2 would not run due to lack of msvcr100.dll and tecio.dll . I have solved these issues and tried to run the NACA0012 aerofoil test case. The code appears to run, however it does not generate the output files: flow.plt or flow.vtk, surface_flow.plt or surface_flow.vtk irrespective of whether I choose Tecplot or Paraview output file option in the inv_NACA0012.cfg file. I set up a path so that I could run SU2 from a working directory where the grid and *.cfg files are. Is there a default location for the Tecplot or Paraview output files, or should they appear in the working directory? I did try to find them using a search, but this was not successful.

I don't see anyone else having a similar problem, so it may be that I have done something daft... Apologies if this is the case, but hoping someone might have some suggestions. I'm very much looking forward to learning to use SU2.

Kind Regards,


Vartan March 3, 2014 20:36

SU2_EDU V1.1 Windows 64 bit version
In order to try and isolate the source of the problem I downloaded and installed SU2_EDU V1.1 Windows 64 bit version and when run it does indeed produce the flow.vtk and surface_flow.vtk files.

btracey March 11, 2014 16:12

Could you post your config file? Specifically the RESTART_FLOW_FILENAME and OUTPUT_FORMAT


Zen April 24, 2014 10:54

I have the same problem as Vartan. My config file reads as follows:

%Output file format (PARAVIEW, TECPLOT)

% Output file restart flow
RESTART_FLOW_FILENAME= restart_flow.dat

When i run the code, I only get the history.plt file.
The extension of the flow and surface_flow files I get is .dat (flow.dat) and .dat and.csv (surface_flow.dat, surface_flow.csv) respectively.

Any help is welcome,


jehanz May 5, 2015 11:37

SU2 do not produce plot files
I have downloaded most up to date version of SU2 and compiled for parallel. Analysis produce history etc files but no vtk plot files. I tested it on Quick folder with given example and there also it does not produce any plot files. I wonder if there is something I need to do to fix the issue.

jehanz May 5, 2015 16:51

a bit more info on the problem
Interestingly I recompiled the code with no parallel feature i.e. just ./configure instead of ./configure --enable-mpi and then re-ran the Quick folder case. It did produce the plots. Then I ran the rotating airfoil case and it also produced the plots. Finally I ran my particular case and it also dumped the plot files. However, it is sad as it is taking way too longer to process on a single core as compared to what I can do with multi-cores. I wish some one can attend to this unique problem ASAP. Thanks :)

economon May 26, 2015 16:38


In order to avoid overheads when running jobs in parallel, we only output the restart files during runtime. The solutions can then be created using SU2_SOL. Please see more in the documentation here:

Hope this helps,

mdmasood36 October 14, 2016 05:13

Problem generating flow files (.vtk)
As I am new to this blog and SU2, and I am still learning it, and I don't know exactly to post my problem.
when I am running my .cfg file in parallel process its unable to generate the flow files (.vtk). and whenever I run the same .cfg file in single process it works well and creates the flow file perfectly.

SU2_CFD filname.cfg ( converges and generates the flow .vtk files)
mpirun -np 4 SU2_CFD filname.cfg ( this doesn't creates the flow.vtk file, but converges).

can anybody tell me that whats wrong with my parallel processing or is their any problem in my .cfg file to run parallel.

Thank you.

talbring October 18, 2016 02:25

Hi Masood,

SU2_CFD creates the output files only if run in serial. In parallel you have to use SU2_SOL after running the solver to generate these files.

More information can be found here:

(And btw the answer can also be found one post before yours ...)

All times are GMT -4. The time now is 04:40.