CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > SU2 > SU2 Installation

Error in compiling SU2_AD

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   January 9, 2018, 08:08
Default Error in compiling SU2_AD
  #1
New Member
 
Lucia
Join Date: Nov 2017
Posts: 7
Rep Power: 4
lazzini is on a distinguished road
Hello,

I am trying to use the adjoint in SU2 (branch feature_turbo2phase).
I ran the ./preconfigure.py --enable-autodiff, and everything went fine, no errors are displayed.
But when I compile it (sudo make install) there is an error in SU2_AD, I took the screenshot of what I get.

It looks related to the "externals/codi" folder, so I tried to remove it and re-do all the steps, but I get the same error.

Did anyone encounter this problem before?
Attached Images
File Type: jpg Picture2.jpg (115.1 KB, 12 views)
File Type: jpg Picture1.jpg (193.5 KB, 14 views)
lazzini is offline   Reply With Quote

Old   January 10, 2018, 19:15
Default
  #2
Super Moderator
 
Tim Albring
Join Date: Sep 2015
Posts: 184
Rep Power: 6
talbring is on a distinguished road
Hi Lucia,

it seems like you are using an older version (4.6) of gcc to compile the code. For the AD stuff we need at least version 4.7. I am not really familiar with ubuntu, but I am sure there is a way to update the compiler even in older versions of ubuntu. Perhaps you find some information here.

Tim
__________________
Developer Director @ SU2 Foundation

Get involved:
talbring is offline   Reply With Quote

Old   January 11, 2018, 08:20
Default
  #3
New Member
 
Lucia
Join Date: Nov 2017
Posts: 7
Rep Power: 4
lazzini is on a distinguished road
Thanks! 4.7 does not work, but 4.9 yes, problem solved
lazzini is offline   Reply With Quote

Reply

Tags
compilation su2_ad

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[OpenFOAM.org] Compiling OpenFOAM 5.0 on the Titan Supercomputer wildfire230 OpenFOAM Installation 17 August 17, 2018 15:04
Getting error both interpreting and compiling serene6390 Fluent UDF and Scheme Programming 1 October 27, 2017 01:49
All files present. but solver not compiling saddy OpenFOAM Programming & Development 1 July 29, 2017 10:50
[OpenFOAM.org] Trouble Compiling OpenFOAM-dev using Intel Compiler 15 for use on Xeon Phi foamer123 OpenFOAM Installation 9 August 20, 2015 15:03
Help with KIVA4 source code compiling geothokar Main CFD Forum 0 September 3, 2010 06:40


All times are GMT -4. The time now is 16:22.