CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > SU2 > SU2 Installation

macOSX installation issues

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   May 11, 2019, 00:16
Default macOSX installation issues
  #1
New Member
 
Karim
Join Date: May 2019
Posts: 4
Rep Power: 3
fulcrum64th is on a distinguished road
Dear all,

I'm a newbie to SU2. I'm trying a simple build on my MacBook (macOS 10.14.4) but I the warnings when running ./bootstrap :
configure: WARNING: C++ compiler cannot create executables
and
errors during make and make install(see below).

My c++ compiler seems to work i.e. I have Xcode and the command line tools. I can compile normally my c++ codes.

Many thanks in advance for your help! I have runned out of ideas on how to get SU2 to work on my Mac.

Karim



PS: full text of ./bootstrap and errors in make and make install commands
Indaequate Libtool (), building a new one...
Inadequate autotools in your path, I'll build new ones...
building autoconf-2.69 in /Users/karim/Documents/SU2/SU2-6.2.0/externals/autotools
configure: WARNING: the version of M4 that was found does not support -g
configure: WARNING: using it with POSIXLY_CORRECT set may cause problems
Wrote /Users/karim/Documents/SU2/SU2-6.2.0/externals/autotools/autoconf-2.69/lib/emacs/elc.47824/autoconf-mode.elc
Wrote /Users/karim/Documents/SU2/SU2-6.2.0/externals/autotools/autoconf-2.69/lib/emacs/elc.47824/autotest-mode.elc
building automake-1.15.1 in /Users/karim/Documents/SU2/SU2-6.2.0/externals/autotools
configure: WARNING: C++ compiler cannot create executables
configure: WARNING: Fortran compiler cannot create executables
configure: WARNING: Fortran 77 compiler cannot create executables
install-info: warning: no info dir entry in `/Users/karim/Documents/SU2/SU2-6.2.0/externals/autotools/share/info/automake-history.info'
building libtool-2.4.2 in /Users/karim/Documents/SU2/SU2-6.2.0/externals/autotools
libltdl/ltdl.c:1368:14: warning: use of logical '&&' with constant operand [-Wconstant-logical-operand]
if (!file && *sys_dlsearch_path)
^ ~~~~~~~~~~~~~~~~~~
libltdl/ltdl.c:1368:14: note: use '&' for a bitwise operation
if (!file && *sys_dlsearch_path)
^~
&
libltdl/ltdl.c:1368:14: note: remove constant to silence this warning
if (!file && *sys_dlsearch_path)
~^~~~~~~~~~~~~~~~~~~~~
libltdl/ltdl.c:1930:20: warning: use of logical '&&' with constant operand [-Wconstant-logical-operand]
if (!is_done && *sys_dlsearch_path)
^ ~~~~~~~~~~~~~~~~~~
libltdl/ltdl.c:1930:20: note: use '&' for a bitwise operation
if (!is_done && *sys_dlsearch_path)
^~
&
libltdl/ltdl.c:1930:20: note: remove constant to silence this warning
if (!is_done && *sys_dlsearch_path)
~^~~~~~~~~~~~~~~~~~~~~
2 warnings generated.

--> successfully installed autoreconf in /Users/karim/Documents/SU2/SU2-6.2.0/externals/autotools/bin - please update your PATH and try again!

Using autoconf (autoreconf (GNU Autoconf) 2.69)
Using libtool (libtool (GNU libtool) 2.4.2)
Using automake (automake (GNU automake) 1.15.1)
autoreconf: Entering directory `.'
autoreconf: configure.ac: not using Gettext
autoreconf: running: aclocal --force ${ACLOCAL_FLAGS} -I m4
autoreconf: configure.ac: tracing
autoreconf: configure.ac: not using Libtool
autoreconf: running: /Users/karim/Documents/SU2/SU2-6.2.0/externals/autotools/bin/autoconf --force
autoreconf: configure.ac: not using Autoheader
autoreconf: running: automake --add-missing --copy --force-missing
autoreconf: Leaving directory `.'

Make:

Undefined symbols for architecture x86_64:
"double abs<double>(std::__1::complex<double> const&)", referenced from:
CHBDriver::ComputeHB_Operator() in libSU2Core.a(libSU2Core_a-driver_structure.o)
ld: symbol(s) not found for architecture x86_64
clang: error: linker command failed with exit code 1 (use -v to see invocation)
make[1]: *** [../bin/SU2_CFD] Error 1
make: *** [all-recursive] Error 1

Make install

$ make install
Making install in externals
Making install in tecio
make[3]: Nothing to be done for `install-exec-am'.
make[3]: Nothing to be done for `install-data-am'.
Making install in cgns
make[3]: Nothing to be done for `install-exec-am'.
make[3]: Nothing to be done for `install-data-am'.
make[3]: Nothing to be done for `install-exec-am'.
make[3]: Nothing to be done for `install-data-am'.
Making install in Common/lib
make[2]: Nothing to be done for `install-exec-am'.
make[2]: Nothing to be done for `install-data-am'.
Making install in SU2_PY
.././install-sh -c -d '/Users/karim/Documents/SU2/bin'
/usr/bin/install -c continuous_adjoint.py compute_uncertainty.py finite_differences.py mesh_deformation.py parallel_computation.py parallel_computation_fsi.py package_tests.py patient_designspace.py shape_optimization.py merge_solution.py set_ffd_design_var.py compute_polar.py compute_multipoint.py discrete_adjoint.py direct_differentiation.py fsi_computation.py SU2_CFD.py '/Users/karim/Documents/SU2/bin'
.././install-sh -c -d '/Users/karim/Documents/SU2/bin'
.././install-sh -c -d '/Users/karim/Documents/SU2/bin/SU2/io'
/usr/bin/install -c -m 644 SU2/io/config.py SU2/io/config_options.py SU2/io/data.py SU2/io/filelock.py SU2/io/redirect.py SU2/io/state.py SU2/io/tools.py SU2/io/__init__.py '/Users/karim/Documents/SU2/bin/SU2/io'
.././install-sh -c -d '/Users/karim/Documents/SU2/bin/FSI/util'
/usr/bin/install -c -m 644 FSI/util/__init__.py FSI/util/switch.py '/Users/karim/Documents/SU2/bin/FSI/util'
.././install-sh -c -d '/Users/karim/Documents/SU2/bin/SU2/opt'
/usr/bin/install -c -m 644 SU2/opt/project.py SU2/opt/scipy_tools.py SU2/opt/server.py SU2/opt/__init__.py '/Users/karim/Documents/SU2/bin/SU2/opt'
.././install-sh -c -d '/Users/karim/Documents/SU2/bin/FSI'
/usr/bin/install -c -m 644 FSI/__init__.py FSI/FSIInterface.py FSI/PitchPlungeAirfoilStructuralTester.py '/Users/karim/Documents/SU2/bin/FSI'
.././install-sh -c -d '/Users/karim/Documents/SU2/bin/SU2/util'
/usr/bin/install -c -m 644 SU2/util/bunch.py SU2/util/filter_adjoint.py SU2/util/lhc_unif.py SU2/util/misc.py SU2/util/mp_eval.py SU2/util/ordered_bunch.py SU2/util/ordered_dict.py SU2/util/plot.py SU2/util/polarSweepLib.py SU2/util/pyCppTap.py SU2/util/switch.py SU2/util/which.py SU2/util/__init__.py '/Users/karim/Documents/SU2/bin/SU2/util'
.././install-sh -c -d '/Users/karim/Documents/SU2/bin/SU2/mesh'
/usr/bin/install -c -m 644 SU2/mesh/adapt.py SU2/mesh/tools.py SU2/mesh/__init__.py '/Users/karim/Documents/SU2/bin/SU2/mesh'
.././install-sh -c -d '/Users/karim/Documents/SU2/bin/SU2/eval'
/usr/bin/install -c -m 644 SU2/eval/design.py SU2/eval/functions.py SU2/eval/gradients.py SU2/eval/__init__.py '/Users/karim/Documents/SU2/bin/SU2/eval'
.././install-sh -c -d '/Users/karim/Documents/SU2/bin/FSI/io'
/usr/bin/install -c -m 644 FSI/io/__init__.py FSI/io/FSI_config.py '/Users/karim/Documents/SU2/bin/FSI/io'
.././install-sh -c -d '/Users/karim/Documents/SU2/bin/SU2/run'
/usr/bin/install -c -m 644 SU2/run/adaptation.py SU2/run/adjoint.py SU2/run/deform.py SU2/run/direct.py SU2/run/interface.py SU2/run/merge.py SU2/run/geometry.py SU2/run/projection.py SU2/run/__init__.py '/Users/karim/Documents/SU2/bin/SU2/run'
.././install-sh -c -d '/Users/karim/Documents/SU2/bin/SU2'
/usr/bin/install -c -m 644 SU2/__init__.py '/Users/karim/Documents/SU2/bin/SU2'
Making install in SU2_CFD/obj
CXXLD ../bin/SU2_CFD
Undefined symbols for architecture x86_64:
"double abs<double>(std::__1::complex<double> const&)", referenced from:
CHBDriver::ComputeHB_Operator() in libSU2Core.a(libSU2Core_a-driver_structure.o)
ld: symbol(s) not found for architecture x86_64
clang: error: linker command failed with exit code 1 (use -v to see invocation)
make[1]: *** [../bin/SU2_CFD] Error 1
make: *** [install-recursive] Error 1

Last edited by fulcrum64th; May 12, 2019 at 06:33.
fulcrum64th is offline   Reply With Quote

Old   May 26, 2019, 22:34
Default Custom GCC on MacOSX
  #2
Member
 
Peter Brady
Join Date: Apr 2014
Location: Sydney, NSW, Australia
Posts: 54
Rep Power: 8
pbrady2013 is on a distinguished road
Hi Karim,


A little late but did you get this working?


On my mac I've found better results than the native CLANG in setting up a custom environment based on GCC 8.1.0 and OpenMPI 3.1.


Quickly glancing through your log your build fails at compile time so the make install section will definately fail.



Cheers,
-pete
pbrady2013 is offline   Reply With Quote

Old   May 29, 2019, 12:14
Default
  #3
New Member
 
Pablo Garrido
Join Date: May 2019
Location: Netherlands
Posts: 7
Rep Power: 3
pgdelaserna is on a distinguished road
Hi Karim,

I went through similar errors and, as Pete says, I finally could run SU2 by installing GCC compiler via Homebrew, then building OpenMPI pointing to the gcc compiler and finally building SU2 pointing to that OpenMPI compiler (which, btw, my version of OpenMPI is 4.0.1)

Regards,
Pablo
pgdelaserna is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installation issues on Ubuntu 13.10 Jeggi enGrid 13 February 8, 2017 14:00
[swak4Foam] installation issues with foamextend3.2 srivatta OpenFOAM Community Contributions 2 January 22, 2017 12:51
[foam-extend.org] issues with extend-3.2 installation on ubuntu CjjJoy OpenFOAM Installation 0 July 18, 2016 08:58
Installation issues for parallel computation Akash C SU2 Installation 1 June 21, 2013 05:26
OpenFOAM 15 and CentOS 52 installation issues remrich OpenFOAM Bugs 9 March 20, 2009 01:48


All times are GMT -4. The time now is 15:00.