CFD Online Discussion Forums

CFD Online Discussion Forums (https://www.cfd-online.com/Forums/)
-   SU2 Installation (https://www.cfd-online.com/Forums/su2-installation/)
-   -   Errors in installing SU2_AD part, maybe about the MKL (https://www.cfd-online.com/Forums/su2-installation/219279-errors-installing-su2_ad-part-maybe-about-mkl.html)

yuezehua July 22, 2019 05:59

Errors in installing SU2_AD part, maybe about the MKL
 
hi there,
i successully installed basic SU2 parts, such as SU2_CFD, SU2_DOT, SU2_MSH, then i tried some examples, they all run successfully.
However, when i trying to install SU2_AD by command :
Quote:

export CXXFLAGS="-O3 -Wall" && ./preconfigure.py --enable-autodiff --enable-mpi --prefix=/opt/software/su2
it works with showing me environment variables in the end, but when i typed:
Quote:

make install SU2_AD
there were many errors, and no file with "_AD" ending in my /su2/bin,so the installion failed.
After checking "conf_SU2_AD.err", it said:
Quote:

grep: /opt/intel/icc/composer_xe_2013.3.163/mkl/include/mkl_version.h: No such file or directory
../configure: lin 6415: [: : integer expression expected
Does this mean that I`m using a wrong MKL? So all the friends here, if you have installed SU2_AD sucessfully, please tell me your MKL version, thanks a lot !!

besides,my gcc version is 4.8.2, and my openmpi version is 3.0.3.

yuezehua July 22, 2019 22:03

Problem solved!
 
I updated my gcc to v6.3.1, then everything runs well!
Besides, my openmpi version is 3.0.3.


All times are GMT -4. The time now is 02:24.