CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > SU2

Mesh deformation in 3D using SURFACE file

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   May 29, 2019, 12:08
Default Mesh deformation in 3D using SURFACE file
  #1
New Member
 
Pablo Garrido
Join Date: May 2019
Location: Netherlands
Posts: 7
Rep Power: 3
pgdelaserna is on a distinguished road
Hi all,

I'm currently using SU2 version 5.0.0 (feature_turbomachinery) and I am interested in using the SU2_DEF module to deform a .su2 mesh corresponding to a 3D axial turbine blade that I already have. For that, I generate a MoveSurface.txt file which includes the identifiers and the new coordinates (x, y and z) of the deformed mesh points.

I've prepared a configuration file where I set DV_KIND to SURFACE_FILE and DV_MARKER to the surface that I want to move (in this case the blade surface) but found a very strange behaviour of the mesh deformation: it successfully deforms the surface (as shown in the pictures named as surface_grid_*, where the deformed grid is in red and the original one in black), but, when checking the volumetric grid, it seems that only the first cell next to the surface is moved while this movement it is not transmitted to the rest of the cells (as can be checked in the figures volumetric_grid_deformed and volumetric_grid_both).

The case that I'm running corresponds to a 3D axial turbine blade, where the upper and lower surfaces of the mesh are walls (hub & shroud) and there is no tip gap, therefore the blade profiles at hub and shroud are contained in the walls.

Thank you very much in advance!


https://i.postimg.cc/bdScpHdp/surface-grid-both-2-D.png

https://i.postimg.cc/HVGGxc75/surface-grid-both-iso.png

https://i.postimg.cc/HVbq7YQN/volumetric-grid-both.png

https://i.postimg.cc/mPR0Yvjg/volume...d-deformed.png
pgdelaserna is offline   Reply With Quote

Reply

Tags
mesh deformation, surface, volumetric

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[swak4Foam] funkyDoCalc with OF2.3 massflow NiFl OpenFOAM Community Contributions 11 November 1, 2016 06:43
SparceImage v1.7.x Issue on MAC OS X rcarmi OpenFOAM Installation 4 August 14, 2014 06:42
Trouble compiling utilities using source-built OpenFOAM Artur OpenFOAM Programming & Development 14 October 29, 2013 10:59
Version 15 on Mac OS X gschaider OpenFOAM Installation 113 December 2, 2009 10:23
DxFoam reader update hjasak OpenFOAM Post-Processing 69 April 24, 2008 01:24


All times are GMT -4. The time now is 15:31.