CFD Online Discussion Forums

CFD Online Discussion Forums (https://www.cfd-online.com/Forums/)
-   SU2 (https://www.cfd-online.com/Forums/su2/)
-   -   Gmsh to SU2: NPOIN (https://www.cfd-online.com/Forums/su2/219193-gmsh-su2-npoin.html)

mhollander July 18, 2019 15:16

Gmsh to SU2: NPOIN
 
1 Attachment(s)
Hi All,


I'm attempting to export a grid from gmsh to SU2 and am running into some frustration.



Whenever I try to run SU2, I run into the following error:


Mismatch between NPOIN and number of points listed in mesh file.
Please check the mesh file for correctness.




I have attempted to export from gmsh by checking the 'save all' option and without checking the 'save all' option. Both give me the same error.



I have also attempted a manual check to see if the number of points match up and they seem to...


I have uploaded a .zip with all my files for reference. Note that I have made a relatively coarse grid in this case to make diagnostics easier. If anyone can find a solution to this, I would be very grateful.


Cheers,
Moshe.

TKatt July 21, 2019 16:49

1 Attachment(s)
Hi Moshe,

just add

Code:

Physical Surface("test") = {1,2};
at the end of your .geo file and build the mesh without the saveall option. See https://www.cfd-online.com/Forums/su...r-3d-mesh.html for my answer on what I expect to be same problem, only in 3D instead of 2D.



The name of the physical surface doesn't matter. It wont appear in the final file and you don't need that anywhere in su2. Hence the name "test"



I attached an image as a proof that I could run your mesh ;)
Btw: good that you attached everything to debug and run the case. including the coarsening such that it is fast to reproduce *thumbs up
Btw 2.0: There is an API to pyhton http://gmsh.info/doc/texinfo/gmsh.html#Gmsh-API which would allow you to do everything in python



Hope that helps, Tobi

mhollander July 22, 2019 12:10

Thanks
 
Yup, that seems to have done the trick! Thanks a ton!


All times are GMT -4. The time now is 03:44.