CFD Online Discussion Forums

CFD Online Discussion Forums (https://www.cfd-online.com/Forums/)
-   SU2 (https://www.cfd-online.com/Forums/su2/)
-   -   SU2 crashes while generating output files (https://www.cfd-online.com/Forums/su2/219887-su2-crashes-while-generating-output-files.html)

BenP August 13, 2019 11:56

SU2 crashes while generating output files
 
2 Attachment(s)
Hello, I have a problem where SU2 crashes when generating output files. There is no error message, the simulation just stops. I've attached a screenshot of the command prompt output I get as well as my .cfg file.

I suspect the problem originates from the mesh I am using (generated with gmsh), but if there was something wrong then would SU2 not crash before ever needing to write any output files? Or at least there would be something visibly wrong with the outputs at each iteration?

From setting the WRT_SOL_FREQ option to effectively remove any periodic output generation, I can see that the solution does converge properly, but then crashes on convergence.

The .su2 file I am using can be accessed using this link (it's fairly large so I couldn't directly upload it). https://1drv.ms/u/s!An1_lpfAG0BCg5VQ...WAtyA?e=9T3g85

I am running SU2 6.0.0 in serial on Windows 10.

Does anyone know why SU2 would operate seemingly as it should but only crash when writing the outputs?

Any help is greatly appreciated :)

hk.narahari August 19, 2019 01:48

Same issue of SU2 crashing before writing output files
 
I have been having the same trouble ( as reported a few days back). The code runs OK ( 100 or 1 iteration) but crashes before writing out the files. I too had created the grid in GMSH for 3 different geometries with same issue, hope it gives a clue to the cause of the problem.
Thanks in advance
Narahari

BenP August 19, 2019 11:53

Fixed
 
I managed to find a solution that works for me.

My understanding is that GMSH will automatically duplicate surfaces that need re-orientated after using any of the Boolean commands available with the OpenCascade kernel (I used a lot of these to create the geometry I was using).

My mistake was setting GMSH to "save all elements" when exporting the SU2 mesh, which would inadvertently save the duplicated surfaces as well and subsequently cause SU2 to crash when trying to generate outputs.

By default, GMSH will create an SU2 mesh by only exporting elements that have been assigned to a physical entity.

While I had assigned all the necessary "Physical Surfaces", I hadn't assigned a "Physical Volume" to the main control volume. Once doing this and making sure to leave the "save all elements" box unchecked, gmsh no longer exported the duplicated surfaces and I could run SU2 without any problem.

Hope this helps in some way.

hk.narahari August 21, 2019 04:24

I tried your suggestion for a couple of cases and it worked :). Thanks a lot, I was really stuck because of that bug.
Regards
Narahari


All times are GMT -4. The time now is 12:03.