CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > SU2

Troubleshooting "Could not find NMARK= keyword" Error

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   September 6, 2021, 19:39
Default Troubleshooting "Could not find NMARK= keyword" Error
  #1
New Member
 
Ben Chaback
Join Date: Aug 2021
Posts: 10
Rep Power: 2
chabackb is on a distinguished road
Greetings,

I am attempting to run a cylinder test case that I exported from another CFD software on SU2 to see how the two compare result wise.

When I go to run the file via SU2_CFD I get the error "Error in "void CSU2ASCIIMeshReaderFVM::ReadMetadata()" Could not find NMARK= keyword"

I did what I guessed a logical next step would be and checked my .SU2 mesh file to make sure it was there and it looked good to go and the syntax appears correct.

Any suggestions on troubleshooting this? I have linked my cfg and mesh files at the link below for convenience when looking at the problem. Much of the cfg file values are arbitrary values currently since I am more interested in having the file run in SU2 successfully then having all the parameters functional currently.

https://drive.google.com/file/d/1s4Z...ew?usp=sharing

Thanks for the help with this, if I forgot any info that would be beneficial to know please let me know.

Technical Info:
OS: Windows 10
SU2 Version: 7.1.1 Blackbird
Mesh File: Cylinder_Mesh2.su2
Configuration File: Cylinder.cfg
Operation Running: SU2_CFD
Running on Virtual Machine OS Ubuntu 18.04.5
chabackb is offline   Reply With Quote

Old   November 3, 2021, 12:45
Default
  #2
New Member
 
Moshe Hollander
Join Date: Dec 2018
Posts: 14
Rep Power: 4
mhollander is on a distinguished road
Did you ever end up resolving this issue?
mhollander is offline   Reply With Quote

Old   November 9, 2021, 10:38
Default
  #3
New Member
 
Ben Chaback
Join Date: Aug 2021
Posts: 10
Rep Power: 2
chabackb is on a distinguished road
Greetings,

Thanks for the reply. Unfortunately neither myself nor the professor I am working with have been able to troubleshoot and solve this issue yet.

Any suggestions or ideas you have on it would be greatly appreciated!
chabackb is offline   Reply With Quote

Old   November 9, 2021, 11:02
Default
  #4
New Member
 
Moshe Hollander
Join Date: Dec 2018
Posts: 14
Rep Power: 4
mhollander is on a distinguished road
I'm not entirely sure that I have gotten right to the bottom of the issue (like yourself, the syntax of my mesh appeared to be fine, at least at first glance...).


I have however managed to get the code to finally run.



I was making my mesh in GMSH.


Regarding the mesh that wasn't working, I hadn't defined the 'flowfield' surface as a named physical group. When I did so, the resultant mesh was fine and ran properly on SU2.


Let me know whether or not that clarifies things. If not, I'll take some screenshots of what I did.
mhollander is offline   Reply With Quote

Old   November 9, 2021, 12:15
Default
  #5
New Member
 
Ben Chaback
Join Date: Aug 2021
Posts: 10
Rep Power: 2
chabackb is on a distinguished road
Interesting, thanks for the reply.

I am using EnGrid for my meshing but I wonder if that is the issue I am running into as well.

I am not currently at a computer but I'll give that a look when I get to my desk and reach out with if that fixed the issue or not.

Appriciate the help!
chabackb is offline   Reply With Quote

Reply

Tags
cylinder flow, nmark, su2 7.1.1

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Undeclared Identifier Errof UDF SteveGoat Fluent UDF and Scheme Programming 7 October 15, 2014 08:11
Compiling dynamicTopoFvMesh for OpenFOAM 2.1.x Saxwax OpenFOAM Installation 25 November 29, 2013 06:34
Problem Building OF on Centos cluster (no admin rights) CKH OpenFOAM Installation 5 November 13, 2011 07:32
CGNS lib and Fortran compiler manaliac Main CFD Forum 2 November 29, 2010 07:25
user subroutine error CFDUSER CFX 2 December 9, 2006 07:31


All times are GMT -4. The time now is 15:42.