CFD Online Discussion Forums

CFD Online Discussion Forums (
-   Tecplot (
-   -   Trying to use tecplot to visualize my result (

boilermaker October 29, 2010 13:07

Trying to use tecplot to visualize my result
Dear all,

I want to output my calculation result to binary tecplot data using functions provided by tecio64.a on Linux platform.

I included the "libraries" and "include" under tecplot directory in my makefile. But I still get error messages like "undefined reference to tecini112." It seems I still fail to use the library tecio64.a.

Could anyone tell me what shall I to to use the library functions such as tecini, tecdat, etc.?

Thank you very much!

juaneco2710 June 30, 2012 19:22

same problem

I'm new using Linux (Ubuntu 12 LTS, 32-bit). I am also new at using Tecplot360. I am having the same problem. I wonder if anyone knows how to solve it.

I've been trying to compile the example file simtest.f90, using this two commands:

1. f95 -fcray-pointer -lstdc++ simtest.f90 tecio.a
2. f95 -fcray-pointer simtest.f90 tecio.f90

In the first case, I get a huge list of errors such as this:
./Tecplot360/util/tecio.a(TranslatedString.o):(.gnu.linkonce.d._ZTIN 7tecplot7strutil16TranslatedStringE[typeinfo for tecplot::strutil::TranslatedString]+0x0): undefined reference to `vtable for __cxxabiv1::__class_type_info'

In the second case, I get that tecio.f90 stopped unexpectedly.

kcengiz September 12, 2012 10:14


Originally Posted by juaneco2710 (Post 369055)

1. f95 -fcray-pointer -lstdc++ simtest.f90 tecio.a
2. f95 -fcray-pointer simtest.f90 tecio.f90


change the order of the libraries when linking. Try:
f95 -fcray-pointer simtest.f90 tecio.a -lstdc++
That is, -lstdc++ should come after tecio.a

By the way, I wonder why there is such duality: is it tecini or tecini112 function?? what is the difference? I used tecini, tecend, etc (without '112'), everything worked fine.

scott_rumage September 13, 2012 11:06

The "112" refers to a version number of the Tecplot TecIO utility. If memory serves me correctly "112" was released in 2006. The TecIO commands without this number extenstion are older. Using the latest TecIO commands can be helpful as the complexity of one's grid (polyhedral, etc.) and/or data increases.

One can create a binary Tecplot file with the older version of TecIO, and it should be readable by current versions of Tecplot.

For the TecIO version appropirate to your version of Tecplot go to the computer where you have Tecplot installed and look in the "doc/bin" folder.


kcengiz September 17, 2012 09:38

i've just tried tecini112 etc. instead. it did not work, though. i use tec360 2010 64 bit version which I just downloaded tecio64.a from tecplot download page. it was said to be 2009 released 64 bit tecio library.
I presume they removed "112" from the functions in 64 bit versions. 64 bit versions should be already new after all. that is, people started to use 64bit computers after 2006.
is my assumption correct??

kcengiz October 8, 2012 04:05

I think the answer is that I bind tecio from fortran. I don't need to include tecio.h nor do I need to use 112 suffix. I just utilized the library just as described in the link

kcengiz October 8, 2012 04:08

I guess the answer is that I use fortran to call the library functions. I don't need to include tecio.h nor do I need to add "112" suffix. I just utilized it as described in the link

ssrobins October 16, 2012 17:03

It looks like you probably already have a solution, but here are the steps to getting the simtest fortran script running on Ubuntu 12.04 32-bit:

Download the simtest.f90 and tecio.f90 source files from here:
Download the proper TecIO library. For 32-bit Linux it would be this:

For modern 64-bit Linux (Ubuntu 8/10/12, CentOS 5/6, Red Hat 5/6, SUSE 11/12), I recommend this:

Run the following command to install FORTRAN and C++ compilers:
sudo apt-get install gfortran g++

Run this commend to build:
gfortran -fcray-pointer simtest.f90 tecio.a -lstdc++
NOTE: The order of the -lstdc++ flag matters for gfortran in Ubuntu 12. I recall it didn't matter previously

Run this command to run the program and generate the .plt file:

All times are GMT -4. The time now is 12:39.