CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   ANSYS Meshing & Geometry (http://www.cfd-online.com/Forums/ansys-meshing/)
-   -   [ANSYS Meshing] Issues with ANSYS Meshing for a raceway geometry (http://www.cfd-online.com/Forums/ansys-meshing/116333-issues-ansys-meshing-raceway-geometry.html)

wangnbangn April 17, 2013 05:24

Issues with ANSYS Meshing for a raceway geometry
 
Hello All,

I need a little help with a problem that I have when meshing a closed raceway pond, seen below:

http://i.imgur.com/UHi76E2l.png

I made the mesh using the multiblock method on all the bodies and with only hexahedral elements, with edge sizing to get the boundary layers I need.

Everything is nearly all and well, except for the area where the bends meet the straights:

http://i.imgur.com/P8Qpg5Al.png

There is an unacceptable jump in size between the straight section and 180 bend that I have been unable to fix. I also get mesh sizing errors when I try to place the first node of the boundary layer 10^-5 m away from the walls in the 180 bend area, so that is a problem for me as well.

Here's the cross section:

http://i.imgur.com/x5jesHWl.png


I have been working in ICEM to see if I can fix both problems there, but so far have been unable to generate a similar mesh at the bend at all (the workflow is completely different), so suggestions for that would be appreciated.

Thanks!

Far April 17, 2013 05:42

In ICEM you can copy the spacing from the adjacent edge. Also in ANSYS try to control the edge meshing parameters.

jrunsten April 17, 2013 09:01

If you want to keep it all Hex, and matching at both the inner and outer radius you will need to use some biasing. I created the example below pretty quick. I guess with your longer straights the distortion of the elements will be less bad.

Basicly I set an edge sizing on the inner and outer edges with the same size, but biasing in opposite order.

http://i.imgur.com/S3W9AYZ.png

http://i.imgur.com/VJfziyO.png

OR use ICEM and match edges

wangnbangn April 20, 2013 17:32

Quote:

Originally Posted by Far (Post 421170)
In ICEM you can copy the spacing from the adjacent edge. Also in ANSYS try to control the edge meshing parameters.

Quote:

Originally Posted by jrunsten (Post 421230)
If you want to keep it all Hex, and matching at both the inner and outer radius you will need to use some biasing. I created the example below pretty quick. I guess with your longer straights the distortion of the elements will be less bad.

Basicly I set an edge sizing on the inner and outer edges with the same size, but biasing in opposite order.

http://i.imgur.com/S3W9AYZ.png

http://i.imgur.com/VJfziyO.png

OR use ICEM and match edges

Thanks guys. These tricks were very helpful, I didn't think to use biasing like this, so that particular problem is solved.

I have remade the mesh in ICEM CFD after spending a few days learning the software because the 'edge params' options are a lot more versatile than edge sizing with bias in ANSYS Meshing. Which leads me to the other problem:

I require placing the first node approx .00001 m away from the wall to get the y+ values I need for my problem. After setting the spacing to this size in ICEM CFD and converting to an unstructured mesh and exporting to fluent, fluent reports issues with negative volumes and left handed faces. The mesh check tool in ICEM also reports 211 problems with volume orientation, 25 of which cannot be fixed.

Okay, so I mess around for a few hours and end up trying .0001m spacing. Same problems in both ICEM and fluent. Then I try .001m. Everything works perfectly: so the problem is almost certainly with my edge params and geometry.

I am not quite sure what I need to modify with my meshing method in order to get the required spacing. Both the geometry and blocking are relatively simple, so I can make changes easily to them if needed but do not know where to start. Is there some double precision checkbox I need to tick so that these dimensions are read properly?

A few sites have said that left-handed faces often occur when two dimensions are large compared to the third, which is definitely happening here, but they do not talk about solutions.

Any suggestions? and Thanks!

Far April 21, 2013 02:18

Can you share your files ?

wangnbangn April 21, 2013 03:30

1 Attachment(s)
Quote:

Originally Posted by Far (Post 422037)
Can you share your files ?

Yes, sir. See my attached ICEM version of the mesh. After check mesh is run once on the unstructured mesh, all but 77 elements (located at the far ends) are fixed, although the 3x3 determinant indicates negative quality elements.

In the mean time, I am going to see if I can get away with just deleting them outright or running the mesh anyway since the volumes are such a small part of the entire mesh.

Far April 21, 2013 09:18

Similar problem had been discussed in some thread, but I cannot recall the thread title.

There were two solutions:

1. Through blocking : Given by me and I am trying for your problem

2. Through edit mesh menu: Diamondx gave solution through edit mesh menu and his strategy was to create 2d mesh and convert it to unstructured mesh. After that using edit mesh menu he extruded mesh

You can try option 2 and meanwhile let me work on option 1

wangnbangn April 21, 2013 21:04

Quote:

Originally Posted by Far (Post 422109)
Similar problem had been discussed in some thread, but I cannot recall the thread title.

There were two solutions:

1. Through blocking : Given by me and I am trying for your problem

2. Through edit mesh menu: Diamondx gave solution through edit mesh menu and his strategy was to create 2d mesh and convert it to unstructured mesh. After that using edit mesh menu he extruded mesh

You can try option 2 and meanwhile let me work on option 1


I believe I have found the solution. I had to change settings -> model -> triangulation tolerance from .001 to .00001. Switching between these two values and recomputing the premesh gave me negative determinants and volume orientations @ .001 and everything being fine (in both the mesh check and importing into fluent) @ .00001.

p.s. the sticky at the top incorrectly links to the tips and tricks pdf, which is what lead me to look at this option. The correct link is https://docs.google.com/file/d/0ByIL...BQT3pQMjQ/edit
but the sticky incorrectly links you to the shortened URL.

The tri-tolerance help file in ICEM also states, word for word, "users who generate very thin boundary layers on curved surfaces may have issues if their surface curvature is not being adequately represented," which seems to be the case here. I would have had a hell of a time finding this option without the sticky, so kudos to that.



Thanks very much.

Far April 21, 2013 21:16

Link is corrected.

Are you able to implement 1e-05 first cell height on curved surface?

wangnbangn April 21, 2013 22:11

Quote:

Originally Posted by Far (Post 422196)
Link is corrected.

Are you able to implement 1e-05 first cell height on curved surface?

Yep, at least according to the edge parameters--they indicate that the spacing is .00001 m in all the places I want it to be. I will know for sure when I check the y plus values.

Also, when I tried to go to 1e-6 or above, I had to mess with the projection limit, as stated in this thread: http://www.cfd-online.com/Forums/ans...it-values.html


All times are GMT -4. The time now is 16:46.