CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM (http://www.cfd-online.com/Forums/openfoam/)
-   -   viscoelasticFluidFoam (http://www.cfd-online.com/Forums/openfoam/106067-viscoelasticfluidfoam.html)

adambarfi August 17, 2012 06:22

viscoelasticFluidFoam
 
hi everybody,

I'm trying to use viscoelasticFluidFoam to solve my problem, but I cannot wmake it!!!!!!:(
when I ran wmake in src/transportModels/viscoelastic the below errors appear:

Code:

In file included from viscoelasticFluidFoam.C:49:
/opt/openfoam201/src/finiteVolume/lnInclude/initContinuityErrs.H: In function ‘int main(int, char**)’:
/opt/openfoam201/src/finiteVolume/lnInclude/initContinuityErrs.H:37: error: expected ‘,’ or ‘;’ before ‘scalar’
In file included from viscoelasticFluidFoam.C:110:
/opt/openfoam201/src/finiteVolume/lnInclude/continuityErrs.H:40: error: ‘cumulativeContErr’ was not declared in this scope
/opt/openfoam201/src/finiteVolume/lnInclude/readPISOControls.H:3: warning: unused variable ‘nOuterCorr’
/opt/openfoam201/src/finiteVolume/lnInclude/readPISOControls.H:12: warning: unused variable ‘momentumPredictor’
/opt/openfoam201/src/finiteVolume/lnInclude/readPISOControls.H:15: warning: unused variable ‘transonic’
make: *** [Make/linux64GccDPOpt/viscoelasticFluidFoam.o] Error 1

anybody knows what should I do??!!:confused:

Thanks
Mostafa Mahmoudi

ata August 18, 2012 04:58

Hi
What is the version of your OpenFOAM?

adambarfi August 18, 2012 05:47

Quote:

Originally Posted by ata (Post 377621)
Hi
What is the version of your OpenFOAM?

Dear ata,
I'm using OpenFOAM-2.0.1 because I have some problem in installing OpenFOAM-2.1.0. you can see my problem at http://www.cfd-online.com/Forums/ope...tml#post377613.

what is wrong with OF-2.0.1?!?

adambarfi August 20, 2012 05:17

Quote:

Originally Posted by adambarfi (Post 377624)
Dear ata,
I'm using OpenFOAM-2.0.1 because I have some problem in installing OpenFOAM-2.1.0. you can see my problem at http://www.cfd-online.com/Forums/ope...tml#post377613.

what is wrong with OF-2.0.1?!?

finally, after a lot of trouble, I could ran it!!!! I've changed my Ubuntu version and install OF-2.1.0. it worked.


All times are GMT -4. The time now is 11:48.