CFD Online Discussion Forums

CFD Online Discussion Forums (https://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (https://www.cfd-online.com/Forums/openfoam-installation/)
-   -   [OpenFOAM.com] paraFoam problem on MacOS after installing openFoam (https://www.cfd-online.com/Forums/openfoam-installation/215486-parafoam-problem-macos-after-installing-openfoam.html)

PanosK March 6, 2019 15:24

paraFoam problem on MacOS after installing openFoam
 
Hi all,

I am fairly new with openFoam and I am trying to find my way through. I have installed the latest version of openFOAM OpenFOAM-v1812 following the guidelines from here:https://www.openfoam.com/download/in...binary-mac.php

The installation was smooth and I was able to run perfectly the cavity tutorial (I can see the progress on the screen and the results in the directory). My problem is when I try to run paraFoam.

What I initially got was (an apparently common problem)
$ paraFoam
$ Created temporary 'cavity.OpenFOAM'
$ QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-ofuser'
$ QXcbConnection: Could not connect to display
$ /opt/OpenFOAM/OpenFOAM-v1812/bin/paraFoam: line 312: 836 Aborted paraview

I then followed the guidelines from here: https://www.cfd-online.com/Forums/op...not-found.html

and I now get a problem with some libraries
$ /opt/OpenFOAM/ThirdParty-v1812/platforms/linux64Gcc/ParaView-5.6.0/lib/paraview: error while loading shared libraries: libmpi.so.12: cannot open shared object file: No such file or directory

Do I need these mpi libraries for this?

thanks a lot in advance!

Panos

wyldckat March 6, 2019 20:38

Quick note: For future reference, PanosK found the answer in this post: https://www.cfd-online.com/Forums/op...tml#post705610 - post #5.


All times are GMT -4. The time now is 12:54.