CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > ANSYS Meshing & Geometry

[ICEM] Match spacing of nodes

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   April 24, 2010, 10:41
Default Match spacing of nodes
  #1
New Member
 
Join Date: Apr 2010
Posts: 10
Rep Power: 7
shib is on a distinguished road
Hi!
I've just started working with icem and am trying to mesh a refiner-plate in a papermachine. The plate has a lot of bars which I have blocked to create a mapped mesh. However I'm having some problems matching the the nodes on the edges between the bars. I thought blocks located next to each other shared the same node count on the edges connecting them but that is not the case for my model. What can I do to make the element between the blocks match? Thanks!
shib is offline   Reply With Quote

Old   April 25, 2010, 16:38
Default Copy to Selected edges...
  #2
Senior Member
 
PSYMN's Avatar
 
Simon Pereira
Join Date: Mar 2009
Location: Ann Arbor, MI
Posts: 2,662
Blog Entries: 1
Rep Power: 35
PSYMN has a spectacular aura aboutPSYMN has a spectacular aura about
If the edges are not actually parallel, you can still copy distributions and counts by selecting "Copy to Selected Edges" under edge params. This will prompt you to select edges on the screen that you want your distribution (for the edge you initially selected) copied to.

As to why those edges are not parallel when you expected they would be... I can't guess from this info...
PSYMN is offline   Reply With Quote

Old   April 25, 2010, 17:43
Default
  #3
New Member
 
Join Date: Apr 2010
Posts: 10
Rep Power: 7
shib is on a distinguished road
Thanks for your help Simon! I've tried coping the node spacing but since some blocks are connected to more than one block it's hard to get the edges to match.

The adjacent blocks' vertices are connected to the same points so their edges should be parallell. Earlier I had another problems with some blocks so had to delete them and replace them with new blocks. Wonder if that can have something to do with it or if there are another reason to why they seem to be "disconnected"? Also, I tried once again to fix the problem by replacing the blocks and managed to restore the "connectivity" on some of them. However when I'm trying to delete and re-create the quarter o-blocks using the 3D-blocks function I get a message saying the number of nodes doesn't match even though I have fixed the edges around the quarter o-block so that they should match.

Attached some pictures of the geometry, mesh and the blocking so you guys can get a better idea of how the model looks like. Cheers!
Attached Images
File Type: png Blocks.png (49.8 KB, 54 views)
File Type: jpg Geometry.jpg (35.7 KB, 58 views)
File Type: jpg Mesh.jpg (87.3 KB, 73 views)
shib is offline   Reply With Quote

Old   April 25, 2010, 22:01
Default Unconnected blocks
  #4
Senior Member
 
PSYMN's Avatar
 
Simon Pereira
Join Date: Mar 2009
Location: Ann Arbor, MI
Posts: 2,662
Blog Entries: 1
Rep Power: 35
PSYMN has a spectacular aura aboutPSYMN has a spectacular aura about
From your pictures, especially the last one that shows the premesh, I would say that your blocks were not connected... You are seeing edges right next to eachother, so your copy to parallel copies to one but not its double from the adjacent block.

I am guessing you created this bottom up instead of top down (like a brick layer instead of a sculptor). I am also guessing your index structure is very over complicated.

To check the block connectivity, zoom into any corner between blocks and turn on the vertex numbers. I expect you will have at least two verticies where you thought you had only one.

You can fix this by merging verticies between the blocks. Merge verts with a small tolerance should fix the ones that are already on top of each other, but you might need to interactive merge some. There is even a special option so you can merge verts to edges without splitting the edges first, but it may just be easier to split the blocks and then merge.
PSYMN is offline   Reply With Quote

Old   April 27, 2010, 11:45
Default
  #5
New Member
 
Join Date: Apr 2010
Posts: 10
Rep Power: 7
shib is on a distinguished road
Thanks Simon, your advice was helpful but there was a lot of problems with the blocks so I finally gave up trying to fix them. Instead I started from scratch and finally managed to get a good mesh.

However, beacause of the mapping, the elments get very small close to the center of the model. Since I'm mostly interested in what happeneds around the bars I want to coarsen the mesh close to the center.

I thought I would do so by converting the mesh in the blocks not belonging to the "bar region" from mapped to free. When I try to do this and generate the mesh I get the messages:

"error meshing __temp_surface.10550.uns error opening volume mesh ./temp_vol.3704.Shib-Computer.uns"
"error meshing unstructured block X"

The mesh remains mapped and the only thing that happends is that the edges get a reduced number of nodes so that the node counts on the edges between the free and mapped regions don't match.

I've tried merging the blocks in the center-region and then converting them to free mesh blocks and also deleting them and replacing them with a new block and associate the blocks to the same edges, faces and points but I can't get it to work.

So I wonder if you have an idea of how I can generate the unstructured mesh and how I can make it connect to the mapped mesh of the bar region?
Attached Images
File Type: jpg Blocks.jpg (59.2 KB, 32 views)
File Type: jpg Mesh.jpg (44.2 KB, 23 views)
File Type: jpg Free mesh.jpg (99.3 KB, 29 views)
shib is offline   Reply With Quote

Old   April 27, 2010, 16:29
Default Hope this helps...
  #6
Senior Member
 
PSYMN's Avatar
 
Simon Pereira
Join Date: Mar 2009
Location: Ann Arbor, MI
Posts: 2,662
Blog Entries: 1
Rep Power: 35
PSYMN has a spectacular aura aboutPSYMN has a spectacular aura about
There are a bunch of ways to do it, but I don't have time for details today.

You could mesh it separatly with ICEM CFD Tetra and merge it (you can find other posts on that).

You could block it differently int he wedge section so you would have cgrids coarsening the mesh... Probably hard to understand if you haven't see it.

Probably the easiest thing would be to chop the block about where you have switched to coarser mesh and then covert the wedge block into swept... You would also need to convert the triangle sides into free and use an option like Quad Dominant.

These pics might give you some idea...

FreeFaceMeshType.gif

FreeFaceMeshType3.gif

And note, you will want to make sure you merge all the blocks in that area first... Otherwise you will have so many edges that you will still have a lot of mesh...

Hope that helps. Gota go.
PSYMN is offline   Reply With Quote

Reply

Tags
block, hexa, icem, match, spacing

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
gmsh2ToFoam sarajags_89 OpenFOAM 0 November 24, 2009 23:50
ICEM CFD - minor internal error, number of nodes don't match Anorky ANSYS Meshing & Geometry 0 June 4, 2009 10:41
ICEM HEXA - Match Edge Spacing S. CFX 1 May 16, 2007 08:59
Node Spacing and number of nodes hagupta CFX 1 June 12, 2006 06:45
CFX4.3 -build analysis form Chie Min CFX 5 July 12, 2001 23:19


All times are GMT -4. The time now is 10:26.