CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > CD-adapco

v3150A on Red Hat Enterp.WS3

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   August 12, 2005, 07:48
Default v3150A on Red Hat Enterp.WS3
  #1
dams
Guest
 
Posts: n/a
Hi anyone, I have just received a new computer and have installed: Linux 2.4.21-27.0.2.ELsmp (Red Hat Enterprise WS 3) - all standard setup and have installed the latest v3.150A.044 and it simply does not work. v3.24 works fine, but I have a lot of old models which I do not want to transfer (=a lot of work)...

My problem is that I can't write any geom file without warnings and I can't run the case.

For example: I make a very small test case (3x3x3 cells with inlet and outlet) When running "geom" I get the warnings:

BEGINNING CONNECTIVITY SEARCH

162 CELL FACES TO PROCESS

**WARNING - BAFFLE CELL 1 IS NOT ATTACHED TO ANY FLUID OR SOLID CELLS. BAFFLE IGNORED.

**WARNING - BAFFLE CELL 2 IS NOT ATTACHED TO ANY FLUID OR SOLID CELLS. BAFFLE IGNORED.

**WARNING - BAFFLE CELL 5 IS NOT ATTACHED TO ANY FLUID OR SOLID CELLS. BAFFLE IGNORED.

... for all cells

Then I get a second warning:

**WARNING - CELL 1 HAS PHYSICAL BOUNDARIES ON ALL SIDES

**WARNING - CELL 2 HAS PHYSICAL BOUNDARIES ON ALL SIDES

... again for all cells

I can make a starlink on the case but it really does not make any sense because the model says that there is boundaries on all cell sides = 162. And the output is nonsense...

Have anybody seen this before and have a solution for it??? I can't be the only one running v3150A on RHEL 3.0?

Hoping for response. dams
  Reply With Quote

Old   August 12, 2005, 08:40
Default Re: v3150A on Red Hat Enterp.WS3
  #2
William Blake
Guest
 
Posts: n/a
I have seen this warning and it might help to delete the param.prp file and let prostar create a new one.

Another option is to install Suse 8.2 which works with all 32bit version of star.
  Reply With Quote

Old   August 12, 2005, 08:51
Default Re: v3150A on Red Hat Enterp.WS3
  #3
dams
Guest
 
Posts: n/a
Thanks for your response...

I tried deleting param.prp, but the problem still exist.

I can not really change os system - it is out of my hands to decide...

  Reply With Quote

Old   August 12, 2005, 09:36
Default Re: v3150A on Red Hat Enterp.WS3
  #4
steve
Guest
 
Posts: n/a
I was told there was a memory conflict with the compiler used for prostar 3.150a and the glibc in your version of RH. It got sorted out in 3.2 but I don't think there is any way around it in 3.15 other than to switch to Suse as William said.
  Reply With Quote

Old   August 12, 2005, 09:56
Default Re: v3150A on Red Hat Enterp.WS3
  #5
William Blake
Guest
 
Posts: n/a
What about rereleasing 3.15 for new versions of Linux? I would be very happy about this too.
  Reply With Quote

Old   August 12, 2005, 13:18
Default Re: v3150A on Red Hat Enterp.WS3
  #6
Jared
Guest
 
Posts: n/a
I have had the error with the baffle and I believe, in my case, that it was because the baffle was placed between fluid cells with different surface areas. Maybe check on that. Hope that helps.
  Reply With Quote

Old   August 12, 2005, 13:48
Default Re: v3150A on Red Hat Enterp.WS3
  #7
William Blake
Guest
 
Posts: n/a
No, this is an old error which occured in models without any baffles at all. Usually it happend when maxsc2 was set to a very large number during some operations in proam meshing. So deleting the param.prp was a workaround. This means that there is some problem with memory allocation. It might be the same reason why it does not run under new versions of linux.

  Reply With Quote

Old   August 15, 2005, 02:47
Default Re: v3150A on Red Hat Enterp.WS3
  #8
dams
Guest
 
Posts: n/a
Thanks for all the responses. Unfortunately this has nothing to do with baffles - there is none in the very simple model. It seems to be related to this distinct version of redhat with kernel: Linux 2.4.21-27.0.2.ELsmp (Red Hat Enterprise WS 3). Am I the only one using this one in the whole world together with prostar 3.150A???

dams
  Reply With Quote

Old   August 15, 2005, 11:14
Default Re: v3150A on Red Hat Enterp.WS3
  #9
Pauli
Guest
 
Posts: n/a
Since it is not supported - probably so.
  Reply With Quote

Old   August 16, 2005, 03:23
Default Re: v3150A on Red Hat Enterp.WS3
  #10
dams
Guest
 
Posts: n/a
Where can you see which kernels are supported for this version of prostar (V3150A.044)???
  Reply With Quote

Old   August 16, 2005, 08:45
Default Re: v3150A on Red Hat Enterp.WS3
  #11
Pauli
Guest
 
Posts: n/a
It is outlined in The Installation and Systems Guide - an Acrobat "pdf" file on the installation disks.
  Reply With Quote

Old   August 17, 2005, 17:24
Default Re: v3150A on Red Hat Enterp.WS3
  #12
staruser
Guest
 
Posts: n/a
I'm using RH 3 on a 32-bit machine and I have no problems with pro-STAR 519-523. To make sure there are no problems with the model, you should try tutorial 1. In order to run the STAR executable you need to enter "setenv LD_ASSUME_KERNEL 2.4.10" (csh) or "export LD_ASSUME_KERNEL=2.4.10" (bash), but this has nothing to do with pro-STAR.
  Reply With Quote

Old   September 5, 2005, 23:39
Default Re: v3150A on Red Hat Enterp.WS3
  #13
afiz
Guest
 
Posts: n/a
perhaps you can continue doing it in v3.24.Just maintain the .mdl file and delete those .geom,.prob and parm.inc file.Do not use the older one because the structures had all changed.Start with a fresh one.
  Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 22:28.