CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > CD-adapco

Help!! Empty post register

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   May 3, 2006, 08:42
Default Help!! Empty post register
  #1
guest7777
Guest
 
Posts: n/a
Hello, i tried different commands, somehow the register value remains blank. Case: transient. Fluid cells are projected on shells and sensor vertices are also present. Want: to export the SU,SY,SW,VMAG and P for particular shell-cells and sensor vertices as table. TRIED: stor,xxx cset news flui mapped them on shells cset news shell oper,getc,p,4 OR vset news shell oper,getv,p,4 the REGISTER REMAINS BLANK.

Thanks,

  Reply With Quote

Old   May 3, 2006, 16:45
Default Re: Help!! Empty post register
  #2
TG
Guest
 
Posts: n/a
If you are really doing things in the order you say, I don't think it should work. You should

trload

STOR,

OPER, GETC,P 4

(print all just to make sure you got data)

Then map the data to shells. Then it should be there.

If you oper getc p 4 last after you map, you wipe out the results of any mapping.
  Reply With Quote

Old   May 4, 2006, 10:07
Default Re: Help!! Empty post register
  #3
guest7777
Guest
 
Posts: n/a
Hello, thanks but i have the case that i want data at particular sites, specifically for this i mapped the fluid cells on particular planes (created at sensor vertices locations). WHat i want is following ( I find STAR-CD horrible regarding post-processing): I have a loop STOR ... for the fluid cells i now do getc,none,p caver,cset now i map on particular planes (created at sensor locations) CSET NEWS CLIS oper,getv,.. ... with GPAR i get the data in graph register What i want is: export 'POST' DATA for these few shell-cells at sensor locations. At the moment the POST-REGISTERS remain empty and GRAPH REGISTERS are filled through the MACRO i use.

How to fill the POST REGISTER and export ALL data (also from GRAPH registers) as table ?

Thanks,
  Reply With Quote

Old   May 4, 2006, 11:04
Default Re: Help!! Empty post register
  #4
guest7777
Guest
 
Posts: n/a
Its horrible how in the message the line-feed is not taken into account, sorry (can I influence this as a user?)
  Reply With Quote

Old   May 4, 2006, 12:43
Default Re: Help!! Empty post register
  #5
TG
Guest
 
Posts: n/a
You are mixing up too many things at once. If you map data to shells then you dump that data out of the POST registers for each shell. If you map data to sensor points and store that in the GRAPH register then that is something entirely different and unrelated. You dont need to map to shells in order to map to sensors. The easiest thing to do is use the Nav Center. Go to Graphs->Extract->Field Data Use the panel to create a few new sensor points, map and then store and create a graph. Then use the External Data panel to write it out. All the commands that these panels use will be written to the echo file. You should be able to understand how to adapt them to use your sensor original points instead.
  Reply With Quote

Old   May 5, 2006, 04:32
Default Re: Help!! Empty post register
  #6
guest7777
Guest
 
Posts: n/a
Thanks, i will try this out.

  Reply With Quote

Old   May 5, 2006, 10:16
Default Re: Help!! Empty post register
  #7
guest7777
Guest
 
Posts: n/a
Hello, I tried also at the NAVCENTER-> GRAPH and so on but am not able to get the data I want. The script I use is: (aim to get data in graph registers, actually for export) I have not written the MAPPING on shells part.

oper,clear,all

rclear, all

gres

y

*set DRUCK 0 0

batch on

*set INCREMENT 0 1

trload,star**.pttc,mvgr on

n

*define noex

store iter INCREMENT

*get ZEIT time

cset,news,clis,NR.

vset,news,cset,all

oper,getv,p,4

*get DRUCK,post,4,

gpar,ZEIT,1,INCREMENT

gpar,DRUCK,2,INCREMENT

*end

*loop 1 N 1

batch off

When looking at GRAPH REGISTER, it sometimes just does not update data. What could the reason be ?

Thanks.

  Reply With Quote

Old   May 9, 2006, 09:09
Default Re: Help!! Empty post register
  #8
TG
Guest
 
Posts: n/a
*set DRUCK 0 0

batch on

*set INCREMENT 0 1

trload,star**.pttc,mvgr on there is no 'on' option. Its mvgr or nomvgr. I don't think a wild card is allowed either (not really sure -never used it). If you want to load multiple files, I think you need trload,star001.pttc,mvgr,N (where N is number of files to load). Then it asks you for file names.

n

*define noex

store iter INCREMENT There is no 'ITER' option. Its 'ITSTEP'.

*get ZEIT time

cset,news,clis,NR. where does 'NR' come from? Is it defined?

vset,news,cset,all

oper,getv,p,4

*get DRUCK,post,4, You are missing the last field which is the data item to get It should be *GET DRUCK POST 4 N (where N is the vertex number)

gpar,ZEIT,1,INCREMENT

gpar,DRUCK,2,INCREMENT

*end

*loop 1 N 1

batch off
  Reply With Quote

Old   May 17, 2006, 10:57
Default Re: Help!! Empty post register
  #9
guest7777
Guest
 
Posts: n/a
Due to older version the commands were accepted !!! (I will check this out). With Nr i meant vertex or cell nr. which is entered. Thank you very much for your response, I am continuing the work.
  Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to imcrease post register memory Airfoil CD-adapco 3 September 7, 2007 01:08
post register operation star CD-adapco 2 July 20, 2007 03:03
Post Register anonymous CD-adapco 3 July 10, 2006 06:47
post to graph register newone CD-adapco 1 November 17, 2003 04:00
post register Astrid Hostrup CD-adapco 1 July 31, 2000 08:11


All times are GMT -4. The time now is 00:20.