CFD Online URL
[Sponsors]
Home > Forums > CFX

User function bug?

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   April 28, 2013, 23:47
Default User function bug?
  #1
Member
 
Sherif Kadry
Join Date: May 2009
Posts: 38
Rep Power: 7
sherifkadry is on a distinguished road
I'm using CFX13, and what I'm essentially doing is applying an algebraic intermittency function via user fortran.
I've checked my function extensively, but something odd happens that I can't explain, I run CFX with my function and it gives me an invalid operand error, suggesting a negative sqrt or so. In order to debug the issue, I put out write statements, to see what is causing this. Once i have a write statement (to a file) in the do loop everything works. No write statement, crash with the operand message. Write statement all is good, obviously it runs slower though.
Any ideas? Or is this a bug?
sherifkadry is offline   Reply With Quote

Reply

Tags
cel fortran cfx

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
interpolation table user function not loading data properly cfdonlineuser CFX 2 November 25, 2012 20:37
DecomposePar links against liblamso0 with OpenMPI jens_klostermann OpenFOAM Bugs 11 June 28, 2007 18:51
Axisymmetrical mesh Rasmus Gjesing (Gjesing) OpenFOAM Native Meshers: blockMesh 10 April 2, 2007 15:00
User Defined Function for convection coefficient ereiss FLUENT 1 July 8, 2004 17:10
User define flux function kethireddy FLUENT 0 July 5, 2004 05:53


All times are GMT -4. The time now is 19:35.