CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > CFX

Error Simmetry

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   September 29, 2013, 10:17
Default Error Simmetry
  #1
New Member
 
Loris
Join Date: Sep 2013
Posts: 17
Rep Power: 3
Loris88 is on a distinguished road
Hello everyone!
I have done mesh with ICEM, then I have imported it in Ansys CFX 14.0.
After setting all things in CFX-Pre, I start the simulation, but there is a problem:

|ERROR #002100013 has occurred in subroutine Chk_Splane. |
| Message: |
| The symmetry boundary condition requires that the boundary patch |
| mesh faces form a plane or axis. However, face set 3 in the |
| symmetry boundary patch |
| |
| PARETE_SYM_2 |
| |
| is not in a strict plane, which means that at least one of its |
| faces is not parallel to the others. To make the solver run |
| you can do one of the following: |
| |
| (1) Make sure that this symmetry boundary patch is in a plane or |
| axis by checking and regenerating the mesh. |
| (2) If the symmetry boundary patch is an axis rather than a |
| plane, change the tolerance of the degeneracy check by |
| increasing the value of the Solver Expert Parameter |
| 'degeneracy check tolerance' (the default value is 1.e-4). |
| (3) Increase the value of the Solver Expert Parameter |
| 'vector parallel tolerance' (the default value is 1 deg.). |
| Note that the accuracy of the symmetry condition may decrease |
| as the tolerance is increased. This is because the tolerance |
| is the number of degrees that a mesh face normal is allowed |
| to deviate from the average normal for the entire face set. |

This is the error message that I received.
After reading some past messages about this error, I have found this reply
"In pre-mesh, in ICEM, click on "No Projection"". I tried this and the first time that I have done that, the problem is solved... but, now this solution does not work anymore.. Can you help me?
I do not have particular geometry... one rectangular channel with a block at circa half length channel... in CFX, I have to analyze this problem in 2D...

I read many post online... I also tried to apply the suggestions that Ansys gives me but in every cases, I do not succeed to solve the problem. I have found also post that it said "Click in ICEM tab Global Mesh Setup and then go to Edge Criterion...change value from 0.2 to 0.05" but nothing...

Last edited by Loris88; September 29, 2013 at 12:20. Reason: Complete Post
Loris88 is offline   Reply With Quote

Old   September 30, 2013, 09:44
Default
  #2
Senior Member
 
OJ
Join Date: Apr 2012
Location: United Kindom
Posts: 475
Rep Power: 11
oj.bulmer will become famous soon enough
Can you post the images of the geometry? Also, have you tried increasing the "vector parallel tolerance" to a higher value, say 5 deg? You can find it in expert parameters.
oj.bulmer is offline   Reply With Quote

Old   September 30, 2013, 11:29
Default
  #3
New Member
 
Loris
Join Date: Sep 2013
Posts: 17
Rep Power: 3
Loris88 is on a distinguished road
Quote:
Originally Posted by oj.bulmer View Post
Can you post the images of the geometry? Also, have you tried increasing the "vector parallel tolerance" to a higher value, say 5 deg? You can find it in expert parameters.
Thanks for the reply!
I have tried to change the value of "vector parallel tolerance" until 45 degree, for little steps, but this method does not give the correct solution at my problem. I also change other parameters that Ansys suggests me but I have always the same problem.
This morning, I read one possible solution that it said "Click "Move Nodes" and then click on "select items in a part" (Shift+P)" if I remeber correctly, but I'm always at the same point.
I attached the image of the mesh... The start and the end of it, are not visible beacuse the channel is very long, 3900 mm and his height is 50 mm.
Loris88 is offline   Reply With Quote

Old   September 30, 2013, 11:37
Default
  #4
Senior Member
 
OJ
Join Date: Apr 2012
Location: United Kindom
Posts: 475
Rep Power: 11
oj.bulmer will become famous soon enough
It is not recommended that you increase it beyond 2-5 deg, let alone 45!

I hope you have ensured that you are using the 3D geometry? CFX can not handle the 2D geometry. Make sure that the width of the channel is one cell thick.

If it infact was a 3D, which surface have you specified the symmetry on, probably the ones that are front and back faces of your above view? Can you instead use free slip boundary condition?

OJ
oj.bulmer is offline   Reply With Quote

Old   September 30, 2013, 11:52
Default
  #5
New Member
 
Loris
Join Date: Sep 2013
Posts: 17
Rep Power: 3
Loris88 is on a distinguished road
Quote:
Originally Posted by oj.bulmer View Post
It is not recommended that you increase it beyond 2-5 deg, let alone 45!

I hope you have ensured that you are using the 3D geometry? CFX can not handle the 2D geometry. Make sure that the width of the channel is one cell thick.

If it infact was a 3D, which surface have you specified the symmetry on, probably the ones that are front and back faces of your above view? Can you instead use free slip boundary condition?

OJ
Don't worry, I tried to change the value of expert parameter first with 2-5 degree, but I did not find solutions so I have tried to change this value until 45 degree...

Yes, after settings 2D mesh, I have extruded it in 3D mesh using 1 cell like thickness and then I have imported it in Ansys CFX.
The problem I have is that the back face of extrusion is not parrallel... so Ansys gives me the error..
Loris88 is offline   Reply With Quote

Old   October 1, 2013, 10:44
Default
  #6
New Member
 
Loris
Join Date: Sep 2013
Posts: 17
Rep Power: 3
Loris88 is on a distinguished road
One moment... for Ansys back face is not parallel... in my exercise, back and frontal faces are parrallel!!
Loris88 is offline   Reply With Quote

Old   October 1, 2013, 13:22
Default
  #7
Senior Member
 
Edmund Singer P.E.
Join Date: Aug 2010
Location: Minneapolis, MN
Posts: 495
Rep Power: 11
singer1812 is on a distinguished road
It seems your nodes on SYM2 are slightly off the tolerance CFX wants for them to be in a plane. Assuming SYM2 is aligned with a cartesian plane, open your mesh in ICEM. Got to Move Nodes Tab. Click the Move Exact Icon >>Set Location. Click the Move X (or Y or Z whatever plane that it aligns on). Type in the value of the coordinate of the axis. Hit apply.

This should line your nodes up in the symmetry plane and free you from that error.
singer1812 is offline   Reply With Quote

Old   October 2, 2013, 09:34
Default
  #8
New Member
 
Loris
Join Date: Sep 2013
Posts: 17
Rep Power: 3
Loris88 is on a distinguished road
Quote:
Originally Posted by singer1812 View Post
It seems your nodes on SYM2 are slightly off the tolerance CFX wants for them to be in a plane. Assuming SYM2 is aligned with a cartesian plane, open your mesh in ICEM. Got to Move Nodes Tab. Click the Move Exact Icon >>Set Location. Click the Move X (or Y or Z whatever plane that it aligns on). Type in the value of the coordinate of the axis. Hit apply.

This should line your nodes up in the symmetry plane and free you from that error.
Thanks!
When I click "Set Location", I leave "offset" or not?
Second: how do I know what is the coordinate of axis of symmetry?
Loris88 is offline   Reply With Quote

Old   October 2, 2013, 09:42
Default
  #9
Senior Member
 
Edmund Singer P.E.
Join Date: Aug 2010
Location: Minneapolis, MN
Posts: 495
Rep Power: 11
singer1812 is on a distinguished road
Method = postion (not offset).

Regarding the coord values of your symmetry plane. You created the geometry. You should know them. If the symmetry plane is aligned with a coordinate plane, they will all have the same value (for example if the sym is in the XY plane, all the z values will be the same).

If you are not sure, you can click on the Tape Measure in the ICEM icon bar at the top. Make sure mesh selection is highlighted in the picking menu, and click on a node that is on your symmetry plane. It will show you the x,y,and z vlaues for that node.

Move all the nodes position to the appropriate coord value.
singer1812 is offline   Reply With Quote

Old   October 2, 2013, 09:54
Default
  #10
New Member
 
Loris
Join Date: Sep 2013
Posts: 17
Rep Power: 3
Loris88 is on a distinguished road
Quote:
Originally Posted by singer1812 View Post
Method = postion (not offset).

Regarding the coord values of your symmetry plane. You created the geometry. You should know them. If the symmetry plane is aligned with a coordinate plane, they will all have the same value (for example if the sym is in the XY plane, all the z values will be the same).

If you are not sure, you can click on the Tape Measure in the ICEM icon bar at the top. Make sure mesh selection is highlighted in the picking menu, and click on a node that is on your symmetry plane. It will show you the x,y,and z vlaues for that node.

Move all the nodes position to the appropriate coord value.
Thanks! Now I will try to do this! I hope that this will be the solution of all my problems!

Best

Loris
Loris88 is offline   Reply With Quote

Reply

Tags
error #002100013

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 01:20.