CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

OF 15dev 1094 wmake calculatedPointPatchField s H

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   March 4, 2009, 13:58
Default Hi Foamers, saw I had to ch
  #1
New Member
 
olivier braun
Join Date: Mar 2009
Location: Lausanne, Switzerland
Posts: 19
Rep Power: 8
obraun is on a distinguished road
Hi Foamers,

saw I had to change to dev as stitchMesh seems to be broken in the .x. Got the dev by svn this afternoon, the makeFiles complain about missing H. files. When looking into it it seems as if there were minor file name changes. For example

make: *** No rule to make target `/home/obraun/OpenFOAM/OpenFOAM-1.5-dev/src/OpenF OAM/lnInclude/calculatedPointPatchField.H', needed by `PointEdgeWave/PointEdgeWave Name.dep'. Stop.

but there is a calculatedPointPatchFields.H with an 's' in lnInclude.

Same for many other files around ...pointPatch... or PointPatch...

I am not a pro of these svn/procedures... What does this mean? Someone is in the middle of changing things to the code and fiddled around with the filenames to make the difference? Or am I just to tired to understand what's up ?

What should I do? Get an older snapshot, those on Hrvoje Jasaks powerlab site? Which is the last of those? Correct the headerfile names manually, well I believe someone was doing this intentionally?

Thanks for any advice or links to relevant info

Olivier
obraun is offline   Reply With Quote

Old   March 5, 2009, 03:49
Default Good morning Olivier When I
  #2
ngj
Senior Member
 
Niels Gjoel Jacobsen
Join Date: Mar 2009
Location: Deltares, Delft, The Netherlands
Posts: 1,619
Rep Power: 25
ngj will become famous soon enoughngj will become famous soon enough
Good morning Olivier

When I run into that message it is usually enough to do a "wclean" before running "wmake".

The more technical reason for this someone else should shed his/her wisdom over the land.

Have a nice day,

Niels
__________________
Please note that I do not use the Friend-feature, so do not be offended, if I do not accept a request.
ngj is offline   Reply With Quote

Old   March 5, 2009, 04:19
Default Thanks for the reply, in fact
  #3
New Member
 
olivier braun
Join Date: Mar 2009
Location: Lausanne, Switzerland
Posts: 19
Rep Power: 8
obraun is on a distinguished road
Thanks for the reply, in fact a wclean would have been appropriate....

Now I know what happened. Too stupid me.

Executed Allwmake in a shell where my environment was still 1.5.x. Demolished my 1.5.x completely, no problem got it back from yesterday snapshot. But I have at the same time corrupted the 1.5-dev files and dependencies and for sure the second Allwmake was running into plenty of errors. Deleted it got a brand new one (1095) and done things in the right order overnight. Sorry for posting too fast.

Olivier
obraun is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ggi 15dev bastil OpenFOAM Bugs 7 June 10, 2009 09:43
InterDyMFoam in 15dev keyword agglomerator is undefined in dictionary eberberovic OpenFOAM Running, Solving & CFD 0 February 16, 2009 11:17
Compiling 15dev and 15x in single precision bastil OpenFOAM Installation 0 February 5, 2009 05:34
Compiling 15dev and 15x in single precision bastil OpenFOAM Installation 0 February 5, 2009 05:03
GGI function ggiCheck in OF 15dev louisgag OpenFOAM Running, Solving & CFD 3 February 3, 2009 21:08


All times are GMT -4. The time now is 05:51.