CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

Installation Problem

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   December 15, 2008, 13:11
Default Hi I installed openFOAM in FC
  #1
Member
 
Velan
Join Date: Mar 2009
Location: India
Posts: 50
Rep Power: 8
velan is on a distinguished road
Hi
I installed openFOAM in FC8. I got the error message which is posted in http://www.cfd-online.com/OpenFOAM_D...tml?1227715756

+ cmake ../..
-- Loading ParaView CMake commands
-- Loading ParaView CMake commands - done
CMake Error: Error in cmake code at
================================================== ======================*/:458:
Unknown CMake command "QT4_WRAP_CPP".
CMake Error: Error in cmake code at
/home/vc/OpenFOAM/OpenFOAM-1.5/applications/utilities/postProcessing/graphics/PV 3FoamReader/PV3FoamReader/CMakeLists.txt:44:
A command failed during the invocation of macro "ADD_PARAVIEW_GUI_EXTENSION".
CMake Error: Error in cmake code at
================================================== ======================*/:562:
ADD_PARAVIEW_GUI_EXTENSION unknown error.
Current CMake stack: /home/vc/OpenFOAM/OpenFOAM-1.5/applications/utilities/postProcessing/graphics/PV 3FoamReader/PV3FoamReader/CMakeLists.txt;/home/vc/OpenFOAM/ThirdParty/cmake-2.4. 6/platforms/linux/share/cmake-2.4/Modules/CMakeCInformation.cmake;/home/vc/OpenF OAM/ThirdParty/cmake-2.4.6/platforms/linux/share/cmake-2.4/Modules/CMakeCXXInfor mation.cmake
CMake Error: Error in cmake code at
/home/vc/OpenFOAM/OpenFOAM-1.5/applications/utilities/postProcessing/graphics/PV 3FoamReader/PV3FoamReader/CMakeLists.txt:44:
A command failed during the invocation of macro "ADD_PARAVIEW_PLUGIN".
CMake Error: Error in cmake code at
/home/vc/OpenFOAM/OpenFOAM-1.5/applications/utilities/postProcessing/graphics/PV 3FoamReader/PV3FoamReader/CMakeLists.txt:43:
ADD_PARAVIEW_PLUGIN unknown error.
Current CMake stack: /home/vc/OpenFOAM/OpenFOAM-1.5/applications/utilities/postProcessing/graphics/PV 3FoamReader/PV3FoamReader/CMakeLists.txt;/home/vc/OpenFOAM/ThirdParty/cmake-2.4. 6/platforms/linux/share/cmake-2.4/Modules/CMakeCInformation.cmake;/home/vc/OpenF OAM/ThirdParty/cmake-2.4.6/platforms/linux/share/cmake-2.4/Modules/CMakeCXXInfor mation.cmake
-- Configuring done

$ cmake --version
cmake version 2.4-patch 6


Can you please suggest me what need to be do ?
velan is offline   Reply With Quote

Old   December 16, 2008, 04:06
Default Hi Velan, What recipe did y
  #2
Senior Member
 
Gijsbert Wierink
Join Date: Mar 2009
Posts: 382
Rep Power: 9
gwierink is on a distinguished road
Hi Velan,

What recipe did you follow? Did you try installing gcc and gcc-c++ and then install with "./configure", then "gmake", and finally "gmake install"?

Rgds, Gijs
__________________
Regards, Gijs
gwierink is offline   Reply With Quote

Old   December 16, 2008, 04:56
Default Hi Gijs, I not tried as you s
  #3
Member
 
Velan
Join Date: Mar 2009
Location: India
Posts: 50
Rep Power: 8
velan is on a distinguished road
Hi Gijs,
I not tried as you said. I did the following

cd OpenFOAM/OpenFOAM-1.5
./Allwmake

Before the end, it gave error.
Now i am working on how to resolve it. I thing problem might be in QT or cmake.
Earlier tried with QT 4.4 then changed to QT 4.3, Similarly changed cmake-2.6.* version and tried, But no vain.

Now changed QT 4.4 to QT 4.3 and cmake-2.6.* to cmake-2.4* , and resolving it. Let you know about the status of it once compilation done. Meanwhile please suggest me if i need to do someother way.

I am using FC8, 32-bit version.
velan is offline   Reply With Quote

Old   December 16, 2008, 05:17
Default Hi all, Finally after two d
  #4
Member
 
Velan
Join Date: Mar 2009
Location: India
Posts: 50
Rep Power: 8
velan is on a distinguished road
Hi all,

Finally after two days (day & night struggle) i got it. Its simple if say it.

[vc@scram OpenFOAM-1.5]$ qmake --version
QMake version 2.01a
Using Qt version 4.3.3 in /usr/local/Trolltech/Qt-4.3.3/lib


The error came because of QT higher version. I used qt.4.3.3 and its works fine and parafoam is working now .

Thanks for your help.
velan is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installation problem Andrei Smirnov (Smirnov) OpenFOAM Installation 21 May 7, 2007 11:15
installation problem Dr C.Bhasker CD-adapco 1 September 13, 2006 07:01
Installation Problem Sundar.M CD-adapco 0 June 27, 2006 23:42
Installation Problem Meenu FLUENT 2 April 22, 2006 14:29
CFX 4.4 installation problem Pandu Sattvika CFX 1 December 1, 2001 05:07


All times are GMT -4. The time now is 02:09.