CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

OpenFOAM15x Installation

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   November 5, 2008, 04:13
Default Dear Foamers, I had success
  #1
New Member
 
Alekh
Join Date: Mar 2009
Posts: 9
Rep Power: 7
kallipygian is on a distinguished road
Dear Foamers,

I had successfully installed OpenFOAM 1.5 at my /home directory. Later I decided to install the patches from OpenFOAM from git repository. This is the procedure I followed.

I downloaded the OpenFOAM patched source code using the command:

git clone git://repo.or.cz/OpenFOAM-1.5.x.git

This created a directory called OpenFOAM-1.5.x, containing the source code in my /home folder. I transferred it to the already existing OpenFOAM folder in my /home directory and edited the .bashrc with the line:

. $HOME/OpenFOAM/OpenFOAM-1.5.x/etc/bashrc

I made sure that the previous entry for OprnFOAM-1.5 was deleted. Then I compiled the library with ./Allwmake command. Now, all my solvers, utilities etc works fine. But, paraview starts crashing. when I tested it on icoFoam tutorial case.

I then compiled Paraview 3.3 and PV3FoamReader module following the steps mentioned in the OpenFOAM site by executing the following command.

* cd $FOAM_INST_DIR/ThirdParty
* rm -rf ParaView3.3-cvs/platforms
* buildParaView3.3-cvs

For PV3FoamReader module:

* cd $FOAM_UTILITIES/postProcessing/graphics/PV3FoamReader
* ./Allwclean
* ./Allwmake

Now, when I run paraFoam on the icoFoam tutorial case, I get the following message

"/home/mechartes/OpenFOAM/ThirdParty/ParaView3.3-cvs/platforms/linuxGcc/bin/para view-real: error while loading shared libraries: libQtAssistantClient.so.4: cannot open shared object file: No such file or directory"

Is it asking me to install Qt4 now? I am a bit confused. I really need to install the patched version of OpenFOAM. Any help will be greatly appreciated.

Regards,
Alekh
kallipygian is offline   Reply With Quote

Old   November 5, 2008, 04:33
Default I already have Qt-4.3.1 Instal
  #2
New Member
 
Alekh
Join Date: Mar 2009
Posts: 9
Rep Power: 7
kallipygian is on a distinguished road
I already have Qt-4.3.1 Installed! Qmake returns the following:

QMake version 2.01a
Using Qt version 4.3.1 in /usr/local/Trolltech/Qt-4.3.1/lib
kallipygian is offline   Reply With Quote

Old   November 5, 2008, 05:18
Default I can see "libQtAssistantClien
  #3
New Member
 
Alekh
Join Date: Mar 2009
Posts: 9
Rep Power: 7
kallipygian is on a distinguished road
I can see "libQtAssistantClient.so.4" at /usr/local/Trolltech/Qt-4.3.1/lib
kallipygian is offline   Reply With Quote

Old   November 5, 2008, 09:23
Default There is some more info that I
  #4
New Member
 
Alekh
Join Date: Mar 2009
Posts: 9
Rep Power: 7
kallipygian is on a distinguished road
There is some more info that I can provide:

Its trying to load "paraview-real" while in 1.5 the paraFoam command loads "paraview"

After running the script "buildParaView3.3-cvs" from 1.5.x somehow paraview-real is also installed and paraFoam is using this application instead of paraview.

I do not know why this is happening.. has anyone else faced the same problem with OpenFOAM-1.5.x installation?

Please help, I am not able to move any further than this roadblock.
kallipygian is offline   Reply With Quote

Old   November 6, 2008, 01:17
Default Ding! :-( Any Hints?
  #5
New Member
 
Alekh
Join Date: Mar 2009
Posts: 9
Rep Power: 7
kallipygian is on a distinguished road
Ding! :-( Any Hints?
kallipygian is offline   Reply With Quote

Old   November 6, 2008, 05:19
Default Dear foamers, Which edition o
  #6
superhugo
Guest
 
Posts: n/a
Dear foamers,
Which edition of LINUX should I installed?should I install the linux parallelly with Windows or should I install it on the virtual drive?Does the latter have any influence the computation of OpenFOAM?
Thanks for your response
  Reply With Quote

Old   November 6, 2008, 06:32
Default Alekh, if you type "echo $L
  #7
Member
 
Ville Tossavainen
Join Date: Mar 2009
Location: Helsinki, Finland
Posts: 60
Rep Power: 7
villet is on a distinguished road
Alekh,

if you type "echo $LD_LIBRARY_PATH", do you see "/usr/local/Trolltech/Qt-4.3.1/lib" in the output? If not, try command "export /usr/local/Trolltech/Qt-4.3.1/lib:$LD_LIBRARY_PATH". Then run paraFoam, do you still see the same error message?

I would like to stress one thing. I know it's annoying that sometimes things don't work. However, this is not commercial support.
villet is offline   Reply With Quote

Old   November 6, 2008, 06:35
Default The correct command is "export
  #8
Member
 
Ville Tossavainen
Join Date: Mar 2009
Location: Helsinki, Finland
Posts: 60
Rep Power: 7
villet is on a distinguished road
The correct command is "export LD_LIBRARY_PATH=/usr/local/Trolltech/Qt-4.3.1/lib:$LD_LIBRARY_PATH"
villet is offline   Reply With Quote

Old   November 6, 2008, 07:25
Default Ville, Thanks, I truly app
  #9
New Member
 
Alekh
Join Date: Mar 2009
Posts: 9
Rep Power: 7
kallipygian is on a distinguished road
Ville,

Thanks, I truly appreciate your help. It works! :-)

I understand its not a commercial support and its just the lack of time which got me restless. I sincerly appreciate the work that has been done by the community and the core developers.
kallipygian is offline   Reply With Quote

Old   September 11, 2009, 06:28
Default
  #10
New Member
 
Ehsan
Join Date: Jun 2009
Posts: 1
Rep Power: 0
eeftekhari is on a distinguished road
Thanks a lot Ville, you are great!
eeftekhari is offline   Reply With Quote

Old   October 12, 2009, 12:53
Default builParaView3.3-cvs got following error
  #11
New Member
 
Nirmal
Join Date: Jun 2009
Posts: 13
Rep Power: 7
nirmalrishi is on a distinguished road
Hi,

When I tried to run buildParaView3.3-cvs after rmoving platforms directory, i got the following messages.

[ 52%] [ 52%] Building CXX object Utilities/VTKClientServer/Graphics/CMakeFiles/vtkGraphicsCS.dir/vtkWindowedSincPolyDataFilterClientServer.o
Building CXX object Utilities/VTKClientServer/Graphics/CMakeFiles/vtkGraphicsCS.dir/vtkGraphicsCSInit.o
Linking CXX shared library ../../../bin/libvtkGraphicsCS.so
[ 52%] Built target vtkGraphicsCS
make: *** [all] Error 2
done



please let me know, how can i avoid this and complete the installation?
nirmalrishi is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem in installing OpenFoam15x mmjhuang OpenFOAM Installation 3 March 24, 2009 06:25
INSTALLATION OF 141 naveen OpenFOAM Installation 3 January 30, 2009 05:19
HP Installation ali OpenFOAM Installation 7 August 18, 2005 17:28
installation mohammad FLUENT 0 May 4, 2003 11:15
HP-UX installation new here FLUENT 1 October 26, 2000 22:54


All times are GMT -4. The time now is 13:10.