CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

Problme to open FoamX

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   February 6, 2006, 21:37
Default Hi everyone, When I opened
  #1
New Member
 
Yoshiki Yamazaki
Join Date: Mar 2009
Posts: 2
Rep Power: 0
yoshikiy is on a distinguished road
Hi everyone,

When I opened FoamX window by typing "FoamX", the FoamX window appered, but told that "Default name service could not contacted"

I am using 64bit Fedora core 4. I installed all 5 files of AMD Linux 64bit version. Also I found one of the OpenFOAM discussion saying that "for fedora core 4 users you need to install xorg-deprecated-libs, just do yum install libXp.so.6" So I did this.

When I opened FoamX, I first typed
export WM_64="on"
and type
. .bashrc
and type
FoamX

Then it tells "Defult name service could not contacted" and also shows the following messages

Starting NameServer with inet:localhost.localdomain:1234 ...
Starting FoamX Host Browser with inet:localhost.localdomain:1234 ...
/*---------------------------------------------------------------------------*\
| ========= | |
| \ / F ield | OpenFOAM: The Open Source CFD Toolbox |
| \ / O peration | Version: 1.2 |
| \ / A nd | Web: http://www.openfoam.org |
| \/ M anipulation | |
\*---------------------------------------------------------------------------*/

Exec : FoamXHostBrowser
Date : Feb 06 2006
Time : 15:00:59
Host : localhost.localdomain
PID : 24614
Root :
Case :
Nprocs : 1
HostBrowser running.....
Using jar /home/yoshikiy/OpenFOAM/OpenFOAM-1.2/applications/utilities/preProcessing/FoamX/ lib/FoamX.jar
Using jar /home/yoshikiy/OpenFOAM/OpenFOAM-1.2/applications/utilities/preProcessing/FoamX/ lib/jlfgr-1_0.jar
FoamX.Exceptions.FoamXException: Default name service could not be contacted.
at FoamX.App.initialiseHostBrowser(App.java:512)
at FoamX.App.initialise(App.java:343)
at FoamX.App.main(App.java:186)
/home/yoshikiy/OpenFOAM/OpenFOAM-1.2/bin/runFoamXHB: line 131: 24614 Killed FoamXHostBrowser -ORBNamingAddr $myIOP
runFoamXHB : cleanup
runFoamXHB: Killing name server nsd(pid 24610).
/home/yoshikiy/OpenFOAM/OpenFOAM-1.2/bin/runFoamXHB: line 66: 24610 Killed nsd -ORBIIOPAddr $myIOP --ior $FOAMX_CONFIG/ns.ref </dev/null

Could someone give me advice to solve this problem?

Thank you for your time.
yoshikiy is offline   Reply With Quote

Old   February 7, 2006, 03:20
Default Hi Yoshiki, Did you install
  #2
Senior Member
 
Jens Klostermann
Join Date: Mar 2009
Posts: 117
Rep Power: 8
jens_klostermann is on a distinguished road
Hi Yoshiki,

Did you install j2sdk1.4.2_05.linux.tgz for java? FoamX needs java tor run. Maybe this is the problem?

Regards Jens
jens_klostermann is offline   Reply With Quote

Old   February 7, 2006, 04:37
Default Yes, I installed j2sdk1.4.2=05
  #3
New Member
 
Yoshiki Yamazaki
Join Date: Mar 2009
Posts: 2
Rep Power: 0
yoshikiy is on a distinguished road
Yes, I installed j2sdk1.4.2=05.linuxAMD64.tgz in $HOME/OpenFOAM/linuxAMD64.

And when I executed the 'foamInstallationTest', there was no error.
yoshikiy is offline   Reply With Quote

Old   February 7, 2006, 05:55
Default Probably your nsd isn't runnin
  #4
Super Moderator
 
Mattijs Janssens
Join Date: Mar 2009
Posts: 1,416
Rep Power: 16
mattijs is on a distinguished road
Probably your nsd isn't running. This is the Mico name server that gets started by the runFoamX script. Put some print statements around the invocation and see with what arguments it gets called and if it runs after that.

I don't tend to run FoamX in 64 bit mode so cannot comment any more specific.
mattijs is offline   Reply With Quote

Old   February 16, 2006, 22:53
Default I had the same message on a 32
  #5
New Member
 
William Solomon
Join Date: Mar 2009
Posts: 1
Rep Power: 0
bill is on a distinguished road
I had the same message on a 32bit machine with Fedora 4. If you turn off the SELinux security (and reboot), FoamX will work. Desktop->System settings->Security Level. No doubt it is possible to more selectively open up whatever FoamX needs...
bill is offline   Reply With Quote

Old   November 6, 2006, 11:13
Default Hej , I did some changes.
  #6
mss
Guest
 
Posts: n/a
Hej ,
I did some changes.
I have add the IP address in two files:

/etc/hosts
and in
/etc/resolve.conf

and made the link:

ln -s hosts /etc/sysconfig/networking/profile/default/hosts

but I still recive the same error message.
--------------------------------------------------
FoamX.Exceptions.FoamXException: Default name service could not be contacted.
-------------------------------------------------

Do you have any idea what I am doing wrong?

Thank you for help,
Rita

P.S: and I switched of FireWall.
  Reply With Quote

Old   November 7, 2006, 13:06
Default Hello, Yoshiki, FoamX and t
  #7
Senior Member
 
Philippose Rajan
Join Date: Mar 2009
Location: Germany
Posts: 530
Rep Power: 16
philippose will become famous soon enough
Hello,
Yoshiki, FoamX and the Foam Host Browser (runFoamXHSB) does not run with the computer name set to "localhost". You need to provide your computer with a name other than "localhost".

Rita... You need to have something like this in your /etc/hosts file:

127.0.0.1 localhost.localdomain localhost <name_you_choose>

And you dont need any reference to your local computer IP address in /etc/resolv.conf

Now... if you make this change to only your /etc/hosts file, I think it will be overwritten at the next reboot... to prevent this, make the same change also to the file:

/etc/sysconfig/networking/profile/default/hosts

And again, you dont need any reference to your local IP address in the copy of the resolv.conf file which also exists in

/etc/sysconfig/networking/profile/default

Also, you need to remove the symbolic link you made for the hosts file....

Try this out, it should work.

As for those who run Fedora linux systems with SELinux enabled.... there is no need to disable SELinux, all you need to do is, to go to:

Administration-> Security Level and Firewall-> the SELinux tab-> Modify SELinux Policy

And under that... in the list.. go to:

Memory Protection, and put a tick next to the option:

"Allow all unconfined executables to use libraries requiring text relocation that are not labeled textrel_shlib_t"

Close and restart your computer, and that should solve the remaining problems (provided your hostname is not set to "localhost" or "localhost.localdomain" :-)!!)


Philippose
philippose is offline   Reply With Quote

Old   November 17, 2006, 17:55
Default Sorry for my english I am o
  #8
New Member
 
Pietro Incardona
Join Date: Mar 2009
Posts: 3
Rep Power: 8
ibird is on a distinguished road
Sorry for my english

I am on Linux Fedora Core 4

I have se same problem of Yoshiki Yamazaki

"Defult name service could not contacted"

Server start on localhost.localdomain 1234

i have added to etc/host
127.0.0.1 localhost.localdomain localhost ibird
so DNS resolve 127.0.0.1 for ibird.

I haven' t Memory Protection into Modify SELinux Policy
i have items like

Compatibility
FTP
HTTPD Service
Kerberos
Name Service
.......
.......

but no Memory menagement

So i have started FoamX, don' t work

Now i have thiked that i should insert ibird somewhere saying FoamX to connect with ibird name changing the file FoamXClient.cfg

the lines

#org.omg.CORBA.ORBInitialPort=1234
#org.omg.CORBA.ORBInitialHost=penfold

with

I am on Linux Fedora Core 4

I have se same problem of Yoshiki Yamazaki

"Defult name service could not contacted"

Server start on localhost.localdomain 1234

i have added to etc/host
127.0.0.1 localhost.localdomain localhost ibird
so DNS resolve 127.0.0.1 for ibird.

I haven' t Memory Protection into Modify SELinux Policy
i have

Compatibility
FTP
HTTPD Service
Kerberos
Name Service
.......
.......

So i have started FoamX, don' t work

Now i have thiked that i should insert ibird somewhere saying FoamX to connect with ibird name changing the file FoamXClient.cfg

the lines

#org.omg.CORBA.ORBInitialPort=1234
#org.omg.CORBA.ORBInitialHost=ibird

Don' t work i have tried to change the port with
1235, but the nsd server start always with 1234 and localhost.localdomain, i have also controlled
the variable FOAMX_CONFIG and point to the folder
with FoamXClient.cfg, but it seem that changing this file has no effect

where is my mistake ?
ibird is offline   Reply With Quote

Old   November 17, 2006, 19:16
Default OK i have solved the problem w
  #9
New Member
 
Pietro Incardona
Join Date: Mar 2009
Posts: 3
Rep Power: 8
ibird is on a distinguished road
OK i have solved the problem with the hostname

now i have the problem with SELinux, if i don' t disable it FoamX don' t work, and i don' t have the item Memory protection into SELinux policy

Any ideas ?
ibird is offline   Reply With Quote

Old   November 18, 2006, 18:19
Default Hello Pietro, Sorry for th
  #10
Senior Member
 
Philippose Rajan
Join Date: Mar 2009
Location: Germany
Posts: 530
Rep Power: 16
philippose will become famous soon enough
Hello Pietro,
Sorry for the delay.... wasnt at home! So... You are using a Fedora Core 4 installation.

In this case, you need to go to SELinux->Modify SELinux Policy -> "Compatibility" , and put a tick next to the option...:

"Allow the use of Shared Libraries with Text Relocation"

But, just to be sure, can you probably give me more information regarding the error message which FoamX puts out before it quits?

Have a nice weekend!

Philippose
philippose is offline   Reply With Quote

Old   November 18, 2006, 20:41
Default Is checked but don' t work
  #11
New Member
 
Pietro Incardona
Join Date: Mar 2009
Posts: 3
Rep Power: 8
ibird is on a distinguished road
Is checked but don' t work

the messages are

Starting NameServer with inet:ibird:1234 ...
Starting FoamX Host Browser with inet:ibird:1234 ...
/*---------------------------------------------------------------------------*\
| ========= | |
| \ / F ield | OpenFOAM: The Open Source CFD Toolbox |
| \ / O peration | Version: 1.3 |
| \ / A nd | Web: http://www.openfoam.org |
| \/ M anipulation | |
\*---------------------------------------------------------------------------*/

Exec : FoamXHostBrowser
Date : Nov 19 2006
Time : 03:44:30
Host : ibird
PID : 13830
Root :
Case :
Nprocs : 1
HostBrowser running.....
Using jar /home/I-BIRD/OpenFOAM/OpenFOAM-1.3/applications/utilities/preProcessing/FoamX/li b/FoamX.jar
Using jar /home/I-BIRD/OpenFOAM/OpenFOAM-1.3/applications/utilities/preProcessing/FoamX/li b/jlfgr-1_0.jar
FoamX.Exceptions.FoamXException: Default name service could not be contacted.
at FoamX.App.initialiseHostBrowser(App.java:512)
at FoamX.App.initialise(App.java:343)
at FoamX.App.main(App.java:186)


then the message box with Default name service could not be contacted is displayed

closing the program

/home/I-BIRD/OpenFOAM/OpenFOAM-1.3/bin/runFoamXHB: line 131: 13830 Killed FoamXHostBrowser -ORBNamingAddr $myIOP
runFoamXHB : cleanup
runFoamXHB: Killing name server nsd(pid 13825).
/home/I-BIRD/OpenFOAM/OpenFOAM-1.3/bin/runFoamXHB: line 66: 13825 Killed nsd -ORBIIOPAddr $myIOP --ior $FOAMX_CONFIG/ns.ref </dev/null


with SELinux disabled work
ibird is offline   Reply With Quote

Old   November 19, 2006, 05:31
Default Hi Pietro, Looks like your
  #12
Senior Member
 
Philippose Rajan
Join Date: Mar 2009
Location: Germany
Posts: 530
Rep Power: 16
philippose will become famous soon enough
Hi Pietro,
Looks like your default SELinux settings are not allowing the FoamX system to start up as it should..

One thing you can try is.... enable SELinux again, and reboot your system (to re-enable all the SELinux policies).

Then... run FoamX. After FoamX quits with the "Unable to contact Name Server" error, login as root in a console.

And then, at the prompt... try:

audit2allow -M local < /var/log/messages

This command looks into your log file, and tries find the different requests which were blocked by SELinux, and creates a set of policies to allow thse requests in the future.

Once the command is run, you need to run the following command:

/usr/sbin/semodule -i local.pp

And then... reboot the computer.

When you run "audit2allow" if it comes up with an error asking you to install the checkpolicy rpm package... use yum to install it using:

yum install checkpolicy

Hope this helps.... I havent tried it myself, but theoretically this should work :-)!

Philippose
philippose is offline   Reply With Quote

Old   November 25, 2006, 19:32
Default Do your Linux distribution use
  #13
Super Moderator
 
Takuya OSHIMA
Join Date: Mar 2009
Location: Niigata City, Japan
Posts: 518
Blog Entries: 1
Rep Power: 11
7islands is on a distinguished road
Do your Linux distribution use nscd (the name service cache daemon) by default? If so make sure nscd is up and running. I got the same 'Default name service could not be contacted' GUI message box when I turned off nscd on SUSE 10.1.
7islands is offline   Reply With Quote

Old   March 10, 2007, 14:30
Default where would i find the nscd op
  #14
New Member
 
Ian Zhang
Join Date: Mar 2009
Location: Illinois, US
Posts: 13
Rep Power: 8
ianz8802 is on a distinguished road
where would i find the nscd option? i use fedora core 6.
ianz8802 is offline   Reply With Quote

Old   March 10, 2007, 21:27
Default I'm not sure because I'm not a
  #15
Super Moderator
 
Takuya OSHIMA
Join Date: Mar 2009
Location: Niigata City, Japan
Posts: 518
Blog Entries: 1
Rep Power: 11
7islands is on a distinguished road
I'm not sure because I'm not a Fedora user... anyone else?
7islands is offline   Reply With Quote

Old   April 15, 2008, 12:37
Default I have the same problem. When
  #16
Senior Member
 
sega's Avatar
 
Sebastian Gatzka
Join Date: Mar 2009
Location: Frankfurt, Germany
Posts: 729
Rep Power: 11
sega is on a distinguished road
I have the same problem.
When starting FoamX there is this message:

A server already seems to be running.
(Detected server reference /home/sega/OpenFOAM/OpenFOAM-1.4.1/.OpenFOAM-1.4.1/apps/FoamX/ns.ref)
Do you want to kill this server? (n)

I cant do anything except typing "n".
Then the message "Default name service could not contacted" is displayed in the FoamX-GUI.

What is the problem?
FoamX was working well until today ...
__________________
Schrödingers wife: "What did you do to the cat? It's half dead!"
sega is offline   Reply With Quote

Old   April 15, 2008, 15:10
Default Sebastian, It sounds like
  #17
Member
 
Graeme Cottrell
Join Date: Mar 2009
Posts: 30
Rep Power: 8
platopus is on a distinguished road
Sebastian,

It sounds like the name server isn't responding to requests.

Try

killall -w -9 nsd

in a shell session, then try to run FoamX again.


Regards, Graeme.
platopus is offline   Reply With Quote

Old   April 15, 2008, 15:19
Default Sebastian, Perhaps that sho
  #18
Member
 
Graeme Cottrell
Join Date: Mar 2009
Posts: 30
Rep Power: 8
platopus is on a distinguished road
Sebastian,

Perhaps that should be

killall -w -s SIGKILL nsd

or

killall -w -s 9 nsd


Regards, Graeme.
platopus is offline   Reply With Quote

Old   April 15, 2008, 15:36
Default Sebastian, on a closer read
  #19
Member
 
Graeme Cottrell
Join Date: Mar 2009
Posts: 30
Rep Power: 8
platopus is on a distinguished road
Sebastian,

on a closer reading of the man pages, I was right the first time, and the first option in my second message here was okay too. The second option in my second email might not work.

You might ask why you are getting this error in the first place, and why FoamX won't kill nsd for you.

The answer is that a normal kill uses the SIGTERM signal (15), which can be blocked. There are a couple of signals which cannot be blocked, and this SIGKILL, number 9, is one of them.

Which makes me think that perhaps this isn't your problem. When you say "I cant do anything except typing "n"." do you mean that you don't get any further if you type 'y'? What happens, exactly?


Regards, Graeme.
platopus is offline   Reply With Quote

Old   April 15, 2008, 16:35
Default Well, I could solve this probl
  #20
Senior Member
 
sega's Avatar
 
Sebastian Gatzka
Join Date: Mar 2009
Location: Frankfurt, Germany
Posts: 729
Rep Power: 11
sega is on a distinguished road
Well, I could solve this problem by deleting (renaming) the /home/sega/OpenFOAM/OpenFOAM-1.4.1/.OpenFOAM-1.4.1/apps/FoamX/ns.ref file.

Now everything is running as usual.

When I was typing "y" the program was simply quitting.
__________________
Schrödingers wife: "What did you do to the cat? It's half dead!"
sega is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
An Open Source mesh generator for Open Foam Ahmed Main CFD Forum 15 September 23, 2010 18:39
FoamX refuses to open an interFoam tutorial case vrecha OpenFOAM Pre-Processing 5 March 12, 2008 13:36
A problme to write data file with Tecplot Kai Yan Tecplot 4 October 30, 2007 14:44
FoamX ianz8802 OpenFOAM Installation 2 March 9, 2007 00:45
problem in running FoamX in Open FOAM Gaurav Main CFD Forum 3 May 10, 2006 05:06


All times are GMT -4. The time now is 20:46.