CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

Starting FoamX error

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   May 16, 2007, 03:38
Default Dear All... I have recently
  #1
Senior Member
 
Join Date: Mar 2009
Posts: 248
Rep Power: 9
jaswi is on a distinguished road
Dear All...

I have recently installed the OpenFOAM on my SUSE 10.2 32 bit. Everything works well except the GUI of FoamX. I have posted the screen dump below...

I have searched the forum for a similar error but cudn't find any clue. The error doesn't lists any missing libraries or so...

With Best Regards
Jaswi

jazz@linux-x9oh:~> FoamX
Starting NameServer with inet:linux-x9oh:1234 ...
Starting FoamX Host Browser with inet:linux-x9oh:1234 ...
/*---------------------------------------------------------------------------*\
| ========= | |
| \ / F ield | OpenFOAM: The Open Source CFD Toolbox |
| \ / O peration | Version: 1.4 |
| \ / A nd | Web: http://www.openfoam.org |
| \/ M anipulation | |
\*---------------------------------------------------------------------------*/

Exec : FoamXHostBrowser
Date : May 16 2007
Time : 09:32:19
Host : linux-x9oh
PID : 21645
Root :
Case :
Nprocs : 1
HostBrowser running.....
Setting LANG to en_EN
Using jar /home/jazz/OpenFOAM/OpenFOAM-1.4/applications/utilities/preProcessing/FoamX/lib/ FoamX.jar
Using jar /home/jazz/OpenFOAM/OpenFOAM-1.4/applications/utilities/preProcessing/FoamX/lib/ jlfgr-1_0.jar
Exception in thread "main" java.lang.InternalError: Can't find supported visual
at sun.awt.X11GraphicsEnvironment.initDisplay(Native Method)
at sun.awt.X11GraphicsEnvironment.<clinit>(X11Graphic sEnvironment.java:134)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:141)
at java.awt.GraphicsEnvironment.getLocalGraphicsEnvir onment(GraphicsEnvironment.jav a:62)
at java.awt.Window.init(Window.java:231)
at java.awt.Window.<init>(Window.java:275)
at java.awt.Frame.<init>(Frame.java:401)
at java.awt.Frame.<init>(Frame.java:366)
at javax.swing.JFrame.<init>(JFrame.java:154)
at FoamX.App.<init>(App.java:196)
at FoamX.App.main(App.java:184)
/home/jazz/OpenFOAM/OpenFOAM-1.4/bin/runFoamXHB: line 139: 21645 Killed FoamXHostBrowser -ORBNamingAddr $myIOP
runFoamXHB : cleanup
runFoamXHB: Killing name server nsd(pid 21641).
/home/jazz/OpenFOAM/OpenFOAM-1.4/bin/runFoamXHB: line 66: 21641 Killed nsd -ORBIIOPAddr $myIOP --ior $FOAMX_CONFIG/ns.ref </dev/null
jaswi is offline   Reply With Quote

Old   May 21, 2007, 09:30
Default Hi, I am using Suse 10.1 . U
  #2
New Member
 
barefoot
Join Date: Mar 2009
Posts: 1
Rep Power: 0
barefoot is on a distinguished road
Hi,
I am using Suse 10.1 . Upon using the command FoamX, I get the following message

--------

Starting NameServer with inet:dhcp076:1234 ...
uncaught MICO exception: IDL:omg.org/CORBA/INITIALIZE:1.0 (0, not-completed)
/home/barefoot/OpenFOAM/OpenFOAM-1.4/bin/runFoamXHB: line 135: 8486 Aborted nsd -ORBIIOPAddr $myIOP --ior $FOAMX_CONFIG/ns.ref </dev/null

--------

Please help.
barefoot is offline   Reply With Quote

Old   May 25, 2007, 05:27
Default Iam having the following probl
  #3
Senior Member
 
Suresh kumar Kannan
Join Date: Mar 2009
Location: Luxembourg, Luxembourg, Luxembourg
Posts: 129
Rep Power: 8
kumar is on a distinguished road
Iam having the following problem and I will appreciate very much your Help. Please tell what Iam doing wrong. The situation is the following.
I have a PC with 2 CPU's(AMD,64 bit) and running RedHat 4. I have copied the following files OpenFOAM webside(OpenFOAM-1.4). The files I used are the following:
gcc-4.1.2.linux64.tgz
j2sdk1.4.2_05.linuxAMD64.tgz
OpenFOAM-1.4.General.gtgz
OpenFOAM-1.4.linux64Gcc4DPOpt.gtgz
OpenFOAM-1.4.linux64Gcc4SPOpt.gtgz
paraview-2.4.4.linux64.tgz

I have executed the following command and the output is also given below:

%foamInstallationTest
Executing /home/l_kumar/OpenFOAM/OpenFOAM-1.4/bin/foamInstallationTest:


Checking basic setup...
-------------------------------------------------------------------------------
Shell: bash
Host: pcxxxx
OS: Linux version 2.6.9-22.0.2.ELsmp
User: l_kumar
User_config: /home/l_kumar/.bashrc
Foam_config: /home/l_kumar/.OpenFOAM-1.4/bashrc sourced correctly.
-------------------------------------------------------------------------------


Checking main FOAM env variables...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Crit
-------------------------------------------------------------------------------
$WM_PROJECT_INST_DIR /home/l_kumar/OpenFOAM yes yes
$WM_PROJECT_USER_DIR /home/l_kumar/OpenFOAM/l_kumar-1.4 yes no
$FOAM_JOB_DIR /home/l_kumar/OpenFOAM/jobControl no yes
-------------------------------------------------------------------------------


Checking the FOAM env variables set on the PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$WM_PROJECT_DIR /home/l_kumar/OpenFOAM/OpenFOAM-1.4 yes yes yes

$FOAM_USER_APPBIN ....4/applications/bin/linux64Gcc4DPOpt yes yes no
$FOAM_APPBIN ....4/applications/bin/linux64Gcc4DPOpt yes yes yes
$WM_DIR .../l_kumar/OpenFOAM/OpenFOAM-1.4/wmake yes yes yes
$FOAMX_PATH ...ations/utilities/preProcessing/FoamX yes no yes
$CEI_HOME /usr/local/ensight/CEI no no

$JAVA_PATH ...kumar/OpenFOAM/linux64/j2sdk1.4.2_05 yes yes no
$MICO_ARCH_PATH ...co-2.3.12/platforms/linux64Gcc4DPOpt yes yes yes
$LAM_ARCH_PATH ...lam-7.1.2/platforms/linux64Gcc4DPOpt yes yes yes
$MPICH_ARCH_PATH --------- env variable not set --------- no
-------------------------------------------------------------------------------


Checking the FOAM env variables set on the LD_LIBRARY_PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$FOAM_LIBBIN ...AM/OpenFOAM-1.4/lib/linux64Gcc4DPOpt yes yes yes
$FOAM_USER_LIBBIN ...OAM/l_kumar-1.4/lib/linux64Gcc4DPOpt yes yes no
$LAM_ARCH_PATH ...lam-7.1.2/platforms/linux64Gcc4DPOpt yes yes yes
-------------------------------------------------------------------------------


Software versions
-------------------------------------------------------------------------------
Software Version Location
-------------------------------------------------------------------------------
gcc 4.1.2 /home/l_kumar/OpenFOAM/linux64/gcc-4.1.2-64/bin/gcc
java 1.4.2_05 /home/l_kumar/OpenFOAM/linux64/j2sdk1.4.2_05/bin/java
gzip 1.3.3 /bin/gzip
tar 1.3.3 /bin/tar
icoFoam ...OpenFOAM-1.4/applications/bin/linux64Gcc4DPOpt/icoFoam
-------------------------------------------------------------------------------


Checking file/directory permissions...
-------------------------------------------------------------------------------
File/directory Set Reqd Crit
-------------------------------------------------------------------------------


Checking networking...
-------------------------------------------------------------------------------
Action Result Crit
-------------------------------------------------------------------------------
Pinging_pcxxxx Successful yes
Pinging_localHost Successful yes
Test_rsh: Unsuccessful_connection_refused* yes
Test_ssh: Successful yes
(*) Only one of rsh or ssh is required by the Foam enviroment.

-------------------------------------------------------------------------------

Base configuration ok.

Critical systems ok.

------------------------------------------------------------

Then I ran "runFoamXHB" and got the following output and I got the following processes runnung.

runFoamXHB
Starting NameServer with inet:pcxxxx:6000 ...
Starting FoamX Host Browser with inet:pcxxxx:6000 ...
/*---------------------------------------------------------------------------*\
| ========= | |
| \ / F ield | OpenFOAM: The Open Source CFD Toolbox |
| \ / O peration | Version: 1.4 |
| \ / A nd | Web: http://www.openfoam.org |
| \/ M anipulation | |
\*---------------------------------------------------------------------------*/

Exec : FoamXHostBrowser
Date : May 25 2007
Time : 11:13:16
Host : pcxxxx
PID : 4318
Root :
Case :
Nprocs : 1
HostBrowser running.....

l_kumar 4269 0.0 0.0 52772 1112 pts/10 T 11:13 0:00 /bin/sh /home/l_kumar/OpenFOAM/OpenFOAM-1.4/bin/runFoamXHB
l_kumar 4315 0.0 0.0 37516 4752 pts/10 Tl 11:13 0:00 nsd -ORBIIOPAddr inet:pcxxxx:6000 --ior /home/l_kumar/OpenFOAM/OpenFOAM-1.4/.OpenFOAM-1.4/apps/FoamX/ns.ref
l_kumar 4318 0.1 0.1 55608 10976 pts/10 Tl 11:13 0:00 FoamXHostBrowser -ORBNamingAddr inet:pcxxxx:6000


But when I start FoamX I get the following error:
$ FoamX
Starting NameServer with inet:pcxxxx:6000 ...
Starting FoamX Host Browser with inet:pcxxxx:6000 ...
/*---------------------------------------------------------------------------*\
| ========= | |
| \ / F ield | OpenFOAM: The Open Source CFD Toolbox |
| \ / O peration | Version: 1.4 |
| \ / A nd | Web: http://www.openfoam.org |
| \/ M anipulation | |
\*---------------------------------------------------------------------------*/

Exec : FoamXHostBrowser
Date : May 25 2007
Time : 11:15:14
Host : pcxxxx
PID : 4603
Root :
Case :
Nprocs : 1
HostBrowser running.....
Setting LANG to en_EN
Using jar /home/l_kumar/OpenFOAM/OpenFOAM-1.4/applications/utilities/preProcessing/FoamX/l ib/FoamX.jar
Using jar /home/l_kumar/OpenFOAM/OpenFOAM-1.4/applications/utilities/preProcessing/FoamX/l ib/jlfgr-1_0.jar
Exception in thread "main" java.lang.UnsatisfiedLinkError: /home/l_kumar/OpenFOAM/linux64/j2sdk1.4.2_05/jre/lib/i386/libawt.so: libXp.so.6: cannot open shared object file: No such file or directory
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.jav a:1586)
at java.lang.ClassLoader.loadLibrary(ClassLoader.java :1503)
at java.lang.Runtime.loadLibrary0(Runtime.java:788)
at java.lang.System.loadLibrary(System.java:834)
at sun.security.action.LoadLibraryAction.run(LoadLibr aryAction.java:50)
at java.security.AccessController.doPrivileged(Native Method)
at sun.awt.NativeLibLoader.loadLibraries(NativeLibLoa der.java:38)
at sun.awt.DebugHelper.<clinit>(DebugHelper.java:29)
at java.awt.Component.<clinit>(Component.java:506)
/home/l_kumar/OpenFOAM/OpenFOAM-1.4/bin/runFoamXHB: line 139: 4603 Killed FoamXHostBrowser -ORBNamingAddr $myIOP
runFoamXHB : cleanup
runFoamXHB: Killing name server nsd(pid 4599).


I have one libXp.so.6 file in /usr/X11R6/lib64 directory.I donot know where to look to this problem. /home/l_kumar/OpenFOAM/linux64/j2sdk1.4.2_05/jre/lib/i386/libawt.so
command gived the following output:
linux-gate.so.1 => (0xffffe000)
libmlib_image.so => /home/l_kumar/OpenFOAM/linux64/j2sdk1.4.2_05/jre/lib/i386/libmlib_image.so (0xf7c9d000)
libjvm.so => /home/l_kumar/OpenFOAM/linux64/j2sdk1.4.2_05/jre/lib/i386/server/libjvm.so (0xf767e000)
libXp.so.6 => not found
libXt.so.6 => /usr/X11R6/lib/libXt.so.6 (0xf7610000)
libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0xf7602000)
libXtst.so.6 => /usr/X11R6/lib/libXtst.so.6 (0xf75fd000)
libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0xf7536000)
libm.so.6 => /lib/tls/libm.so.6 (0xf7513000)
libdl.so.2 => /lib/libdl.so.2 (0xf750f000)
libjava.so => /home/l_kumar/OpenFOAM/linux64/j2sdk1.4.2_05/jre/lib/i386/libjava.so (0xf74ec000)
libc.so.6 => /lib/tls/libc.so.6 (0xf73c2000)
libnsl.so.1 => /lib/libnsl.so.1 (0xf73ac000)
libpthread.so.0 => /lib/tls/libpthread.so.0 (0xf739a000)
libSM.so.6 => /usr/X11R6/lib/libSM.so.6 (0xf7392000)
libICE.so.6 => /usr/X11R6/lib/libICE.so.6 (0xf737a000)
/lib/ld-linux.so.2 (0x56555000)
libverify.so => /home/l_kumar/OpenFOAM/linux64/j2sdk1.4.2_05/jre/lib/i386/libverify.so (0xf7367000)

Thanks in advance.



The ldd
kumar is offline   Reply With Quote

Old   May 25, 2007, 07:10
Default Hi ldd! The problem is that
  #4
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,915
Rep Power: 40
gschaider will become famous soon enoughgschaider will become famous soon enough
Hi ldd!

The problem is that your machine is 64 bit and java is 32 bit. Propably you have the 64-bit version of the package libXp installed, but not the 32 bit.

If you have yum configured
yum install libXp.i386
should fix that
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   September 3, 2007, 02:11
Default Hi Everyone I have installed
  #5
kim
New Member
 
Hyung min Kim
Join Date: Mar 2009
Location: Suwon-shi, Kyonggi-Do, Korea
Posts: 14
Rep Power: 8
kim is on a distinguished road
Hi Everyone
I have installed OpenFOAM1.4.1 on Opensuse 10.2.
FoamX is not running on this machine.
When I run FoamX on the machine, the error message comes out as shown below

pius@pintel:~> FoamX
Starting NameServer with inet:pintel:1234 ...
Starting FoamX Host Browser with inet:pintel:1234 ...
/home/pius/OpenFOAM/OpenFOAM-1.4.1/bin/runFoamXHB: line 139: FoamXHostBrowser: command not found
runFoamXHB : cleanup
runFoamXHB: Killing name server nsd(pid 11210).
/home/pius/OpenFOAM/OpenFOAM-1.4.1/bin/runFoamXHB: line 66: 11210 Killed nsd -ORBIIOPAddr $myIOP --ior $FOAMX_CONFIG/ns.ref </dev/null

Please tell me what is the error..

pius
kim is offline   Reply With Quote

Old   September 3, 2007, 04:03
Default /home/pius/OpenFOAM/OpenFOAM-1
  #6
Senior Member
 
Srinath Madhavan (a.k.a pUl|)
Join Date: Mar 2009
Location: Edmonton, AB, Canada
Posts: 700
Rep Power: 12
msrinath80 is on a distinguished road
/home/pius/OpenFOAM/OpenFOAM-1.4.1/bin/runFoamXHB: line 139: FoamXHostBrowser: command not found

FoamX has not been compiled properly. What does the following command return:

which FoamXHostBrowser
msrinath80 is offline   Reply With Quote

Old   September 3, 2007, 07:46
Default It return Nothing If I have
  #7
kim
New Member
 
Hyung min Kim
Join Date: Mar 2009
Location: Suwon-shi, Kyonggi-Do, Korea
Posts: 14
Rep Power: 8
kim is on a distinguished road
It return Nothing

If I have to compile it again, Please tell me the detail procedure.

pius
kim is offline   Reply With Quote

Old   September 3, 2007, 14:00
Default That depends. Did you compile
  #8
Senior Member
 
Srinath Madhavan (a.k.a pUl|)
Join Date: Mar 2009
Location: Edmonton, AB, Canada
Posts: 700
Rep Power: 12
msrinath80 is on a distinguished road
That depends. Did you compile OpenFOAM or install it from the binaries? If you installed from the binaries provided in the OpenCFD web page, then perhaps you did not set it up correctly. Does foamInstallationTest report any Errors?
msrinath80 is offline   Reply With Quote

Old   September 3, 2007, 20:36
Default I have installed from the bina
  #9
kim
New Member
 
Hyung min Kim
Join Date: Mar 2009
Location: Suwon-shi, Kyonggi-Do, Korea
Posts: 14
Rep Power: 8
kim is on a distinguished road
I have installed from the binaries provided in the OpenCFD web page.

it is the report by foamInstallationTest


Executing /home/pius/OpenFOAM/OpenFOAM-1.4.1/bin/foamInstallationTest:


Checking basic setup...
-------------------------------------------------------------------------------
Shell: bash
Host: pintel
OS: Linux version 2.6.18.2-34-bigsmp
User: pius
User_config: /home/pius/.bashrc
Foam_config: /home/pius/.OpenFOAM-1.4.1/bashrc sourced correctly.
-------------------------------------------------------------------------------


Checking main FOAM env variables...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Crit
-------------------------------------------------------------------------------
$WM_PROJECT_INST_DIR /home/pius/OpenFOAM yes yes
$WM_PROJECT_USER_DIR /home/pius/OpenFOAM/pius-1.4.1 yes no
$FOAM_JOB_DIR /home/pius/OpenFOAM/jobControl no yes
-------------------------------------------------------------------------------


Checking the FOAM env variables set on the PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$WM_PROJECT_DIR /home/pius/OpenFOAM/OpenFOAM-1.4.1 yes yes yes

$FOAM_USER_APPBIN ...1.4.1/applications/bin/linuxGccDPOpt yes yes no
$FOAM_APPBIN ...1.4.1/applications/bin/linuxGccDPOpt yes yes yes
$WM_DIR /home/pius/OpenFOAM/OpenFOAM-1.4.1/wmake yes yes yes
$FOAMX_PATH ...ations/utilities/preProcessing/FoamX yes no yes
$CEI_HOME /usr/local/ensight/CEI no no

$JAVA_PATH /home/pius/OpenFOAM/linux/j2sdk1.4.2_05 yes yes no
$MICO_ARCH_PATH .../mico-2.3.12/platforms/linuxGccDPOpt yes yes yes
$LAM_ARCH_PATH --------- env variable not set --------- yes
$MPICH_ARCH_PATH --------- env variable not set --------- no
-------------------------------------------------------------------------------


Checking the FOAM env variables set on the LD_LIBRARY_PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$FOAM_LIBBIN ...OAM/OpenFOAM-1.4.1/lib/linuxGccDPOpt yes yes yes
$FOAM_USER_LIBBIN ...penFOAM/pius-1.4.1/lib/linuxGccDPOpt yes yes no
$LAM_ARCH_PATH --------- env variable not set --------- yes
-------------------------------------------------------------------------------


Software versions
-------------------------------------------------------------------------------
Software Version Location
-------------------------------------------------------------------------------
gcc 4.2.1 /home/pius/OpenFOAM/linux/gcc-4.2.1/bin/gcc
java 1.4.2_05 /home/pius/OpenFOAM/linux/j2sdk1.4.2_05/bin/java
gzip 1.3.5 /usr/bin/gzip
tar 1.3.5 /bin/tar
icoFoam .../OpenFOAM-1.4.1/applications/bin/linuxGccDPOpt/icoFoam
-------------------------------------------------------------------------------


Checking file/directory permissions...
-------------------------------------------------------------------------------
File/directory Set Reqd Crit
-------------------------------------------------------------------------------


Checking networking...
-------------------------------------------------------------------------------
Action Result Crit
-------------------------------------------------------------------------------
Pinging_pintel Successful yes
Pinging_localHost Successful yes
Test_rsh: Unsuccessful_connection_refused* yes
Test_ssh: Successful yes
(*) Only one of rsh or ssh is required by the Foam enviroment.

-------------------------------------------------------------------------------

Base configuration ok.

Critical systems ok.

Is there any something wrong in my installation?

Thank you

pius
kim is offline   Reply With Quote

Old   September 3, 2007, 21:04
Default Something not right with your
  #10
Senior Member
 
Srinath Madhavan (a.k.a pUl|)
Join Date: Mar 2009
Location: Edmonton, AB, Canada
Posts: 700
Rep Power: 12
msrinath80 is on a distinguished road
Something not right with your installation. To fix the FoamX related error, goto ~/OpenFOAM/OpenFOAM-1.4.1/applications/utilities/preProcessing/FoamX

and run ./Allwmake there. That should rebuild FoamXHostBrowser.
msrinath80 is offline   Reply With Quote

Old   October 17, 2007, 16:49
Default Hi OpenFOAM workers, I go
  #11
javier_chantokes
Guest
 
Posts: n/a
Hi OpenFOAM workers,

I got the same problem.
From foamInstallationtest it seems everything works well, but running FoamX I got this:

pcornejo@bachasaurus:~/OpenFOAM/OpenFOAM-1.4.1/applications/utilities/preProcessing/FoamX> FoamX
Starting NameServer with inet:bachasaurus:1234 ...
Starting FoamX Host Browser with inet:bachasaurus:1234 ...
/*---------------------------------------------------------------------------*\
| ========= | |
| \ / F ield | OpenFOAM: The Open Source CFD Toolbox |
| \ / O peration | Version: 1.4.1 |
| \ / A nd | Web: http://www.openfoam.org |
| \/ M anipulation | |
\*---------------------------------------------------------------------------*/

Exec : FoamXHostBrowser
Date : Oct 17 2007
Time : 17:40:22
Host : bachasaurus
PID : 9906
Root :
Case :
Nprocs : 1
HostBrowser running.....
Setting LANG to en_EN
Using jar /home/pcornejo/OpenFOAM/OpenFOAM-1.4.1/applications/utilities/preProcessing/Foam X/lib/FoamX.jar
Using jar /home/pcornejo/OpenFOAM/OpenFOAM-1.4.1/applications/utilities/preProcessing/Foam X/lib/jlfgr-1_0.jar
java: xcb_xlib.c:52: xcb_xlib_unlock: Assertion `c->xlib.lock' failed.
/home/pcornejo/OpenFOAM/OpenFOAM-1.4.1/bin/FoamX: line 244: 9911 Abortado $jdkhome/bin/java -cp "$jars" -DFoamX.SystemPath=$WM_PROJECT_DIR -DFoamX.SystemConfigPath=$FOAMX_CONFIG -DFoamX.UserConfigPath=$FOAMX_CONFIG FoamX.App $orbArgs $args
/home/pcornejo/OpenFOAM/OpenFOAM-1.4.1/bin/runFoamXHB: line 139: 9906 Terminado (killed) FoamXHostBrowser -ORBNamingAddr $myIOP
runFoamXHB : cleanup
runFoamXHB: Killing name server nsd(pid 9900).
/home/pcornejo/OpenFOAM/OpenFOAM-1.4.1/bin/runFoamXHB: line 66: 9900 Terminado (killed) nsd -ORBIIOPAddr $myIOP --ior $FOAMX_CONFIG/ns.ref < /dev/null



hope someone could help me.
  Reply With Quote

Old   January 11, 2008, 06:34
Default I, in my own deviant way and d
  #12
New Member
 
Robin Pitt
Join Date: Mar 2009
Posts: 4
Rep Power: 8
robinp is on a distinguished road
I, in my own deviant way and despite the best advice on the website, am attempting to install the OpenFOAM suite on a server for remote access from other terminals accessing it via an NFS mounted drive. The command line applications appear to be working okay now, but when I try and run foamX I get the same response as Pablo,

java: xcb_xlib.c:52: xcb_xlib_unlock: Assertion 'c->xlib.lock' failed.

And then everything is, as his machine puts it, terminado. Any ideas what's going on?

Robin
robinp is offline   Reply With Quote

Old   January 11, 2008, 07:07
Default Gentlemen, please check this t
  #13
Senior Member
 
Srinath Madhavan (a.k.a pUl|)
Join Date: Mar 2009
Location: Edmonton, AB, Canada
Posts: 700
Rep Power: 12
msrinath80 is on a distinguished road
Gentlemen, please check this thread and see if it solves your problems:

http://www.cfd-online.com/OpenFOAM_D...es/1/6033.html
msrinath80 is offline   Reply With Quote

Old   January 14, 2008, 06:19
Default Aha, yes, the ALLOW_SLOPPY_LOC
  #14
New Member
 
Robin Pitt
Join Date: Mar 2009
Posts: 4
Rep Power: 8
robinp is on a distinguished road
Aha, yes, the ALLOW_SLOPPY_LOCK thing seems to work and I'm not fussy. Thanks very much!

Robin
robinp is offline   Reply With Quote

Old   February 7, 2012, 06:43
Default Error in JAVA_PATH to the JDK installation directory
  #15
hhh
Senior Member
 
kumar
Join Date: Nov 2011
Posts: 115
Rep Power: 5
hhh is on a distinguished road
Dear foamers,
i am kumar,i am working in flapping wing analysis, i use open foam (2.1.0)i try to run Foamx but its shows error like Cannot find JDK at /home/toshiba/OpenFOAM/linux/j2sdk1.4.2_05. Please set JAVA_PATH to the JDK installation directory, i already download and extract this j2sdk1.4.2_05.linux.tgz, please give me idea about this problem.
link:http://oshima.eng.niigata-u.ac.jp/Op...-20070224.html

i follow this link i use binary distribution as i follow the instruction upto third point, okay but i struct only in 4th point it shows error above i mentioned.

Regards,
kumar.
hhh is offline   Reply With Quote

Old   February 7, 2012, 15:53
Default
  #16
Senior Member
 
Wouter van der Meer
Join Date: May 2009
Location: Elahuizen, Netherlands
Posts: 132
Rep Power: 8
wouter is on a distinguished road
hello,
foamX is discontinued as of version 1.4 afaik. You can find more on Wiki

Best regards
Wouter
wouter is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with starting FoamX laker OpenFOAM Installation 2 May 13, 2008 09:34
FoamX starting on Fedora 8 x86_64 and i386 Error nsd ORBIIOPAddr %24myIOP ior %24FOAMX_CONFIGnsref %2360 devnull rationaalinen OpenFOAM Pre-Processing 6 December 2, 2007 12:40
FoamX not starting Javarelated error agrahn OpenFOAM Pre-Processing 5 October 20, 2007 05:33
Java error while starting FoamX erydj OpenFOAM Pre-Processing 2 May 4, 2007 08:53
Java error while starting FoamX cfdengineering OpenFOAM Pre-Processing 16 June 28, 2006 20:02


All times are GMT -4. The time now is 00:27.