CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

Windows Installation BugsComments on Petrbs patch

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   March 28, 2006, 10:41
Default Philippe can you try please to
  #41
Member
 
Petr Vita
Join Date: Mar 2009
Posts: 57
Rep Power: 9
pvita is on a distinguished road
Send a message via MSN to pvita Send a message via Skype™ to pvita
Philippe can you try please to execute command wclean zlib-1.2.1 and then wmake libso zlib-1.2.1 posting here exact output?
pvita is offline   Reply With Quote

Old   March 28, 2006, 16:35
Default Horray!!! Many thanks Petr
  #42
New Member
 
Philippe STRAET
Join Date: Mar 2009
Location: Olne, Belgium
Posts: 9
Rep Power: 9
ceradi is on a distinguished road
Horray!!!

Many thanks Petr and Brooks !

The wclean had a magic effect in my case!

Let me know if you still want the exact output for examinations...

The Allwmake is running while writing this message, I'll see and I suppose it will be OK now...

Thanks again... Bye

Philippe
ceradi is offline   Reply With Quote

Old   March 28, 2006, 16:46
Default Great! I don't think there's
  #43
brooksmoses
Guest
 
Posts: n/a
Great! I don't think there's a need for you to post the exact output, if it worked and produced the right .dll files.

(Speaking of which, it's probably a good idea to delete the erroneous libNULL.dll and libNULL.a files, if you haven't already.)

Let me know when the Allwmake process finishes, and if it seems like everything works, I'll put all the bugfixes in a patch and upload them.

Thanks again for your bug reports and help in debugging this.
  Reply With Quote

Old   March 29, 2006, 04:00
Default Brooks, The Allwmake took a
  #44
New Member
 
Philippe STRAET
Join Date: Mar 2009
Location: Olne, Belgium
Posts: 9
Rep Power: 9
ceradi is on a distinguished road
Brooks,

The Allwmake took approximately 5 hours to finish his job. I've got now 165 .exe files , 46 .a and 46 .dll.

I tested the installation with the cavity tutorial and it work without any problem...

Thanks again for all ..

Philippe
ceradi is offline   Reply With Quote

Old   April 10, 2006, 14:12
Default I have followed the messages h
  #45
ewr
New Member
 
Errol Robinson
Join Date: Mar 2009
Posts: 2
Rep Power: 0
ewr is on a distinguished road
I have followed the messages here and have also successfully implemented OpenFOAM on a windows based system (Windows XP). Thanks for all your work.

I was wondering if anyone had attempted to compile the latest OpenFOAM release (version 1.3) for a cygwin/windows installation?

Thanks
Errol
ewr is offline   Reply With Quote

Old   April 10, 2006, 22:54
Default Errol - You're welcome. Th
  #46
brooksmoses
Guest
 
Posts: n/a
Errol -

You're welcome. Thanks for the report that it works! It's good to know that it's useful and that it's working.

As for OpenFOAM-1.3, you have excellent timing with your question -- I've just finished the port for that and posted it; see the other thread that I started for that.

- Brooks
  Reply With Quote

Old   April 15, 2006, 15:41
Default I am quite new for both cygwin
  #47
New Member
 
Kitchener Wang
Join Date: Mar 2009
Posts: 3
Rep Power: 9
kitchener is on a distinguished road
I am quite new for both cygwin and OpenFOAM. I tried to follow the method described in http://dpdx.net/openfoam-cygwin/ provided by Brooks Moses. I met some problems. Here are what I have done.

1) install Cygwin with default packages plus sed, make, flex, bison, xorg-x11-devel in C:\cygwin.

2)Build a directory called OpenFOAM and downloaded and unpack (tar xzf (filenames)) both OpenFOAM-1.3.cygwin-src-0.5.tar.gz and
gcc-4.1.0.cygwin-OpenFOAM.tar.gz from the website into that directory.

3)Type .bashrc under the directory of /home/wang/OpenFOAM/OpenFOAM-1.3

4)Type Allwmake. Then a lot of errors were reported like "Makefile... ...wmake: command not found"

Could anyone please give me some advices how to fix the problem? Many thanks,

Wang
kitchener is offline   Reply With Quote

Old   April 15, 2006, 23:57
Default One problem with step 2: Yo
  #48
brooksmoses
Guest
 
Posts: n/a
One problem with step 2:

You should not unpack gcc-4.1.0.cygwin-OpenFOAM.tar.gz into the OpenFOAM directory. You should create a directory called "cygwin" inside the OpenFOAM directory, and unpack the gcc-... file into it.

Two problems with step 3:

First, that's the wrong bashrc file; you should use the one under /home/wang/OpenFOAM/OpenFOAM-1.3/.OpenFOAM-1.3/bashrc. (Probably I should make that more clear in the directions.)

Second, just running it as a normal script doesn't do anything -- all the environment variables that it sets go away once the script finishes running. Instead you need to run it with the command "source bashrc".

That should be sufficient to get things working, I hope. Apologies that the installation instructions didn't make this sufficiently clear.
  Reply With Quote

Old   April 16, 2006, 00:20
Default Hi Brooks, thanks for your hel
  #49
New Member
 
Kitchener Wang
Join Date: Mar 2009
Posts: 3
Rep Power: 9
kitchener is on a distinguished road
Hi Brooks, thanks for your help very much. It seems now that things go toward to a right direction in my computer. Thanks,
kitchener is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP NEEDED HOW TO MAP VALUES FROM PATCH OF ONE MESH TO PATCH OF ANOTHER MESH mkraposhin OpenFOAM Running, Solving & CFD 3 September 4, 2011 09:42
INSTALLATION OF 141 naveen OpenFOAM Installation 3 January 30, 2009 05:19
Regarding installation vidyaprakash CD-adapco 0 December 22, 2006 00:03
Installation of 13 grtabor OpenFOAM Installation 14 August 24, 2006 12:43
Windows Installation Petrbs Port Redux Patches and Binary Distribution brooksmoses OpenFOAM Installation 0 February 10, 2006 18:35


All times are GMT -4. The time now is 07:39.