CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

OpenFoam 1.5.x installation

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   March 19, 2009, 05:29
Default OpenFoam 1.5.x installation
  #1
New Member
 
Gareth
Join Date: Mar 2009
Posts: 24
Rep Power: 8
gareth__it_power is on a distinguished road
I need to upgrade from 1.5 to 1.5.x for reasons I won't go into. I have changed the line in the ~/.basrc file to 1.5.x from 1.5, and updated that by typing . $HOME/.bashrc. Then ran ./Allwmake in the OpenFoam/OpenFoam-1.5.x directory. It seemed to work after compiling for a couple of hours, but none of the commands run - eg blockMesh returns 'command not found'. I ran foamIntsallationTest which highlighted ths:

...
Third party software
-------------------------------------------------------------------------------
Software Version Location
-------------------------------------------------------------------------------
gcc 4.3.1 .../OpenFOAM/ThirdParty/gcc-4.3.1/platforms/linux/bin/gcc
gzip 1.3.12 /bin/gzip
tar 1.19 /bin/tar
icoFoam
WARNING: Conflicting installations:
OpenFOAM settings : /home/itpower/OpenFOAM/OpenFOAM-1.5.x/applications/bin/linuxGccDPOpt/icoFoam
current path :
CRITICAL ERROR

The directory /home/itpower/OpenFOAM/OpenFOAM-1.5.x/applications/bin/linuxGccDPOpt/ is empty. Is there an easy fix for this? I am a total beginner and don't understand things like 'sourcing environment variables' or anythnig like that. But I'd be very grateful for any advice please!

Thanks

Gareth
gareth__it_power is offline   Reply With Quote

Old   March 19, 2009, 09:16
Default
  #2
Senior Member
 
dmoroian's Avatar
 
Dragos
Join Date: Mar 2009
Posts: 647
Rep Power: 11
dmoroian is on a distinguished road
Hello Gareth,
It seems that your icoFoam solver didn't get compiled. The cause of this is most likely some failure in compiling some of the openFoam libraries.
My suggestion is to start from the top of OpenFOAM-1.5.x directory and look inside the Allwmake files. There are simple shell commands, that you can copy/paste in an xterm and run them one by one. You will see exactly where the problem lies.

I hope this is useful,
Dragos
dmoroian is offline   Reply With Quote

Old   March 19, 2009, 11:47
Default
  #3
Senior Member
 
Rishi .
Join Date: Mar 2009
Posts: 138
Rep Power: 8
hellorishi is on a distinguished road
Hello Gareth,

I also has a similar error 2 weeks ago. I am trying to recall how I solved this error. I guess I compiled the ThirdParty from Hrv's site http://powerlab.fsb.hr/ped/kturbo/OpenFOAM/release/ and then compiled OF-1.5.x. Then it definately has something to with sourcing files. I guess I used 1.5 while compiliing ThirdParty and 1.5.x while compiliing 1.5.x

sourcing environment is explained in Section 3 of README
http://www.opencfd.co.uk/openfoam/doc/README.html


EITHER if running bash or ksh (if in doubt type echo $SHELL), source the etc/bashrc file by adding the following line to the end of your $HOME/.bashrc file:
  • . $HOME/OpenFOAM/OpenFOAM-<VERSION>/etc/bashrc
Then update the environment variables by sourcing the $HOME/.bashrc file by typing in the terminal:
  • . $HOME/.bashrc
OR if running tcsh or csh, source the etc/cshrc file by adding the following line to the end of your $HOME/.cshrc file:
  • source $HOME/OpenFOAM/OpenFOAM-<VERSION>/etc/cshrc
Then update the environment variables by sourcing the $HOME/.cshrc file by typing in the terminal:
  • source $HOME/.cshrc
So my suggestion delete your 1.5.x folder. Compile ThirdParty from Hrv's site. Then compile 1.5.x.

Good luck,
Rishi
hellorishi is offline   Reply With Quote

Old   March 31, 2009, 02:38
Default
  #4
Senior Member
 
ZHOU Bin
Join Date: Mar 2009
Location: Nanjing/Shanghai/Torino, Nanjing/Shanghai/Piemente, China/Italy
Posts: 164
Rep Power: 8
zhoubinwx is on a distinguished road
Send a message via ICQ to zhoubinwx Send a message via MSN to zhoubinwx Send a message via Skype™ to zhoubinwx
Hi Gareth,

When I compile OF1.5.x., I get the same error:

icoFoam
WARNING: Conflicting installations:
OpenFOAM settings : /home/itpower/OpenFOAM/OpenFOAM-1.5.x/applications/bin/linuxGccDPOpt/icoFoam
current path :
CRITICAL ERROR

The directory /home/itpower/OpenFOAM/OpenFOAM-1.5.x/applications/bin/linuxGccDPOpt/ is empty.

I need to think about it.

Bin
zhoubinwx is offline   Reply With Quote

Old   March 31, 2009, 20:56
Default
  #5
New Member
 
Ken Robinson
Join Date: Mar 2009
Posts: 1
Rep Power: 0
woodenanteater is on a distinguished road
Hey guys,

I'm installing 1.5.x and I would just like to add my voice to the chorus of people getting this error. I've tried recompiling the third party folder (using ./Allwmake from the third party directory), and this made no difference. Is it worth trying a clean install using only the 1.5.x files (I assume you don't need the 1.5 stuff there to operate 1.5.x)?

Thanks,

Ken

Edit - I'm running a clean compilation now, with freshly downloaded files, and as it's running I often get the line that OpenFOAM-1.5.x/ wmake/rules/linuxGcc/wmkdep: not found. I've had a look in the directory that this refers to, and wmkdep is in there (I'm not hugely familiar with Ubuntu or linux in general, but it has the same icon as a lot of executeables?). I've tried running it if it is an executeable, and it won't start or anything like that. Does this shed some more light?

Last edited by woodenanteater; March 31, 2009 at 22:33.
woodenanteater is offline   Reply With Quote

Old   April 1, 2009, 03:27
Default
  #6
ngj
Senior Member
 
Niels Gjoel Jacobsen
Join Date: Mar 2009
Location: Rotterdam, The Netherlands
Posts: 1,595
Rep Power: 24
ngj will become famous soon enoughngj will become famous soon enough
Hi Bin

It does indeed sound like none of your applications are compiled. The reason I can come of is that some important parts of your src-directory is not compiled, e.g. libfiniteVolume.so.
Try to "cd ~/OpenFOAM/OpenFOAM-1.5.x/src" and execute "./Allwmake" from there. Then carefully watch whether or not you get any error messages.
Typically when you have been running the binaries from OpenCFD you are not aware, that you are missing some of the essential third party software. This is probably either the C++ header files (found in build-essential) or flex.

Good luck

Niels

P.S. If you add "export WM_NCOMPPROCS=N", where N is the number of processors to your ~/OpenFOAM/OpenFOAM-1.5.x/etc/bashrc file, then the compilation takes place on N processors instead of just one.
ngj is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenFOAM installation Mark Main CFD Forum 2 March 29, 2008 08:45
OpenFoam 14 installation problem gfcoppola OpenFOAM Installation 20 November 2, 2007 14:38
Installation OpenFoam on SUSE 101 t42 OpenFOAM Installation 1 August 1, 2007 06:15
Installation OpenFoam on SuSe 101 mephisto OpenFOAM Installation 1 November 8, 2006 03:15
OpenFOAM installation on AIX 53 with gnu 40 compiler chauvin OpenFOAM Installation 3 June 15, 2006 13:12


All times are GMT -4. The time now is 00:33.