CFD Online Logo CFD Online URL
Home > Forums > OpenFOAM Installation

OpenFoam-1.7.0- Installation problems

Register Blogs Members List Search Today's Posts Mark Forums Read

LinkBack Thread Tools Display Modes
Old   July 20, 2010, 05:30
Default OpenFoam-1.7.0- Installation problems
Dynampally Pavitran
Join Date: Mar 2010
Location: India
Posts: 73
Rep Power: 7
pavitran is on a distinguished road
Hello OpenFoam users,

I have downloaded the OpenFoam-1.7.0 & Thirdparty and I sourced the "etc/bashrc" correctly in "$HOME/.bashrc".

After sourcing, I called "echo $WM_PROJECT_DIR", and it pops up correct path.
  1. Then firstly I have executed the ./foamSystemCheck which gave me the below statements
Checking basic system...
Shell: /bin/bash
OS: Linux version 2.6.9-89.0.11.ELsmp
User: bpl

System check: PASS
Continue OpenFOAM installation.


2. Next I have executed ./Allwmake

the problem is that it shows some warning messages and finally once the execution stops, when I call "icoFoam" it pops up showing that
command not found.
  1. I am attaching the Log files of ./Allwmake & ./foamInstallationTest.
  2. The ./foamInstallationTest log file states that gcc version lower than required.
  3. Is that a critical problem.
Attached Files
File Type: txt Allwmake_log.txt (77.3 KB, 5 views)
File Type: txt foamInstallationTest_log.txt (3.5 KB, 7 views)
pavitran is offline   Reply With Quote

Old   July 20, 2010, 05:54
Senior Member
santos's Avatar
Jose Luis Santos
Join Date: Mar 2009
Location: Portugal
Posts: 214
Rep Power: 9
santos is on a distinguished road
Send a message via Skype™ to santos

Your gcc version is very old, update it to (at least) 4.3.1 as suggested in the log file.

Jose Santos
santos is offline   Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Openfoam installation on OpenSuse 11.1 Bufacchi OpenFOAM Installation 1 June 15, 2010 19:55
Problem installing OpenFOAM 1.5 installation on RHEL 4. vwsj84 OpenFOAM Installation 4 April 23, 2009 04:48
New openfoam installation fivos OpenFOAM Installation 5 April 1, 2009 03:58
Installation problems ianz8802 OpenFOAM Installation 37 January 30, 2009 14:20
OpenFOAM Debian packaging current status problems and TODOs oseen OpenFOAM Installation 9 August 26, 2007 13:50

All times are GMT -4. The time now is 01:53.