CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Paraview & paraFoam

Praview fails after starting

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   December 11, 2006, 15:56
Default Hi, When running Paraview for
  #1
mer
Member
 
merrouche djemai
Join Date: Mar 2009
Location: ain-oussera, djelfa, algeria
Posts: 46
Rep Power: 8
mer is on a distinguished road
Hi,
When running Paraview for post-processing and after the case was opened:
by click on accept, the operation aborts with the fellowing message:

/*---------------------------------------------------------------------------*\
| ========= | |
| \ / F ield | OpenFOAM: The Open Source CFD Toolbox |
| \ / O peration | Version: 1.3 |
| \ / A nd | Web: http://www.openfoam.org |
| \/ M anipulation | |
\*---------------------------------------------------------------------------*/



--> FOAM FATAL ERROR : Not implemented

From function void CyclicPointPatchField<patchfield,>::evaluate()
in file /home/dm2/henry/OpenFOAM/OpenFOAM-1.3/src/OpenFOAM/lnInclude/CyclicPointPatchFie ld.C at line 187.

FOAM aborting
/home/mer/OpenFOAM/linux/paraview-2.4.2/lib/paraview-2.4/paraview-real: symbol lookup error: /home/mer/OpenFOAM/OpenFOAM-1.3/lib/linuxGcc4DPOpt/libOpenFOAM.so: undefined symbol: cplus_demangle


My system is Fedora Core 5.
Any Help?

Djemai
mer is offline   Reply With Quote

Old   December 11, 2006, 16:20
Default Abstract: Paraview tries to fa
  #2
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,915
Rep Power: 40
gschaider will become famous soon enoughgschaider will become famous soon enough
Abstract: Paraview tries to fail, but it can't do that decently because of the lack of some libraries.

It has been written elsewhere on the board that in for cyclic BCs to be postprocessed correctly the body of the method
void CyclicPointPatchField<patchfield,>::evaluate()
should be commented out because it generates an error message and fails (don't forget to recompile). During the generation of the error message OpenFOAM tries to tell you in which method this happens (that is what the cplus_demangle is for). For some reason the cplus_demangle is not found in one of the libraries that are linked by standard to OpenFOAM (propably because the good people of the Fedora-project moved it elsewhere).
And that is why you are not told what the real problem is.

Consequence: you might not get all the debug-information you are entitled to get if a OpenFOAM-program fails in your installation.

Solution: find out which library has cplus_demangle and add it to the stuff that is linked by standard (somewhere in wmake/rules/yourArchitecture). I can't tell you which library because all my machines are pre-Fedora 5 (Centos which is based on RedhatEnterprise which is based on Fedora 4)

Symptom removal: Comment out the body of the mentioned method (which basically says: "I'm not implemented")and recompile the OpenFOAM-library
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   December 12, 2006, 09:23
Default Hi, I am able to run paraFo
  #3
New Member
 
Alejandro Molina
Join Date: Mar 2009
Posts: 4
Rep Power: 8
amolinao is on a distinguished road
Hi,

I am able to run paraFoam with the "cavity" tutorial case. But when trying the aachenBomb in dieselFoam, paraFoam opens, but after clicking "accept" I get the error below. I am using LINUX x86-64. Any ideas? Thanks, Alejandro

--> FOAM FATAL IO ERROR : keyword walls is undefined in dictionary "/home/amoli nao/OpenFOAM/amolinao-1.3/run/tutorials/dieselFoam/aachenBomb/0/ft::boundaryFiel d"

file: /home/amolinao/OpenFOAM/amolinao-1.3/run/tutorials/dieselFoam/aachenBomb/0 /ft::boundaryField from line 34 to line 34.

From function dictionary::lookupEntry(const word& keyword) const
in file db/dictionary/dictionary.C at line 152.

FOAM exiting
amolinao is offline   Reply With Quote

Old   December 12, 2006, 12:27
Default The field ft in the initial co
  #4
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,915
Rep Power: 40
gschaider will become famous soon enoughgschaider will become famous soon enough
The field ft in the initial conditions doesn't have the required boundary patches defined. As far as I remember it is not need to start the simulaion. Remove aachenbomb/0/ft and you should be fine (or move it somewhere else)
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   December 12, 2006, 15:56
Default Thanks. That solved the probl
  #5
New Member
 
Alejandro Molina
Join Date: Mar 2009
Posts: 4
Rep Power: 8
amolinao is on a distinguished road
Thanks. That solved the problem.
amolinao is offline   Reply With Quote

Old   December 12, 2006, 16:41
Default hi, i got similar trouble w
  #6
New Member
 
ROBBIN
Join Date: Mar 2009
Location: delhi, DELHI, INDIA
Posts: 3
Rep Power: 8
chitkara_robbin is on a distinguished road
hi,

i got similar trouble with caviy case.
plz tell me how to solve the problem,.

i got the errot segmentation fault(core dumped). plz help me to solve the problem



robin
chitkara_robbin is offline   Reply With Quote

Old   December 12, 2006, 18:51
Default Hi Robbin! I don't see how
  #7
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,915
Rep Power: 40
gschaider will become famous soon enoughgschaider will become famous soon enough
Hi Robbin!

I don't see how your problem is similar to the other two mentioned in this thread. Maybe this is because you are not very specifiy about the programs you're using (I suspect it is paraFoam)/how you invoke them/your system/the exact error message.

One tip: segmentation faults with paraFoam are an old favourite on this board. Try searching with "segmentation paraFoam" using AND as the keyword option. If none of the threads you find there solves your problem it should at least give you an idea what to ask/how to ask.
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   December 13, 2006, 11:56
Default Hi Bernhard ; Many thanks. my
  #8
mer
Member
 
merrouche djemai
Join Date: Mar 2009
Location: ain-oussera, djelfa, algeria
Posts: 46
Rep Power: 8
mer is on a distinguished road
Hi Bernhard ;
Many thanks. my problem is solved.

Djemai
mer is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installation test fails henkw OpenFOAM Installation 4 December 2, 2005 12:01
RunFoamX fails jvn OpenFOAM Installation 12 August 11, 2005 11:12
Restart fails, .lck appears John CFX 2 April 29, 2005 09:12
SOR Fails Near Walls Chih-Wei Chiu Main CFD Forum 0 May 9, 2002 01:05
CFX 5.5 fails to start from an interpolation Astrid CFX 7 March 16, 2002 17:20


All times are GMT -4. The time now is 01:54.