CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Paraview & paraFoam

Has anyone had luck with paraFoam on RedHat Enterprise AMD64 platform

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   August 24, 2006, 09:13
Default OpenFOAM and FoamX run fine. B
  #1
sek
Member
 
Sung-Eun Kim
Join Date: Mar 2009
Posts: 76
Rep Power: 8
sek is on a distinguished road
OpenFOAM and FoamX run fine. But paraFoam crashes. Can someone please suggest a workaround?
sek is offline   Reply With Quote

Old   August 24, 2006, 11:21
Default I have paraFoam here running o
  #2
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,915
Rep Power: 40
gschaider will become famous soon enoughgschaider will become famous soon enough
I have paraFoam here running on CentOS 4.3 (which is essentially RHEL) without problems. In my experience it's more difficult to get FoamX to run without problems.

Could you supply us with a more detailed description of the crash?

(One of the main reasons for crashing paraFoams - in my experience - are old paraview installations. But that's really the best guess I can give you)
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   August 24, 2006, 12:17
Default I have Scientific Linux 4.1 an
  #3
Senior Member
 
Srinath Madhavan (a.k.a pUl|)
Join Date: Mar 2009
Location: Edmonton, AB, Canada
Posts: 700
Rep Power: 12
msrinath80 is on a distinguished road
I have Scientific Linux 4.1 and works fine here as well.
msrinath80 is offline   Reply With Quote

Old   August 24, 2006, 16:40
Default Both paraview and paraFoam dow
  #4
sek
Member
 
Sung-Eun Kim
Join Date: Mar 2009
Posts: 76
Rep Power: 8
sek is on a distinguished road
Both paraview and paraFoam downloaded with OpenFOAM 1.3 crash immediately without any error messages after showing the paraview logo in a split of second. It even logs me off!

I tried to recompile paraview, but ran into another problem, which appears to be due to the compatibility issue (gcc 4.1.0 and /usr/bin/ld) discussed somewhere in the message board.
sek is offline   Reply With Quote

Old   August 24, 2006, 17:20
Default That sounds heavy. With "log o
  #5
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,915
Rep Power: 40
gschaider will become famous soon enoughgschaider will become famous soon enough
That sounds heavy. With "log off" you mean that the X-Server crashes?

Some things come to mind (but none of them a solution):
- try the original binary from www.paraview.org (make sure with 'which paraview' that you are using the right one). If that crashes too, the OpenFOAM-paraview isn't guilty.
- have you ever used a OpenGL-application on that machine?

I'd think that the problem is somewhere in the X-Server/OpenGL/GraphicCard-Driver-complex
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   August 25, 2006, 15:01
Default That's right. The X-server cra
  #6
sek
Member
 
Sung-Eun Kim
Join Date: Mar 2009
Posts: 76
Rep Power: 8
sek is on a distinguished road
That's right. The X-server crashes and I need to relogin. The binary downloaded from the paraview website crashes exactly like the one from OpenCFD.
sek is offline   Reply With Quote

Old   August 27, 2006, 16:52
Default Then I'm afraid you'll have to
  #7
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,915
Rep Power: 40
gschaider will become famous soon enoughgschaider will become famous soon enough
Then I'm afraid you'll have to check with the paraview-mailing list.

Just one idea (but I've never tried it, therefor don't know if it works and I can't check due to a lack of a crashing paraview ;) ): starting paraview with (assuming you're using the bash)

nohup >/tmp/paraviews_last_words 2>&1 paraview &

might(!) give you the last output of paraview that usually goes to the terminal (which might(!) show the reason for crashing).
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   August 28, 2006, 14:38
Default Hello Bernhard It indeed giv
  #8
sek
Member
 
Sung-Eun Kim
Join Date: Mar 2009
Posts: 76
Rep Power: 8
sek is on a distinguished road
Hello Bernhard
It indeed gives diagnostics that sounds serious.
Thanks for your suggestion.
================================================

XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
after 4594 requests (4591 known processed) with 0 events remaining.
X connection to :0.0 broken (explicit kill or server shutdown).
sek is offline   Reply With Quote

Old   August 28, 2006, 14:51
Default And glxinfo gives me this.
  #9
sek
Member
 
Sung-Eun Kim
Join Date: Mar 2009
Posts: 76
Rep Power: 8
sek is on a distinguished road
And glxinfo gives me this.

X Error of failed request: BadWindow (invalid Window parameter)
Major opcode of failed request: 146 (NV-GLX)
Minor opcode of failed request: 4 ()
Resource id in failed request: 0x2800002
Serial number of failed request: 22
Current serial number in output stream: 22
name of display: :0.0
sek is offline   Reply With Quote

Old   August 29, 2006, 12:28
Default Hello Bernhard, Thanks for
  #10
sek
Member
 
Sung-Eun Kim
Join Date: Mar 2009
Posts: 76
Rep Power: 8
sek is on a distinguished road
Hello Bernhard,

Thanks for pointing me to the right direction. Your comments help me trouble-shoot the Xterm/OpenGL problem. The grahics card driver turned out to be faulty. Thanks again for your help.
sek is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Compiling OpenFOAM13 on AMD64 with Redhat Enterprise mbeaudoin OpenFOAM Installation 20 June 17, 2008 06:43
Installation of OpenFOAM14 on Redhat Enterprise 14 gtg627e OpenFOAM Installation 2 July 23, 2007 10:37
FoamX libssl problem on redhat enterprise braennstroem OpenFOAM Installation 5 June 21, 2007 09:00
Parafoam on AMD64 frank178 OpenFOAM Installation 1 October 4, 2005 18:35
The AMD64 platform is perfect for CFD! Snorre Heimsund Main CFD Forum 10 September 9, 2003 07:44


All times are GMT -4. The time now is 03:07.