CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Paraview & paraFoam

Both paraview and paraFoam crash on Redhat Linux WS v4 64bit

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   August 17, 2006, 09:45
Default Running either paraview or par
  #1
sek
Member
 
Sung-Eun Kim
Join Date: Mar 2009
Posts: 76
Rep Power: 8
sek is on a distinguished road
Running either paraview or paraFoam crashes immediately after entering the command line. It seems to launch paraview, showing the paraview logo in a split of second. But it crashes instantly and even logs me off! I'll appreciate if anyone can enlighten me with any clue to what's happening and trouble-shooting.
sek is offline   Reply With Quote

Old   August 17, 2006, 09:49
Default I should've said I'm using Ope
  #2
sek
Member
 
Sung-Eun Kim
Join Date: Mar 2009
Posts: 76
Rep Power: 8
sek is on a distinguished road
I should've said I'm using OpenFOAM 1.3 along with paraview 2.4.3.
sek is offline   Reply With Quote

Old   August 17, 2006, 12:14
Default I had a similar problem on ubu
  #3
Senior Member
 
Ziad Boutanios
Join Date: Mar 2009
Location: Montréal, Canada
Posts: 113
Rep Power: 8
ziad is on a distinguished road
I had a similar problem on ubuntu dapper drake 64bit and several versions of paraview. posted but no replies yet. see

http://www.cfd-online.com/OpenFOAM_D...tml?1155406587

It is a resource problem but since there is enough memory (512Mb) I suspect this might be the compiling options of paraview. doesn't seem to be connected to foam since it runs just fine in 64bit, so probably have to recompile...
ziad is offline   Reply With Quote

Old   August 17, 2006, 15:15
Default I tried to rebuild paraview. B
  #4
sek
Member
 
Sung-Eun Kim
Join Date: Mar 2009
Posts: 76
Rep Power: 8
sek is on a distinguished road
I tried to rebuild paraview. But I got the following error while trying to compile. Has anybody seen this before? I don't quite understand why the linker bothers with /usr/lib/libGL.so? I thought it should look for /usr/lib64/libGL.so, as my CMakeCache.txt file says.

[sek@KimS paraview-2.4.4-obj]$ make
-- Found existing Tcl, not rebuilding
-- Found existing Tk, not rebuilding
Linking CXX shared library ../../../bin/libvtkftgl.so
/usr/bin/ld: skipping incompatible /usr/lib/libGL.so when searching for -lGL
/usr/bin/ld: cannot find -lGL
collect2: ld returned 1 exit status
make[2]: *** [bin/libvtkftgl.so.pv2.4] Error 1
make[1]: *** [VTK/Utilities/ftgl/CMakeFiles/vtkftgl.dir/all] Error 2
make: *** [all] Error 2
[sek@KimS paraview-2.4.4-obj]$
sek is offline   Reply With Quote

Old   August 17, 2006, 16:26
Default how about linking /usr/lib/lib
  #5
Senior Member
 
Ziad Boutanios
Join Date: Mar 2009
Location: Montréal, Canada
Posts: 113
Rep Power: 8
ziad is on a distinguished road
how about linking /usr/lib/libGL.so temporarily to /usr/lib64/libGL.so? just for building paraview. you can reset the links after. might solve your problem.
ziad is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Xwindows crash with paraview save srinath OpenFOAM Paraview & paraFoam 1 October 15, 2008 09:37
ParaView crash srinath OpenFOAM Paraview & paraFoam 2 June 1, 2008 19:03
Fluent-AMD-64bit-Linux-Redhat MCB FLUENT 4 January 19, 2007 15:39
Has anyone had luck with paraFoam on RedHat Enterprise AMD64 platform sek OpenFOAM Paraview & paraFoam 9 August 29, 2006 12:28
Redhat Linux/CFX Meri CFX 1 June 1, 2005 05:43


All times are GMT -4. The time now is 21:51.