CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Pre-Processing

Viscous Layers generating defaultFaces

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   July 20, 2015, 08:50
Default Viscous Layers generating defaultFaces
  #1
New Member
 
James F.
Join Date: May 2015
Posts: 24
Rep Power: 2
NoradFirst2 is an unknown quantity at this point
Hi Foamers,

I have a problem with Salome/OpenFoam.

There is a viscous layer in my current mesh and it is generating a problem once I export it to UNV to use it in OpenFoam later: the viscous layer is generating a face which is identified when I export to OpenFoam and create a defaultFace I cannot get rid off.

(I first had this defaultFace poping, I went on paraFoam to see it and it was a face 3mm above my actual wall corresponding to the last viscous layer...)

Does anyone has an idea on how to handle this problem? It never appeared before... Thanks :')

EDIT: The ideasUnvToFoam command is telling me at the end:

Quote:
FOAM Warning: [...] Found 31920 undefined faces in mesh; adding to default patch.
The thing is I cannot find those faces in Salome.

EDIT2: checkMesh is telling me there are two regions in my mesh which is not normal. I should probably try to merge these two regions into one. Somehow...

EDIT3: Everything is fine as long as I remove the viscous layers.
NoradFirst2 is offline   Reply With Quote

Old   July 20, 2015, 09:46
Default
  #2
New Member
 
James F.
Join Date: May 2015
Posts: 24
Rep Power: 2
NoradFirst2 is an unknown quantity at this point
"Solved" my problem by computing the mesh again... It was a bug I guess.
NoradFirst2 is offline   Reply With Quote

Old   July 23, 2015, 05:09
Default
  #3
New Member
 
James F.
Join Date: May 2015
Posts: 24
Rep Power: 2
NoradFirst2 is an unknown quantity at this point
Well, I changed some parameters in my mesh to improve my computation but the problem is coming back and I cannot get ride off it by simply computing the mesh again and again... Any idea to fix my problem properly?
NoradFirst2 is offline   Reply With Quote

Old   February 2, 2016, 06:04
Default
  #4
New Member
 
Christof Schmidt
Join Date: Nov 2015
Posts: 6
Rep Power: 2
cristopf is on a distinguished road
Hi,

I have exactly the same problem. I donīt know how to solve that. Could you find a way to handle it in the meantime?
cristopf is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[ICEM] Prism layers distorted near trailing edge of blade-Unstructured Mesh Rohith Giridhar ANSYS Meshing & Geometry 3 June 29, 2015 17:52
run Doxygen offline anishtain4 OpenFOAM 8 November 27, 2014 10:36
Doxygen documentation Tanay OpenFOAM Installation 9 September 23, 2011 11:40
ParaView and Qt 4.3.5 on Mac OS X 10.6 Adrian OpenFOAM 3 August 8, 2010 03:16
TGRID- Problem in generating Viscous Mesh abhinit FLUENT 3 January 8, 2007 09:48


All times are GMT -4. The time now is 21:28.