CFD Online Logo CFD Online URL
Home > Forums > OpenFOAM Programming & Development

using 1.6-ext libraries in 2.1.1

Register Blogs Members List Search Today's Posts Mark Forums Read

LinkBack Thread Tools Display Modes
Old   July 11, 2013, 08:34
Default using 1.6-ext libraries in 2.1.1
Join Date: Sep 2012
Posts: 60
Rep Power: 5
achyutan is on a distinguished road

I want to use FEM features of 1.6-ext in 2.1.1. So, I tried to copy those directories from 1.6-ext/src into 2.1.1 environment and compile but i got errors.

Note : I have 1.6-ext installed on my m/c and 2.1.1 on cluster (SGE, Rocks 6.0). Also, not able to install 1.6-ext on cluster as it requires old version packages.

The problem seems to be in linking certain files to 2.1.1/src since the underlying structure of these 2 versions seem to be different.
If i copy 1.6-ext/src into 2.1.1 environment (cluster), i need to link all the files to 1.6-ext/src environment but Make/options has -I$(LIB_SRC)/.. which refers to 2.1.1/src.

I know its going to be a difficult task, but i m ready to do it with help from the forum.

achyutan is offline   Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
OF 1.6 ext on Ubuntu 12.10 (64 bit) compilation errors dreamilam OpenFOAM Installation 7 April 21, 2013 05:43
difference in 'make axial mesh' for OF 2.1 & OF 1.6 EXT Rocky4 OpenFOAM Mesh Utilities 0 November 17, 2012 17:48
Solver Compiling error - OF 1.6 ext. raditz OpenFOAM Programming & Development 8 November 4, 2012 10:53
OpenFOAM 1.6 ext - Compilation errors - Fedora 17(32bit) toolpost OpenFOAM Installation 15 September 21, 2012 09:38
installing OF 1.6 ext yhaomin2007 OpenFOAM Installation 3 September 11, 2012 16:52

All times are GMT -4. The time now is 15:24.