CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Programming & Development

Compiling in debug mode

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   February 17, 2010, 10:46
Default Compiling in debug mode
  #1
New Member
 
Marc-Florian Uth
Join Date: Jan 2010
Posts: 10
Rep Power: 6
Marc10 is on a distinguished road
Hi,

Compiling and running OpenFoam hasn't been a problem yet.
Now I am trying to compile OpenFoam in debug-mode.
I changed the compile-option in bashrc to "debug".

Now when I try to compile my solver using wmake it gives me the following error message:

/usr/bin/ld: cannot find -lmeshTools

What am I doing wrong?

Thanks for your help!!

Marc
Marc10 is offline   Reply With Quote

Old   February 17, 2010, 11:13
Default
  #2
Senior Member
 
louisgag's Avatar
 
Louis Gagnon
Join Date: Mar 2009
Location: Québec, QC, Canada
Posts: 169
Rep Power: 7
louisgag is on a distinguished road
Send a message via ICQ to louisgag
libmeshTools was not built.. did you try to rerun Allwmake after the error message?
louisgag is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to compile OF-1.5 in the debug mode? sandy OpenFOAM Running, Solving & CFD 4 July 8, 2009 08:43
Problem when compiling debug version of 141 kar OpenFOAM Installation 0 February 22, 2008 09:59
Compiling OpenFOAM 13 in Debug mode fra76 OpenFOAM Installation 2 April 14, 2006 03:09
Batch mode swapnil CFX 5 November 23, 2002 09:38
Debug mode with UDF ?? Thierry FLUENT 0 November 4, 2002 04:31


All times are GMT -4. The time now is 06:01.